Remote Rig

RRC 1258 Support in English => General discussion forum => Topic started by: VE3ERQ on 2012-05-21, 04:55:38

Title: Updating Firmware
Post by: VE3ERQ on 2012-05-21, 04:55:38
In preparation to update my firmware in my 1258's from v2.41 to the current v2.57, I also updated Setup Manager from v1.10 to v1.13. Everything appeared to go well until I tried to connect to the modem which it wouldn't do. Strangely it did connect if I killed the power to the modem and rebooted it but that's about all it would do.

Am I trying to make to much of a leap in the software versions? Do I need to use an older version of Setup Manager to load the older versions? Do I need to load each version of firmware in succession?

Any thoughts of where I may have messed up??

I used two different laptops, one bootcamped core duo Mac with XP and the other a Core 2 W7 machine. Both behaved the sameway. Previous version of Setup Manager on the Mac worked well before it was scrubbed to load V1.13. The w7 machine was a virgin load of Setup Manager.

Would appreciate any assistance!

Thanks for your help in advance.

Title: Re: Updating Firmware
Post by: Jan (Microbit) on 2012-05-21, 09:48:19
Going directly from 2.41 to 2.57 should be possible. By connecting to the "modem" I assume you mean that the RRC doesn't get connected to the Internet/LAN like it should?

The newest version of Setup Manager should work with all RRC program versions. I don't understand what you mean goes wrong with the Setup Manager?
Title: Re: Updating Firmware
Post by: VE3ERQ on 2012-05-21, 22:05:58
Thanks for the quick reply Jan!
Let me provide some more detail as my choice of words may have not have been descriptive enough.

1 - The modems are not connected to the internet but are on my work bench with the laptop.

2 - The laptop is connected to the modems with the USB cable provided by RR.

3 - SETUP MANAGER appeared to load successfully on my laptops. On the W7 machine, being a new load Manager loaded along with the 5 drivers, on the XP machine, the drivers did not load as I suspect they were still in the machine from v1.10.

4 - Without the USB cable connected to the modem,Manager appeared to function normally.

5 - Connecting the USB cable to the modem causes Manager to clear the info window of the display. (indication of connection disappears)

6 - Leaving the USB cable connected to the modem and interupting the DC supply to the modem, causing a reboot results in the info window of Manager to come alive and give the software version info. It will not though allow a firmware update under the Update tab, as it appears to hang up searching for something even though the new firmware location is available in the window.

7 - The modem used was the control modem. I did not try the other one in fear of corrupting it.

I would appreciate any assistance as I can't see what I may be doing wrong. I never had any programming issues with any of the 4 modems I have until now.

Thanks for your help, greatly appreciated!

Title: Re: Updating Firmware
Post by: Jan (Microbit) on 2012-05-22, 06:45:20
Oh, now I think I understand why I was lost at first! You call the RRC boxes "modems". I never think of them as modems, so I did not understand what you wrote at all, hehe! Back to topic:

On the PC which already had v1.10 of the Setup Manager installed, did you uninstall v1.10 manually prior to installing v1.13?

But since you experience the same behavior on both PCs there must be something strange either with v1.13 or the RRC you used. So far I haven't heard from someone else having this kind of problem, and for me it has worked OK. You could try the other RRC too, by just connecting it and see if you can get soft/hard-ware version you could tell if it behaves alike. It is highly unlikely, almost impossible, that it will be damaged by  that. I will try 2.41 and 1.13 at work too.

Title: Re: Updating Firmware
Post by: Jan (Microbit) on 2012-05-22, 09:11:57
Using Setup Manager v1.13 and RRC 2.41(on hardware 004) works fine for me. I also upgraded to 2.57 from 2.41 and that too worked. Don't now what could cause it to fail in your case. Which hardware version does the RRC have?
Title: Re: Updating Firmware
Post by: VE3ERQ on 2012-05-22, 19:04:51
More info for you Jan ---
I did not remove the previous version of SETUP MANAGER in my XP laptop, my mistake but it does not seem to have affected how it performed.
Using my W7 laptop with the virgin load of v1.13 MANAGER, I observed the following --

1 - With the Control RCC powered and connected to my W7 laptop with the USB cable,when Manager was opened it did not display the Manager window on the laptop screen.Disconnecting the USB cable allowed the Manager window to appear on the laptop screen -- very strange.

2 - With the USB cable still disconnected, the display indicated it had connected but "failed getting SW version" and "failed getting FW/HW version. Failed writing".

3 - Connecting the USB cable to the laptop causes the info window in the Manager display to clear of all information.

4 - Disconnecting the DC power to the RCC brings back the info in the info window of the Manager display.

5 - Repowering the RCC reads the version info as follows-
Firmware v2.41
Bootloader v1.9
Hardware v006

6 - The other 3 tabs appear to function normally until I go to the "FM Update" tab and activate "UPDATE". I then get a warning window "Unhandled exception has occurred ----  Background Worker is busy -----"

7 - Choosing "Continue" in the warning window causes Manager to freeze and become non-responsive.

8 - Un plugging USB cable from laptop closes Manager and makes the window disappear.

9 - I found my desktop XP machine had v1.10 on Manager on it so I tried it. Unlike #1 the SETUP Manager display appeared, but did not read the software versions in the RCC either. When I tried another tab Manager became unresponsive until I pulled the USB cable.

10 - Trying the RCC with my XP laptop and v1.13 of Manager resulted in similar performance to the W7 machine.

The RCC's have been in service for some 8 months using COM 2 as a transparent transport for serial CAT traffic to my remoted Omni07 using HRD without any major problems and were working well before I decide to update the firmware. Could the RCC software be corrupterd in some way and still function using HRD??

Anything I could try next -- I'm totally puzzled!

Title: Re: Updating Firmware
Post by: Jan (Microbit) on 2012-05-23, 08:28:21
Seems to me the only thing in common is the RRC since two PCs with different versions of Setup Manager behaves strange, or did you try the radio RRC too? All the symptoms you describe seem to indicate that the USB connection between the PC and the RRC isn't working properly, giving read and write errors, as well as freezing/timeouts.

You could try to upgrade the firmware via the internal web pages of the RRC's. If that goes well, then try USB again.
Title: Re: Updating Firmware
Post by: VE3ERQ on 2012-05-24, 17:49:36
Haven't done it for so long,--- now I have to figure out how to get into the RRC thru the Ethernet port!

Title: Re: Updating Firmware
Post by: VE3ERQ on 2012-06-09, 18:32:32
Finally managed to update the firmware in the 1258 through the web port and guess what, the USB port now connects with my laptop which it wouldn't do before!!

Go figure!

Thanks for the help!!
Title: Re: Updating Firmware
Post by: Jan (Microbit) on 2012-06-11, 08:58:50
Great!!  ;D