Remote Rig

RRC 1258 Support in English => General discussion forum => Topic started by: dj4mz on 2010-12-21, 09:34:35

Title: Audio stream stalls
Post by: dj4mz on 2010-12-21, 09:34:35
Hi Jan,

unfortunately I have to come back to this topic.

Yesterday after the update I just tested with CW and not with phone. Today when trying to operate on the local UHF relais I recognized that TX audio is sometimes there and sometimes not! If TX audio goes away, then sometimes also RX audio is missing. It returnes after some while and stays available until I again try to transmitt. At that point TX may work or not  ??? It very seldom happens, that even though PTT is pressed the TRX switches back to RX (of course with no RX audio). Looks very much like the SIP stream has been lost.

When this happens I can see RTP timeout time in the Remote RRC going down from 60 step by step until approx. 40 (or even less), then jumping back to 60 and everything works fine again for a few seconds.

Ping round trip time is 30...35ms.

Any hints?

More than ever: NEVER change a running system!

Edit: Looks like it does not really have to do with transmitting or not. Just have been monitoring the RTP timeout value in the Remote RRC. It is normally reading 60, and TX is possible. Suddenly the value starts to decrease and from that point on no TX audio is there. At some point, mostly at values arount 40, it jumps back to 60 and TX audio again is present. After some seconds the value again is decreasing and TX audio disappears.
Title: Re: Audio stream stalls
Post by: Dick,WN3R on 2011-01-03, 20:02:21
When I made the upgrade I was in the shack and I was able to see the status of both units side-by-side using the web-based programming setup.  What I noticed was the ports used for the audio were not the same.  I couldn't figure out if that was something I set or that it was dynamic controlled by the firmware.  Perhaps if you can watch the status of both units at the same time, you might get a clue as to what is happening.

For me, everything is working perfectly from the remote location so far.  That will be the last time, I upgrade a perfectly working system. Hi.

Good luck, 73 Dick, WN3R
Title: Re: Audio stream stalls
Post by: Jan (Microbit) on 2011-01-04, 08:27:37
Which audio ports were different? If it were the "Out" ports then it's normal for them to be different from a session to another.
Title: Re: Audio stream stalls
Post by: dj4mz on 2011-01-04, 12:38:59
Hi Dick,

I haven't been at the remote shack when updating the device but as long as the settings available via the web interface are concerned, I couldn't find any differences. We already have had a discussion about changing ports in another thread. Also there, only the "out" ports have been changing, which is not a problem.

Jan, I have exported settings for both local and remote RRC. So if you are looking into this issue and the settings can be helpful, just let me know.

BTW: I'm back to V2.06. The downgrade caused even much more trouble but for now I looks like it is stabe again.

vy 73
Simon, DJ4MZ
Title: Re: Audio stream stalls
Post by: Jan (Microbit) on 2011-01-04, 14:32:25
Life (as a software developer) would be a piece of cake if every bug was spotted and fixed immediately while working on new things. This issue you Simon(and a few others) have run into is what makes life less easy, but definitely more challenging ;)

I can understand that you went back to the "safety of old good" 2.06, though from our point of view it makes tracking down what happens harder as issues like this often need as much information as possible in order to be able the find the cause.

From the description of how it behaves it looks like the RTP(audio) stream simply "pauses" for X secs and then magically resume its operation. How often did it happen for you Simon? Were you able to start a session and just wait for a while and "voila" there it was? Or were there sessions which worked just fine?

Title: Re: Audio stream stalls
Post by: dj4mz on 2011-01-07, 19:40:52
Hi Jan,

I can totally understand that such bugs can not be fixed in the blink of an eye! I also understand that the fact that this problem only occurs at some installations makes it even less easy to find. As far as I was concerned I simply had to "change" something because if was absolutely impossible to work any phone mode due to the constantly disappearing TX audio.

So to answer your question: No there were no sessions where it worked! The behaviour was just like described in my first post (in the edit). An with "after some seconds" I really mean after some (i.e. approx. 10) seconds.

vy 73
Simon, DJ4MZ
Title: Re: Audio stream stalls
Post by: k7cf on 2011-01-13, 21:24:10
I had a similar problem. The stream went "off" no sound every 25 seconds for a 2 second period. I looked at the Internet and DSL light on the QWEST modem and it was brighter during the 2 second period so it appeared there was polling coming down the internet to the modem/router.
I checked my speed of the broadband and it was down to one fifth the rated speed I was paying for. I called the ISP provider, QWEST, they reset the port on my server and the speed came up to normal, increasing 500 per cent and the steam became continuous, and no more "off" times of the TS480 stream from the remote.
So, check the speed of the internet at the control end and probably the remote end. In this case, the slow speed was at the control end.