Remote Rig

RRC 1258 Support in English => Configuration, RRC 1258 => Topic started by: vk3bia on 2018-11-11, 10:34:36

Title: configure the remote rig ddns fails, but I but get error 12.
Post by: vk3bia on 2018-11-11, 10:34:36

I have had the remote rig pair running on a local lan for a few years but now I wish to connect the radio to the remoterig ddns server but it fails and shows error code 12 on the status page, I upgraded from v2.78 to the current firmware with no effect.

I think error code 12 means it has communicated with the ddns server but not received the correct response?

From the webbrowser: returns my Current IP Address: with my ip correct. returns: hostname not found.

The RRC has full access to port 80. Even with port 80 fully forwarded to enable access to the RRC from outside the ddns fails.
The RRC is configured with static ip, valid gateway and dns settings.

I saw on this forum somewhere that a software ddns updater that allows sever configuration will work with the remoterig ddns server using the login details created in the RRC for ddnd.remoterig.
The only updater I could find that was freely configurable was ddnsupdate from

This updater allows a log file to be kept. It also allows configuring of the external ip check url, this failed with remoterig ddns server but if you leave the input box empty it will use a default ip check url, I saw it used which returned the correct ip.

The updater is using for the IPv4 update url.

This log entry below  shows its checked the current ip and detected an ip change then "successfully" updated ddns.remoterig with the new IP. Next cycle in 10 minutes it checks the ip is the same and so does nothing more.

However the RRC hostname is still not found on ddns.remoterig  which seems to indicate neither the RRC or the updater program have successfully updated the server,not even once.

To me this above indicates that both the RRC ddns update and the ddnsupdater program on the pc are having an issue with the ddns.remote rig server, I thought maybe there was a problem with the server but 5 days have gone by with no change?

Can anyone confirm the server is normal and or please shed light on whats wrong here, I have tried to give as much info as possible.

[11/11/2018 8:25:08 AM] Checking external IPv4 address
[11/11/2018 8:25:08 AM]
[11/11/2018 8:25:09 AM]   Current IPv4 address detected as 36.75.120.xx
[11/11/2018 8:25:09 AM] IPv4 address check complete
[11/11/2018 8:25:09 AM] IPv4 changed: != 36.75.120.xx
[11/11/2018 8:25:09 AM] Updating dynamic DNS IPv4 to 36.75.120.xx
[11/11/2018 8:25:09 AM]   Using update URL
[11/11/2018 8:25:09 AM]   Update successful
[11/11/2018 8:25:09 AM] Update complete

[11/11/2018 8:35:08 AM] Checking external IPv4 address
[11/11/2018 8:35:08 AM]
[11/11/2018 8:35:09 AM]   Current IPv4 address detected as 36.75.120.xx
[11/11/2018 8:35:09 AM] IPv4 address check complete

Title: Re: configure the remote rig ddns fails, but I but get error 12.
Post by: dj0qn on 2018-11-11, 17:20:23
Here is the list of error codes:

How are you accessing the RRC's web page from outside, i.e. are you typing in its IP number or what exactly?

I would just turn the RRC's DDNS client off, reboot and then turn it on again. Maybe something got corrupted. There is no
reason whatsoever to use an external updater.

Mitch DJ0QN / K7DX
Title: Re: configure the remote rig ddns fails, but I but get error 12.
Post by: vk3bia on 2018-11-12, 04:01:18
Thanks for the response Mitch.

Yes I had the error code page from searching before. To access the RRC webpage from outside I can use ip or FQDN, the fibre router has the option to use the no-ip ddns service, just using forwarding port 80 to verify the RRC has full access on port 80 while trying to find the problem.

Likewise using the configurable external update program, because apparently they are supposed to work with (same protocols for DDNS) and its got logging it makes a handy tool for fault finding, it it works I can compare its network interactions with ddns.remoterig compared to the RRC.

However as there a 2 inet services available here, ddns from the routers is not viable and normally there is no pc to run clients. The RRC is the obvious but also only option.
Restarting the RRC does not help, even going to site and doing a power up restart does not help.

Also now a small change.
now we have "unknown" for the RRC's ddns status rather than code 12, it also links to further info page as below

Own IP:

Last reply:

rue;bsa.src = url;(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(bsa);}netbro_cache_analytics(requestCfs, function(){});};</script></body></html>

The Own IP: is in the correct country but not the correct IP, calling the page does have the correct ip however.

Concurrent with DDNS IP:, shows no result.

CHK IP: as below indicates the RRC has working DNS server access. currently using googles

IP Lookup Details:

IP Information -

Host name:

Title: Re: configure the remote rig ddns fails, but I but get error 12.
Post by: dj0qn on 2018-11-12, 06:27:33
Hi Harry,

Probably best if Mike at Microbit takes a look, since he developed that function. However, I need
to point out that the DDNS will always show "unknown" for a few minutes after booting the RRC.
You need to be patient and check it after about 15 minutes or so. Perhaps you did that, but I just
wanted to make sure.

Otherwise, I can't see any reason why the update won't work. Of course, there is always the
alternative to load a DDNS from this service, which the RRC also accepts:
When they starting charging a few years ago, Microbit setup their own service, which is causing you problems.

Mitch DJ0QN / K7DX
Title: Re: configure the remote rig ddns fails, but I but get error 12.
Post by: vk3bia on 2018-11-13, 05:22:59
Ok Mitch,

no I was not aware of the up to 15 min delay till it all settles down but I guess its had plenty of time over the last week, but i will wait longer after changing settings.

Yes the 1 week dyndns test offer would have been handy for debugging but I just closed the tab when the credit card request came up. I thought I saw more DDNS options in the web switch somewhere in my searches.

In Telnet it is sending out ### dns response [1] timeout about once a minute but it seems to have a working dns?

### dns response [1] timeout

Title: Re: configure the remote rig ddns fails, but I but get error 12.
Post by: vk3bia on 2018-11-15, 18:15:20
This excerpt below is from telnet to the radio RRC.

Even thought its set to it seems to be looking to dyndns? does return the correct ip but the RRC DDNS  status gives a different IP.

From the device status webpage DDNS info we have:
Own IP:<<<<< different and wrong IP!

from telnet : System, dns

----- DYNAMIC DNS -------
Dynamic DNS check inter : 10
Dynamic DNS host [0/1/2]  : 1
Dynamic DNS host name   :
IP check host name      :
Own host name           :
Username                : rrc1258-6693
Password                : b7irgpia

Hostname : DynDNS: timeout

DynDNS: Checking if external IP has changed.

DynDNS: Checking if external IP has changed.
DynDNS: timeout

How can it be only I have these issues, is my RRC possessed or something?


Title: Re: configure the remote rig ddns fails, but I but get error 12. DHCP bug?
Post by: vk3bia on 2018-11-16, 06:10:27
This has to be a bug which was known in 2014.
The issue was in v2.78 and the current firmware v2.91

The remote rig DDNS works if you use DHCP instead of static IP.

I can not imagine anyone would want to use DHCP with a server device like this, especially when most users have to port forward to the device on a known ip.

To make this work the router must be capable of assigning a MAC address with a fixed IP, not all have this facility.

I have 2 internet connections to the site, fortunately both routers are capable of assigning a MAC address with a fixed IP.

Thanks for your help Mitch, I picked it from your post of 2014.

Title: Re: configure the remote rig ddns fails, but I but get error 12.
Post by: dj0qn on 2018-11-16, 17:34:04
Hi Harry,

Glad you found the problem, I had completely forgotten about that old problem.

I always recommend that even radio RRC's are set to DHCP and then fix the IP number in the router.
The reason is that many routers (such as the popular Fritz!Box in Germany) will not forward ports for
any device that it did not issue an IP address for and this prevents a number of other issues as well,
not to mention this DDNS bug.

Mitch DJ0QN / K7DX
Title: Re: configure the remote rig ddns fails, but I but get error 12.
Post by: sm2o on 2018-11-16, 21:16:41
I still think 99.9% of the users use fixed IP on the Radio-RRC including my self. This is not a Remoterig issue, probably a buggy router

73 de mike
Title: Re: configure the remote rig ddns fails, but I but get error 12.
Post by: vk3bia on 2018-11-27, 06:49:20
Sorry for delay in reply Mitch and Mike, I have not had time to revisit this since your posts.

Interesting both your comments, I will have to investigate further as soon as I get time to revisit the issue, because when using dhcp the DDNS updater worked with it but seemed a bit hit and miss.
 I have grave doubts this is router related in this case, my routers service a lot of devices all with fixed IP with port forwarded and translated external ports. but please let me test further with the RRC before saying more, I reply now to acknowledge your comments from last week.
However port forwarding to the RRC 13000-> 13002, 23, 80 ports all work fine on fixed ip here, just the DDNS updater fails.

To complicate things the government here (Indonesia) block and redirect all offshore DNS lookup ports though local servers to block radical islamic and porn sites etc, any site on the block list gets a dummy IP returned. This might slow down an ip update being retrieved by nslookup but not on the page, however having said that, the No-IP service updated by the 2 fixed IP voip PBX,s here seems almost instant.

Please correct me if I am wrong, I was of the understanding DDNS interaction is all done on HTML port 80, the client finds and gets its current IP from the server, if its different to the clients last recorded IP  it then recontacts the server with an update to the new IP, all on port 80. If so I don't see how the DDNS updater would need port forwarding?

Regards Harry.