Remote Rig

RRC 1258 Support in English => General discussion forum => Topic started by: w3hzz on 2018-11-24, 03:49:05

Title: Missing virtual drivers
Post by: w3hzz on 2018-11-24, 03:49:05
I have an Elecraft Twin setup using a K3 and K3/0 mini. All works well, both at CONTROL and at RADIO sites.

I am unable to establish rig/CAT control on CONTROL side. On the RADIO side I have a serial cable (with keyspan adapter) going from COM1 on RR to the computer and am able to get control.

When I try this same set up CONTROL unit I am unable to get it to work.

On both RADIO and CONTROL sides, I do not see any Microbit Serial drivers. even though I have installed and reinstaled the Setup program several times. The only COM port I see is the Keyspan adapter when it is connected to RR unit. Without adapter, I see no COM ports.

I am on Windows 10 Ver 1803. Could there be an incompatability problem?

Phil, W3HZZ
Title: Re: Missing virtual drivers
Post by: dj0qn on 2018-11-24, 04:34:47

Did you go into the serial settings and change the appropriate COM port's setting
"Use USB Com Port as COMx" to YES?

Mitch DJ0QN / K7DX
Title: Re: Missing virtual drivers
Post by: w3hzz on 2018-11-24, 15:05:26
Yes, under Serial Settings Use USB as COM1 is YES.
Using Mode 7, 9600 Baudrate.
I've taken the serial cable and Keyspan adapter from RADIO unit and put it on CONTROL. The only port I see is COM15 "Keyspan"

Phil, W3HZZ
Title: Re: Missing virtual drivers
Post by: dj0qn on 2018-11-24, 15:38:08
I was trying to figure out what a "Keyspan" adapter is. I assume that this is a USB to serial converter.

In that case, it appears to the RRC as a "real" serial cable. In that case, "Use USB Com Port as COMx"
must be set to NO to make it work.

The virtual serial ports will only appear if you plug a normal USB cable into the RRC's USB port and into
your PC and set "Use USB Com Port as COMx"  to YES when doing so.

Mitch DJ0QN / K7DX
Title: Re: Missing virtual drivers
Post by: w3hzz on 2018-11-24, 18:19:11
Yes the Keyspan is a Serial to USB adapter. I works fine on my RADIO unit.

I have tried in Serial Settings changing "USB COM PORT as COM2" as YES and as NO. Rebooted the Control RR and then plugged in the Keyspan USB Serial Port to CONTROL RR at COM1 on RR and USB on Computer. I only see COM15 "Keyspan USB Serial Port" as connected in the device manager. I am unable to interface logging program (Amateur Contact Log) with computer.

I removed Keyspan and connected a USB cable directly from CONTROL unit to Computer, in serial settings after I changed "USB ComPort as COM1" to YES, rebooted. No ports were found at all in the computer.

I am using a MacBook Pro running Windows 10 under Bootcamp. Although arrangement is similar to the one I am using on RADIO side (MacMini, Bootcamp, Windows 10), perhaps this has something to do with the lack of virtual drivers. I am grasping at straws.

Any ideas appreciated.

Phil, W3HZZ

Title: Re: Missing virtual drivers
Post by: dj0qn on 2018-11-24, 19:19:34

You essentially have two completely different problems:

1) The Keyspan should work in any case if the port is set to NO.

2) Using the USB cable and set to YES does not show the Windows virtual ports

Now onto possible solutions:

1) I theorize that a serial setting somewhere is not correct. Note that the COM1 baud settings in both the radio
and control RRC must be identical and in mode-7, but not necessarily identical to the COM2 setting. Check both RRC's
and also make sure that the K3/0 mini is also set to that same baud rate. To check the mini's baud rate, it must
NOT be connected to the radio side, otherwise you will see the remote radio's menu settings instead.

2) The second one can be tricky. The first question is: did you install the Microbit drivers first using the Microbit Setup
Manager? If you did install them before trying, then try a different USB cable. I have seen several bad USB cables and
recently even a bad USB connector in the RRC (wiggling the cable made it work). If that all is OK and still doesn't work,
then you need to go to and follow the directions there.

Mitch DJ0QN / K7DX
Title: Re: Missing virtual drivers
Post by: w3hzz on 2018-11-24, 22:42:26
I changed the USB cable from CONTROL to computer. Success. Virtual drivers loaded. Computer CAT/logging control of K3/0 now working! Thanks.

I also updated the K3/0-mini firmware, was unable to figure out how to set the baudrate - seems to default to 38.4, but I am guessing that it will find the correct speed. But since I have the USB port working, that is a moot point.

Thanks for your help.

Phil, W3HZZ
Title: Re: Missing virtual drivers/now N1MM+ control
Post by: w3hzz on 2018-11-26, 00:20:25
I spoke too soon. Although the CONTROL RR works great now that I swapped out the USB cable between the CONTROL RR and computer. I am able to use my regular loggin program as well as N1MM+, but the RADIO side isnít working.

Decided to see if I could have the same luck with the RADIO setup. With a USB cable between the RADIO RR and my computer, I saw four new virtual COM ports (COM 22-25). I tried first my everyday logging program, N3FJP, and then N1MM+. Neither would connect with any of the 4 ports. I swapped out the USB cable from the CONTROL RR, just in case the cable was bad. No change.

Then I removed the USB cable and connected a serial cable between COM1 of the RADIO RR and the computer (using a Keyspan Serial USB adapter). I saw one new COM port, in this case COM14. I was able to use the logging program, and to get some functionality with N1MM+, namely I was able to have N1MM track frequency, but when I tried using the function keys to send CW, the TX light on the K3 lights, but I seem not to be sending anything. On the other hand, if I use the paddle, I am able to key the transmitter.

Clearly I have a setting not correct. Why doesnít the USB cable work on the Radio RR? It does on the other side

Why donít I hear a tone when using the function keys with COM1 port connected? Baudrate is 9600. The K3 TX lights, but I am not sure i am sending anything.

Any thoughts appreciated.....

Phil, W3HZZ
Title: Re: Missing virtual drivers
Post by: dj0qn on 2018-11-26, 03:19:04

It is hard to know for sure what the problem is, but here are some tips:

- First of all, what are the serial settings for COM1 on the radio RRC?
- You said that you see four new virtual COM ports (COM 22-25). The only one that is relevant is the one marked COM1.
- I was unable to figure out which chip the Keyspan uses, Prolific or FTDI. The Prolific chip is very flaky and generally can
not be used. One with a FTDI chip will work fine. Remember to set use USB to No if using this cable.
- You wrote in the last posting that the baud rate is 9600, but the previous post you said it was 38.6k. Which is correct?
   This ties back to my first question about the settings. If it is 38.6k, then the software should be set to that, too.

Mitch DJ0QN / K7DX
Title: Re: Missing virtual drivers
Post by: w3hzz on 2018-11-27, 00:16:04
Thanks for your patience....

Serial settings on RadioRRC:
COM1 mode   mode-7
COM1 baudrate   9600
COM1 data bits   8
COM1 stop bits   1
COM1 parity   0-Off
COM1 rts/cts   No
COM1 terminator (hex) 00

COM2 mode   Logical parallel with Com0
COM2 baudrate   38400
COM2 data bits   8
COM2 stop bits   1
COM2 parity   0-Off
COM2 terminator (hex) 0

I have a USB connected to Computer at REMOTE site, I see these ports:
Microbit virtual Comport (COM1)
RRC 1258 Come 0 (COM24)
RRC 1258 COM1 (COM22)
RRC 1258 COM2 (COM 23)
RRC 1258 COMExtra (COM25)
USB Serial Port (COM5)
USB Serial Port (COM4) (These last two are Green Heron rotator and unused)

I am unable to get connectivity with any of these. When I try to connect COM1 with N1MM+, I am told the port is being used by another application. When I try to connect to COM 22-25, nothing happens.

Recall that for the CONTROL setting, with a USB cable to a local computer, I get full rig control and I am able to send CW using the function keys of N1MM. In otherwords, the CONTROL functions perfectly.

On CONTROL, I have same settings as RADIO and USB is Yes. There is no setting on RADIO RR for USB

If I remove the USB cable on RADIO side and connect a serial cable with a Keyspan Serial converter (I have tried two) from RADIO RRC to Computer, I see COM1, COM4&5, and COM17. I am able to connect N1MM+ to COM17 and I am able to get rig control )it shows tuning, I can click and change frequency, etc, but I am unable to send CW through N1MM function keys.

I agree that there must be a setting off, but I am unable to find it. Baudrate for COM1 is set to 9600 for CONTROL and REMOTE. Baudrate for COM2 is 38400 for both CONTROL and REMOTE.

It appears that the Keyspan/TrippLite use FTDI, not prolific, chips.

Thanks again for your thoughts,

Phil, W3HZZ
Title: Re: Missing virtual drivers
Post by: dj0qn on 2018-11-27, 03:52:23
Hi Phil,

Here are my comments:

- Like I said, you don't have to waste your time trying all ports. Only COM22 (COM1) is the one
that should work for CAT, assuming the "USB COM PORT as COM1" is set to YES.

- Where I am puzzled is that you have the radio RRC COM1 set to 9600, but the control RRC COM1
set to 38.6k. As far as I understand, these must be identical, because the radio COM1 is "transmitting"
CAT to the control side COM1. I therefore do not understand why the control CAT works at all, but maybe
my assumption is wrong (Mike, maybe you can comment?). Just to play safe, you may wish to change either
the radio COM1 to 38.6 or the control side to 9600 and see if that solves the problem.

- I think you are getting virtual and "real" serial ports confused from what you wrote. You are only interesting
in using one of two ports, depending upon if you use the USB or Keyspan cable. As above, COM22 would be used
under USB and COM17 (?) would be used with the Keyspan if "USB COM PORT as COM1" is set to NO. What is
referred to as COM1 is the RRC's internal COM1, which would never be the same used by any computer program.
That is why you are told that COM1 is blocked, since it is non-existent.

- I do not know why you can not send CW, however I can tell you that the program must be set to send CW over CAT
for it to work at all. I do not know N1MM and can't tell you more. There is however a work-around: use the Winkeyer
emulation instead. Set N1MM to use Winkeyer with COM25. Make sure that COM3/COMEXTRA in your RRC's serial
settings are set to Winkeyer.

Mitch DJ0QN / K7DX

Title: Re: Missing virtual drivers
Post by: w3hzz on 2018-11-28, 19:02:20
Thanks again, Mitch

COM1 is (and has always been) set to 9600. Sorry if I misled you or made a typo.

Right now I have a Serial cable and Keyspan Serial USB connected between the Radio RRC and Radio computer. That shows up as COM42. I am able to connect with both my logging programs, however, with N1MM+ I am unable to send CW from the program. This is confusing because at the CONTROL RRC, with a USB cable connected to the Control computer, I am able to send CW from N1MM+. At the CONTROL RRC I have USB to COM1 set to YES. 

I have toggled the USB to COM1 to NO at CONTROL and found that at the RADIO RRC, it makes no difference. I still can control the K3 through the logging program at RADIO site.  Do you know if I must use USB for both CONTROL and RADIO or can I have CONTROL RRC using USB at COM1 (set to YES and running USB cable) and run Serial cable at RADIO RRC?

Right now I am thinking my problem lies with my set up of N1MM+. I will search the forum for others' experiences.

Phil, W3HZZ
Title: Re: Missing virtual drivers
Post by: W1UE on 2018-12-01, 20:52:07
Phil- I have the same setup that you do, and I can tell you it works fine.  First off, a tip- ditch the USB cable that goes from the computer to the Control RRC.  I think its just confusing the issue.

Install the USB to serial cable, and make note of that Com port number.  That is the comport number that you will use in N1MM.  Forget all the others.

I have my serial cable going to Com1 of the Control RRC.  I have nothing connected to Com2 of the Control RRC.  The K3/0 is connected to the Control RRC via the TTL cable.

Don't bother with trying to key the K3/0 via the RTS or DTR lines.  I have not had success using it. 

Also keep in mind, if you are looking at the baud rate of the K3/0, you can't have it connected to the Remote unit over the internet.  If you do, you are looking at the baud rate of the K3 at the remote site!

Try it again with the above in mind.  As I said, this setup works fine for me here.  Made 542 QSOs via it during the ARRL 160m contest this weekend so far.

Dennis W1UE