Remote Rig

RRC 1258 Support in English => Configuration, RRC 1258 => Topic started by: ajkatz83 on 2019-11-28, 19:56:43

Title: fail to read reply error with HDR
Post by: ajkatz83 on 2019-11-28, 19:56:43
So I have been using a remote rig for a  long time and always able to figure out the issues with it. Yesterday I bought a SingaLink from Tigertronics, plugged it into the data port of my TS480, and since that time yesterday afternoon, the entire link went down.

I cannot access the radio side remotely or even locally via USB at all. I have checked the radio side RRC, its settings, and nothing is abnormal there at all, yet the remote connectivity comes back saying "failed to read reply." I know it's not this hard seeing when HDR was version 5 I could do it all day long. The local serial connection with radio side RRC concerns me the most, I was right plugged in and none of the virtual COMs that came start it up at all.

Only things that changed were this SignaLink and an error of my netmask being the the gateway for my router.......why this had totaled and brought down the link, I am at a loss now. Yesterday morning I had full control and today, nothing.

So when I head home, nothing but SIP errors now. All ports are forwarded on my router. All cables for panel, mic and serial communications, all as they should be. SignaLink is still connected, which I don't think should make a difference.
Title: Re: fail to read reply error with HDR
Post by: dj0qn on 2019-11-28, 22:36:00
Adding a Signalink has no effect whatsoever on the RRC's and network, so it is a complete

I suggest that you just reboot the network components (routers, etc.) and your RRC's and
everything should (hopefully) work just fine.

I am not sure if you are trying to just use data modes remotely, or also at the radio site. If only
remotely, then it is much easier to install the Singalink on the control side and use it from there
and not in the station. All you do is to go to the control RRC's AUX/MIC and SP jacks and you
are in business.

Mitch DJ0QN / K7DX
Title: Re: fail to read reply error with HDR
Post by: ajkatz83 on 2019-11-29, 08:12:21
Hi Mitch:

You know that makes a lot of sense. Seeing I had everything remotely tied into where I lie, I figured adding the Signalink at the station was where it needed to go. So if I have the Signalink on the control side, I don't understand how the AUX/MIC jack here would work. For the TS480 I need to plug a min 6pin DIn connector to the DATA port and the radio itself is in a remote location, plus could it coexist with a the foot-switch I've used for voice?

It's truly odd that all these network problems suddenly appeared seeing it's worked flawless. However, I have gotten the link up again, by what means I haven't a clue how, but the audio is all choppy coming from the station. I had rebooted all routers and radio RRC at the location, but the audio was always clear and didn't haven't a chop to it. I'm guessing, at the moment, that the audio I'm taking from the Signalink SP out to the radio RRC in is what's wrong, seeing before I had it directly from the ext. SP of the TS480 to radio RRC SP in. Also it's been real sluggish turn on the panel from the TS480, control side, and same with the serial connection to HDR here as well. I messed with the baud rates on both RRC and it doesn't seem to have much effect except to not establish a connection at all, so still wondering what I did so drastically to mess everything up from the pristine condition it was once in.
Title: Re: fail to read reply error with HDR
Post by: dj0qn on 2019-11-29, 18:46:13
I can't answer why your network all of a sudden is acting strange, you are going to have to figure that
out yourself.

I suggest using the process of elimination. The first step is to move the control setup to a different location
and see if the problem still occurs. If it does, then the issue is likely at the radio site, or the other way
around. Once you figure out which side it is on, you can check all network components to figure out which is
the culprit. I have even seen simple network switches go bad.

As for the control side using the Signalink: if you use the Signalink cable designed for the TS-480 microphone
jack, then that will work on the RRC. All modern digital modes just use audio, so you don't need the data jack.
You can do all the digital modes that way except for FSK, but the RRC supports FSK directly without an interface.

Mitch DJ0QN / K7DX

Title: Re: fail to read reply error with HDR
Post by: ajkatz83 on 2019-11-30, 02:06:21
At the moment, the audio has been put back to normal and is working fine, but I have a feeling the TTL cable on my radio may be the colprit, when looking into it, it is passing some audio and the controls there and I may have damaged it. Any ways, I'll see about replacing it and perhaps that will clear up the issues.

With the signalink, I found the cable SLCABRJ4 which is just RJ45 on both ends. I had plugged it into the RRC control and the signalink in back, and the basically didn't respond accordingly. It seemed to have crashed the entire RRC control. Unplugging it brought everything to the state it was before. I am not sure which cable you mean, but this particular I tried does do anything. The only cable made for the signalink for the TS480 has a mini-din on the other end, unless I cut it off and crimp something else in, that's the only way I can see using the AUX/MIC port with the signalink. I'm just curious to know what you mean.   
Title: Re: fail to read reply error with HDR
Post by: dj0qn on 2019-11-30, 06:49:58
When I bought my Signalink years ago, I had a choice between two different cables to use. One went
to the microphone jack and the other to the data jack. In this case, it is the SLCABRJ4, which should
work just fine.

To be able to use the SLCABRJ4 instead of the DIN cable, then of course you need to open up the Signalink
and reprogram the jumpers to match, or use the correct jumper module (SLMODR4K). Did you do that?

Mitch DJ0QN / K7DX
Title: Re: fail to read reply error with HDR
Post by: ajkatz83 on 2019-11-30, 08:34:20
I apologize. I am not thinking clearly and totally forgot about the jump module I had wonder it was messing up. I had the SLMOD6PM in there and just assumed all was well, until I tried a different cable for another setup.

I'll have to retrieve that jumper bundle that came with the signalink and program it by hand. I do have the diagram here and now it makes sense. I was truly under the impression that I was going to have to cut and splice cables and connector pins together make some funky cabling, but now I see what has to be done. I have the diagram for SLUSBRJ4 cable and the layout of what get plugged where. Thank you so much for your help here, I just get confused with all these cables and pin numbers and where everything goes sometimes.
Title: Re: fail to read reply error with HDR
Post by: OH6IH on 2020-04-07, 13:31:11

I trying to get a setup with dongle + Kenwood Control Program ARCP-480 + computer/smartphone/tablet to work digi modes.

Have you any advice how to do it?

I have an USB-soundcard that I intend to use instead of SignalLink.

73 de Alf OH6IH