Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - sm0nzy

Pages: [1]
1
Feature Requests / IC-735 CI-V Support in Nano-I
« on: 2018-01-28, 10:44:35 »
I have an old IC-735 at the remote QTH. The IC-735 use a "dialect" of CI-V that differs from the later implementations Icom did. This is well known and well documented. (If interested, I can explain the difference. But it might be easier to look at any versions of HRD. They support the IC-735 and you can see the difference in the protocoll there)  I do understand if you don't plan to spend time on this old radio but wanted to mention it. 73's de SM0NZY

2
Hårdvara, Kablage, Installationer / COM1-problem
« on: 2014-04-18, 16:08:12 »

Jag har under en tid av 1-2 år använt mina RRC (V6) utan problem. Nu har jag emellertid fått ett problem med COM1 på Radio-RRC. Jag använder den för att styra en UART med lite reläer. Trodde först det var mitt UART-kort som gett upp. Men det var inte så. Testade även annan RS-232 utr. med samma dåliga resultat.  Började misstänka COM1-porten i Radio-RRC och tog fram oscilloscopet. Mätningen ger att jag har anledning att misstänka att RS-232 interfacet på COM1 i Radio-RRC har gått sönder. 

När jag skickar in RS-232 kommandon (bytes) i COM1 på Control-RRC så kommer de ut på COM1 på Radio-RRC men tecknen ser eländiga ut. Stigtiderna (vid 2400 Bd) är så långa att spänningsnivån inte kommer upp som de skall. Det blir därmed inga snygga fyrkantiga pulser utan mer en odefinierad sågtand. Dock kommer de burstvis när jag skickar tecken så överföringen verkar fungera som den skall. Det förefaller som det bara är sista steget med omvandling till RS-232 nivåer som ej fungerar.

Jag vet nu inte hur designen av detta COM1-interface ser ut, men jag vill minnas jag sett liknande fel vid användning AV MAXIM's MAX232 kretsar när dess kondensatorer varit dåliga. De kond. som används till de kretsarna för att skapa RS-232 spänningarna.

- Är det en liknande design här ?
- Finns det schema o placeringsskiss kring dessa delar ?
I fall det är en liknande design och jag kan få info om var dessa kond sitter så kan jag nog byta dem.

Allt annat fungerar som det skall. COM2 rigstyrning, ljud åt bägge håll, PTT, CW...

Tacksam för tips om COM1.

73's de SM0NZY/Patrik


3
Detta är ingen fråga, bara ett tips som jag tänkte att fler kan ha nytta av.

Jag har en RRC-Radio fjärrstyrd över mobilt nätverk av typ Net_1 (CDMA-nätet på 450 MHz). Det går fint, men det går inte att skicka vanliga "ping" genom Net_1 vilket är lite tråkigt om man t.ex vill kolla "ping-tider". Detta antagligen pga att ping skickas via ICMP som tydligen spärras av Net_1.

På siten nedan kan man gratis hämta ett program vid namn CryPing. CryPing körs som command line (DOS-fönstret) och skickar ping via TCP istället för ICMP.
Man skriver bara "CryPing <adress> -p 80" om man har port 80 öppen för TCP trafik till RRC's webgränsnitt vilket de flesta antagligen har. I mitt fall gav detta att jag har 130mS ping tid. Då har jag 12km från QTH till Net_1 siten som kör det äldre D35-modemet med en 4el Yagi vilket i detta fall ger en maximal downlink av ca 2,5 Mbps till siten.  Utöver det har jag sedan en lokal WLAN-sträcka på 100m från byggnaden med Net_1 modemet till garaget där RRC'n är monterad med en WLAN-brygga. Radion är en gammal IC-735 som styrs via HRD över seriekanal i RRC. Fungerar UFB.

http://www.cryer.co.uk/downloads/cryping/index.htm

73's de Patrik

4
Först, tack för en utmärkt produkt. Har som ett semesterprojekt satt upp detta på sommar-QTH utan större svårigheter. På SSB låter det fantastiskt bra. Jag skulle nu även sätta upp det för CW och har då stött på ett litet problem som känns som en bug.

Jag har h/w typ MkII med snr 4920 (ctrl) och 4900 (radio). s/w 2.55.
Radion är en gammal IC-735 som jag styr via CI-V (radio) och COM2 (ctrl) från HRD i lokal-mode. Fungerar ufb. Då 735'an är gammal är möjligheterna att styra den lite begränsade. Det innebär att jag vid CW ej kan köra VOX utan måste sätta den i Tx inför nyckling. Nu har ju Remoterig stöd för detta genom att under keyer settings i RRC-radio sätta "PTT activated by keyer till "Yes". Det fungerar som tänkt. Men bara tills dess jag  börjar köra SSB och trycker in PTT-tangenten på mic'en kopplad till AUX/MIC-ingången. Efter det att jag tryckt in mic'ens PTT-knapp en gång så tycks systemet helt ha glömt bort att jag har satt PTT activated by keyer till "Yes". (Fast det att flaggan tillsynes fortfarande är satt i GUI't för RRC-radio.) Enda sättet att komma ur detta är att toggla parametern (PTT activated by keyer) varefter det fungerar igen. Tills dess jag trycker PTT på micen.
Jag kanske bör nämna att det metod för PTT-styrnig jag använder är via radions 8-poliga mic-kontakt kopplat till MIC/AUX på RC-radio enl. anvisningarna för SSB. Dvs jag använder INTE PTT-styrning via I/O-kontakten. (borde jag göra det ?)
Bug eller har jag missat någon konfig av PTT ?

73's de SM0NZY/Patrik

Pages: [1]