Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - W4AFK

Pages: [1] 2
Thanks :-)

That's what I thought ... it was something simple that I overlooked. I'll connect a RS232 cable


have you connected the cat cable from RRC com2 to the radio ?


The remote 1258 is connected to the radio via the CAT cable.

As noted in my setup: TS-480 control head --> 1258 --> router --> gateway --> WAN --> modem --> 1258 --> TS-480 radio section work fine. I use this every day.

Now are you referring to the other connectors on the RR and radio? After all, there is only one CAT type connector on the front and another LAN/WAN connection on the back. The front one is connected to the radio and the back one to the router.

I do have one of the actual TS-480 radio ports connected to a MFJ ARI-500 so it can manage the attached ALS-600S amplifier. But this has nothing to do with RR Client as it's totally transparent.

Now I am trying to read between the lines so please bare with me ... Are you trying to say that I need another connection from the remote 1258 to the radio portion of the TS-480? Possibly the "DB9 COM2" on the back of the 1258?

This makes sense and it might be what's missing (shame on me) so a simple diagram might help a lot LOL

And yes, the COM port, baud rates, etc. are set as between the 1258.

If I do need that DB9 COM2 then it will be interesting as I have to connect the radio to the ARI-500 so the amplifier can follow the band switching. I need to check to see if it uses the COM port.

Thanks. I'll send you an E-mail ...

So to summarize:

1. Home - Control-head --> 1258 --> router --> Gateway --> ONT (fiber interface) --> [WAN --> DynDNS] --> Cable modem --> 1258 --> works fine  8)

2. Home - RR Client software w/1274A (first version with sound chip) --> router --> Gateway --> ONT (fiber interface) --> [WAN --> DynDNS] --> Cable modem --> 1258 --> doesn't work:-\

3. Office - RR Client software w/1274A (first version with sound chip) --> switch --> modem --> [WAN --> DynDNS] --> Cable modem --> 1258 --> doesn't work:-\

Note that when I tried to use the RR Client I made sure that the two 1258 devices were not connected (TS-480 control head switched to off). However, I do NOT disconnect the base 1258 from the LAN nor do I see any reason to do so as both 1258 devices are not connected to each other. I do use DynDNS but I also tried the direct IP address just in case, and I had the same results.

UPDATE - Tried on a Lenovo Yoga laptop running in Windows 10 x64 and I have the same problem. Must be a configuration issue but I can't seem to figure it out.

I cannot get RR-Client to work.

RR Client (1.9.2) w/1274A interface

- Matched RTP/UDP audio port to what's on the 1258
- Matched RTP/UDP command port to what's on the 1258
- RX jitter size= 4 (same as 1258)
- RX jitter delay = 3 (same as 1258)
- Packet Size = 20 (same as 1258)
- RRC COM 0 and 1 = inactive
- RRC COM 2 = 4- Kenwood, COM2

At this stage I make sure that the TS-480 control head is turned off (not active)

RR Client = Connect
Audio bar flashes GREEN every half second or so, RTP is green and RRC flashes red/green at the same rate as the audio bar.

Accessing the remote 1258 control port I see that Connection Status is "faulty". UDP command status (0) error (which seems right as HRD is not connected)

I start HRD (current and licensed). It's configured as follows:

- Company = Kenwood
- Radio = TS-480
- COM 2 at 9600 bps (as set in the radio and in COM 1 and COM 2 in the 1258) - Note that in the remote 1258 COM 0 is set to 57600. Now just for kicks I tried 57600 on COM 2 and COM 3.
- Flow control / Interface power = CTS unchecked, DTR unchecked, RTS checked (tried all OFF and different configurations)
- Fails w/HRD error message =  "Make sure your radio is switched ON and not in memory mode" <--Also failed reading frequency "0".

Seems like the radio doesn't turn ON.

What I have tried:

- In RR Client COM 0 and COM 1
- In HRD changed from COM 2 to COM 1, and even tried COM 3
- Confirmed that the Virtual COM ports installed with RR Client are OK

I must be missing something very basic here ... what would that be???

Normal setup: Pair of RR-1258 connected to my remote TS-480SAT
- Software   2.86
- Bootloader   1.10
- Compiler   4.6.2
- Build May 28 2015 11:12:06

RR-Client: Current (downloaded). I have the 1274A w/headset. It's recognized on the laptop.

Laptop: Windows 7 Pro x64 (up to date) <-- This is the laptop I use
Internet connection: FTTH (fiber) 1Gbps U/D - Via 802.11AC Wi-Fi I have ~400 Mbps U/D for all these tests

Operating the remote system using the TS-480 control head on my Windows 10 based ham radio computer is fine. It's been working great since day one.

As I will be on a multi-week \business trip and I want to be able to use the laptop + HRD + 1274A + Client to operate my remote station.

General discussion / Re: Problem getting RR Micro to work...
« on: 2015-07-08, 02:54:46 »
Thank you MIke. I was using the port number to manage the remote RR1258MKii. It's not needed for normal use :-)


1. I found an old 2011 post which says that ARCP-480 does not work with virtual COM ports. So I loaded HRD 6.x
2. RR1258 (remote) set COM2 to 9600 8n1
3. In RR Micro, I set COM 2 to mode 4 and virtual port 2
4. In HRD, I set COM2 to 9600 8n1 and Kenwood

It now works... However, it took me quite a while to uncover all of this. I highly suggest that you "sticky" messages that instruct users how to configure RR1258, RR-micro and HRD (or other apps) to work. It would save lots of aggravation.

I lost quite a bit of time trying to get ARCP-480 to work. If SOMEWHERE is was clearly noted that this app does not support virtual ports, it would have been great. These new crop of laptops no longer have COM ports :-)

          I have a pair of RR1258 MKII devices for my remote base (Kenwood TS480SAT) and all is working fine. However, when I finally tried to use RR Micro (I bought the HW interface and downloaded the current software, rev 1.70), I get the error message that “No such host is known”.

          - I followed the instructions from the RR website.
          - Note that I use DynDns w/port forwarding being that my remote cable modem is Dynamic. So I tried the following:
          - <DynDns address>:<port>  (ex. resulting in the error.
          - Then I tried the direct IP (ex. “111.222.333.444:999”) with the same error.

          My dual RR1258 MKII setup which works fine, uses port 5065 for SIP, 11000 for Audio and 12000 for CMD, so I configured RR Micro with the same parameters.

          By the way, my local RR is not connected to the remote RR when I try to use RR Micro.

          I am open to suggestions as I am certain that I missed one small item somewhere :-)

I need some help in setting-up the RR-1274A in order to be able to use a laptop to remotely run my TS-480SAT.

Note that the system is connected via a pair of 1258-MKII devices and the radio works just fine from my home-based TS-480 control-head & RR-1258 combo.

- The TS-480SAT is connected to the radio's 1258-MKII front COM port via a direct DB9 cable

- I installed RR-Micro and it's working fine.

- Three virtual COM ports appear on the Windows XP laptop: COM 1, 2 and 3. All show that they are associated to "Microbit Virtual COM Port"

- Configured RR-Micro to connect to the RR-1258-MKII and it works (bottom green bar 1/3 up, activity LEDs are OK)

- TS-480SAT 's COM port is set to 9600 8,N,1

- Configured RR-Micro on COM 1, mode 4 (Kenwood), COM PORT: 1  (I also tried TERMINATOR to 00 as it's on the RR-Radio box). COM 0 and COM 2 remain inactive

- I connect to the remote MKII and as noted above, RTP is green, RRC flashed w/activity and Speaker is 1/3 green

- I start the Kenwood ACRP-480 application

- Then under the CONTROL | SETUP, I select COM 1 and 9600 BAUD, TX control DTS (also tried PTT) Kenwood Network Command is NOT checked

- When I click on "CON" to connect, the indicator turns yellow then I get a pop-up message "An unknown device is connected to COM 1 or the BAUD rate doesn't match... etc.)

 - I tried different settings but to no avail.

So I need some help... I am certain that the problem is obvious to someone out there :-)

Thanks Mike... as I suspected, I need to access the BRAKE switch (yep... one side is "hot").

By the way, I had planned on leaving the 1216L outside the box as it is being placed in a small "Tupperware type", quasi-sealed enclosure as is the 1216H (a separate one). The main reasons were to keep them accessible and as these are in a garage, I also wanted to keep the "biological" bugs away :-)

OK... I have the 1216L-5 configured but when it was time to connect it to the Ham-IV rotator control (analog), I encountered a dilemma.

The BRAKE release line controlled by switch S3 is NOT available on the rear terminal. The 8 screw terminals on the back are CW (5), CCW (6), PWR (2), GND (1), POT+ (3), POT- (7), Capacitor (4) and Capacitor (8')... 4 & 8 are not connected to the 1216L

I would like to see how those of you who use the Ham-IV rotator connected your 1216L to the control box.

Looking at the schematic, it seems as if I need to open the controller box and solder two wires to the BRAKE switch (S3) and bring them out. This is the only way I can see how we can activate the BRAKE release switch.

Am I missing something here?

Thanks for the info, the 1-W problem is fixed. I have another question but I will start a new topic :-)

Feedback --> The 1216L-5 & Webswitch 1216H work fine thanks to Jan's info. I actually misread the instructions and assumed that I had to scan the 1-W BUS-A. As the rotator and control is not at my home, I could not fully test it but I have enough experience now to wire it up at my remote base on Saturday.

Suggestion --> The 1216L-5 "manual" is spread across many webpages. It would be helpful if we could download the entire manual as one file. I had to print page by page so that I could have something on paper :-)

Thanks Jan... I will have a look tonight when I get back from work  ;)

I need some assistance with my 1216H Webswitch and my 1216L. My goal is to use this to remotely manage a HAM-IV rotator.

At this stage, I have no rotator connected as I am getting familiar on how to configure this at home before a live setup, so my connections are only the Ethernet cable, the USB cable, the DC power (both devices) and the BUS-A 1-wire connection (which is really two wires, “BUS –A” and “0” per the online diagram)

•   Connected +12Vdc to the 1216H

•   Connected the USB cable and configured the 1216H
           I updated the F/W in the 1216H Webswitch to 4.0 (Ham use)

•   I then connected the 1216L to the 1216H per the on-line diagram
      Power in parallel
          1216H #9 “BUS-A” to 1216L 1-W “+“
      1216H #10 “0” to 1216L 1-W “-”

•   When I power the system, the green LED on the 1216L blinks fast then settles @ around 1/second

•   I then connect to the 1216H via my browser (Ethernet cable from router).

•   I followed the instructions regarding “ham mode”, set some rotator controls, etc. BUT it doesn’t work!

•   Problem: When I scan for 1-Wire devices on BUS A, it always says “No Bus-A 1-wire devices found!”
            The 1216H does not seem to see the 1216L-5

So essentially, it seems like the 1216H cannot see the 1216L-5 even though the green LED is flashing at 1/second on the 1216L-5. BUT... On the “System Info” page of the 1216H, it shows "1216L HW >=5, FW 5", which seems to say that it does see the 1216L (which is confusing as it can't find it when scanning BUS-A)

So please help me out here… what am I missing???


Yes there is a restart link on the left of the webpage.

The normal way of updating the remote RRC is via the webinterface

I looks to me that you have not configured your router so you can access the Radio-RRC over internet. You need to forward port 80 to the ip of the Radio-RRC.

port 11000 is normally the audioport and not be accessed from the web browser.

If the radio turns on automatically you have probably set "Auto connect" to yes by mistake, change it back to No

73 de mike

Thanks Mike.!

You were right. The "Auto Connect" was set to "yes". The oddity is that it has been like this since day one and the problem of not being able to shut it down only started to occur recently. In any event, it's fixed!

Noted for port 80 (banging my head on the wall ;-) I forgot to configure the router so I remotely setup the virtual server to port forward to 80 and I am now able to access RR/Radio from home.

As for auto-rebooting, I have ordered an IP based remote power switch which will permit me to power on/off the PSU which feeds the TS-480SAT radio and the RR/Radio.

Status as of this moment:
- Remote radio is working (TX, RX & Control)
- RR/Base and RR/Radio have been updated to the current firmware
- I now have access to the remote RR/Radio via the Internet

My "To Do" list:
- IP based AC power controller has been ordered. This will let me remotely manage up to 8 AC power ports via a web browser.

- Sometimes you need to have someone to tweak you a bit so you can get the desired results ;-)

Pages: [1] 2