Author Topic: Exactly what is wrong!  (Read 18618 times)

dj0qn

  • Hero Member
  • *****
  • Posts: 2012
    • View Profile
    • DJ0QN / K7DX
    • Email
Re: Exactly what is wrong!
« Reply #15 on: 2011-11-25, 16:15:53 »
Thanks, Mike,

I tested the update and now can turn the FT-2000 on using the PC Client and use HRD.

I know this was a work around caused by HRD and not a bug in your firmware, so I really
appreciate that you and your team took the time to resolve this problem.

73,
Mitch DJ0QN / K7DX

w7ao

  • Newbie
  • *
  • Posts: 23
    • View Profile
Re: Exactly what is wrong!
« Reply #16 on: 2011-11-29, 22:27:18 »
I have done a lot of testing of RRC-micro the last few days and I have found the following:
I can connect RRC-micro to my local RRC-1258-Radio box.  With my FT2000 turned on, I can hear the audio A-OK. When I try to connect my CAT using FT2000RC, I get no data from the radio.  Using a RS-232 tester, I never see any RTS signal come from the RRC-1258 box even though I know FT2000RC has made RTS active.  In the PC, I can see the RTS signal using my RS-232 Port Monitor program.  With the radio still on, I try to connect with HRD and get the same results.  HRD can never connect.  I never see any RTS signal from the RRC-1258-Radio box comming from the PC even though HRD said it was active.  I do see a CTS signal comming from the radio. I am using version 1.31 of RRC-micro.  I will try 1.32 tommorrow but I don't expect any change.  The FT-2000 is never going to send data until it sees RTS.

w7ao

  • Newbie
  • *
  • Posts: 23
    • View Profile
Re: Exactly what is wrong!
« Reply #17 on: 2011-11-29, 22:47:00 »
I upgraded my local RRC-1258-Radio box to version 2.47 today.  RRC-micro does NOT turn the FT2000 on when it connects.  In advanced I have it set to "yes."

dj0qn

  • Hero Member
  • *****
  • Posts: 2012
    • View Profile
    • DJ0QN / K7DX
    • Email
Re: Exactly what is wrong!
« Reply #18 on: 2011-11-29, 22:56:59 »
Russ,

I have tested this thoroughly, and it works just fine now. I was reporting this problem for several
months as well. Please explain more how you are making the connection through HRD; you are
not supposed to click on DTR or CTS. Make sure you use COM2 for CAT, either of the ports that
the PC Client installs can be used. You said that you changed the new "Yaesu Power Off" to yes.

73,
Mitch DJ0QN / K7DX


ON4AOI

  • Sr. Member
  • ****
  • Posts: 295
    • View Profile
    • Email
Re: Exactly what is wrong!
« Reply #19 on: 2011-11-30, 12:06:46 »
Mitch,
there was a work around in HRD also if you added a macro for switching on/off
but easier from reoterig ofcoarse

Guy ON4AOI

w7ao

  • Newbie
  • *
  • Posts: 23
    • View Profile
Re: Exactly what is wrong!
« Reply #20 on: 2011-11-30, 17:43:30 »
Hi Mitch, DJ0QN,
That is amazing. Yes, I am using COM2 for the FT2000 CAT.  I installed Version 2.47 yesterday however connecting does not turn my radio on.  I never see any TXD/RXD activity comming from the RCC1258 box to the radio.  I think if I can get the radio to turn on, everything else will start to work.  Also in HRD, I do not have the CTS/RTS boxes checked.

What caused me to start this thread with a rather angry note was the fact that microBit has never told the customer that the RS-232 emulation in RRC client does not emulate the complete RS-232 package.  I had assumed that all signals ie. TXD,RXD,RTS,CTS and DSR were being sent.  It is clear to me now that only TXD and RXD are there.  No wonder they have so much trouble getting most PC CAT programs to work.

I don't know what to try next.  I think I will install RCC client on another computer and see if can get it to turn the radio on.

73--Russ, W7AO

 

dj0qn

  • Hero Member
  • *****
  • Posts: 2012
    • View Profile
    • DJ0QN / K7DX
    • Email
Re: Exactly what is wrong!
« Reply #21 on: 2011-11-30, 17:49:26 »
Ok, Russ, let me know if I can help. We can use Skype and Teamspeak if you
want me to help you out directly. I am GMT +1 (end of next week GMT +7 for
three weeks).

73,
Mitch DJ0QN / K7DX

sm2o

  • Administrator
  • Hero Member
  • *****
  • Posts: 2552
    • View Profile
    • sm2oan
    • Email
Re: Exactly what is wrong!
« Reply #22 on: 2011-11-30, 17:59:27 »
The pwr on/off function has nothing to do with the pc client or setup of HRD.
It's sent when SIP ocnnection is up, independent of the control side. It will send the message even if you use box to box solution. You should use radio mode 4 or 10 and enable the function under advanced settings.

The problem with old PC softwares accepting virtual com ports has nothing to to with if RTS/DTR etc.  is used or not, the problem is on a totally different level.

I assume you have coonected pin 7 and 8 and set jmp 3 in place.

73 de mike

w7ao

  • Newbie
  • *
  • Posts: 23
    • View Profile
Re: Exactly what is wrong!
« Reply #23 on: 2011-11-30, 19:42:30 »
Partial Success!
Yes Mike, I understand how you are doing ON/OFF; however I still can not get the radio to turn on when RCC-Client connects. Yes, I am in mode 4 and I have Yaesu power set to YES in the advanced section.

I reflashed the RRC-1258-Radio box and reinstalled RRC Client in the PC.  Now, if I turn the radio on and then connect RRC-client, I can connect and operate the radio using HRD.  Hooray!!

With the radio off, I can connect RRC-Client and then start FT2000RC.  FT2000RC will turn the radio ON with its ON/OFF button.  RT2000RC will control the radio completely; however FT2000RC never sees any data from the radio.  The PC screen with FT2000RC running never changes but the radio will change mode/bands/frequency and anything else by clicking the buttons on the PC.  SO CLOSE TO PERFECTION!!!

Vy 73
Russ, W7AO

w7ao

  • Newbie
  • *
  • Posts: 23
    • View Profile
Re: Exactly what is wrong!
« Reply #24 on: 2011-12-01, 17:51:54 »
I installed V 2.48 in RRC 1258-Radio today and I still do NOT turn the radio on when RRC-Client connects.  I am using Mode 4.

Russ, W7AO

w7ao

  • Newbie
  • *
  • Posts: 23
    • View Profile
Re: Exactly what is wrong!
« Reply #25 on: 2011-12-01, 18:11:16 »
Now have radio turning on A-Okay when RRC-Client connects.  Had cable disconnected.  Sorry about that.
Russ, W7AO

sm2o

  • Administrator
  • Hero Member
  • *****
  • Posts: 2552
    • View Profile
    • sm2oan
    • Email
Re: Exactly what is wrong!
« Reply #26 on: 2011-12-01, 18:15:37 »
Cables are important some times, even in this wireless world. Good luck

/mike

w7ao

  • Newbie
  • *
  • Posts: 23
    • View Profile
Re: Exactly what is wrong!
« Reply #27 on: 2011-12-02, 16:43:49 »
Mike,
I think you should take another look at the Yaesu ON/OFF fix.  Yesterday, I saw the radio start when RRC-Client connected.  I tryed it two times and it worked and I thought the problem was solved.  When I tried later in the day, the radio would not turn on and has not turned on after many tries last night.  If I change the radio type in HRD to FT-950, as you suggested, the radio comes on every time with I start HRD.  Something not right here.  Today, I will flash my RRC-1258-TWIN box to V2.48 and try in Mode 10.

sm2o

  • Administrator
  • Hero Member
  • *****
  • Posts: 2552
    • View Profile
    • sm2oan
    • Email
Re: Exactly what is wrong!
« Reply #28 on: 2011-12-02, 17:10:16 »
Maybe there is some differences in timing between different FT-2000. Setup portforwarding for port 23 (telnet) and email me the info we need to connect to your Radio-RRC. We will test on Monday when the software guys are at the office.

73 de mike


Jan (Microbit)

  • Software Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1796
    • View Profile
    • Email
Re: Exactly what is wrong!
« Reply #29 on: 2011-12-02, 17:32:44 »
Maybe there is some differences in timing between different FT-2000. Setup portforwarding for port 23 (telnet) and email me the info we need to connect to your Radio-RRC. We will test on Monday when the software guys are at the office.

73 de mike
Some of us are still here  ;)
Always include type of hard/software and version when asking for support.