Author Topic: Web Page Port button  (Read 4017 times)

SM0HXB

  • Newbie
  • *
  • Posts: 26
    • View Profile
    • Email
Web Page Port button
« on: 2012-04-08, 22:31:36 »
HI
I use the Web Page Port 8000, since my router uses port 80.
But I can not save port 8000 in the "RRC settings" in the RRC Micro PC Client ver 1.5.0. Save button is grayed out.
If I change any other values in RRC Settings​​, the save button turns red.

/Göran

dj0qn

  • Hero Member
  • *****
  • Posts: 2012
    • View Profile
    • DJ0QN / K7DX
    • Email
Re: Web Page Port button
« Reply #1 on: 2012-04-08, 22:39:17 »
The web page port has nothing to do with the Micro PC Client. That port is only used
to access the RRC via a web browser, for example: 192.168.0.224:8080.

The Micro PC Client only speaks to the radio RRC through the SIP port, so this is
what you need to put into the software. No TCP port number is necessary, only
use the radio's dynamic DNS or external IP address without a port number (like :8080)
at the end.

73,
Mitch DJ0QN / K7DX

SM0HXB

  • Newbie
  • *
  • Posts: 26
    • View Profile
    • Email
Re: Web Page Port button
« Reply #2 on: 2012-04-09, 08:52:32 »
Hi Mitch
Thanks for the reply.
I have no problem with the remote function.

In version 1.5.0 there is a new button called "Visit RRC Web Page". Default port is set to 80. In PC Client under RRC Settings is a new box, "Web Page Port" where it says port 80. I thought I could change it to the port I use (8000) to access the RRC 1258 web page. But it does not matter, it is just as good to use a bookmark in my web browser.

73
Göran / SM0HXB

roland

  • Guest
Re: Web Page Port button
« Reply #3 on: 2012-04-09, 11:37:36 »
Hi Mitch
Thanks for the reply.
I have no problem with the remote function.

In version 1.5.0 there is a new button called "Visit RRC Web Page". Default port is set to 80. In PC Client under RRC Settings is a new box, "Web Page Port" where it says port 80. I thought I could change it to the port I use (8000) to access the RRC 1258 web page. But it does not matter, it is just as good to use a bookmark in my web browser.

73
Göran / SM0HXB
Hi there. I will check that when I come to office tomorrow. It might be so that I mistakenly forgot to enable the Red Save button when this new port value is changed. I can not test this at the moment but you could give this a try. Change the Web-port value and then change some other value so the Save button goes red. Then click Save.

dj0qn

  • Hero Member
  • *****
  • Posts: 2012
    • View Profile
    • DJ0QN / K7DX
    • Email
Re: Web Page Port button
« Reply #4 on: 2012-04-09, 12:19:37 »
Hi Göran,

You are right, I completely missed this new feature, now I know what you
were writing about.

73,
Mitch DJ0QN / K7DX

roland

  • Guest
Re: Web Page Port button
« Reply #5 on: 2012-04-10, 08:26:45 »
Göran.

Issue confirmed.
This value is mistakenly ignored (even if saved)
The port 80 will always be used.

Will fix this asap.


« Last Edit: 2012-04-10, 08:33:55 by Roland (Microbit) »

roland

  • Guest
Re: Web Page Port button
« Reply #6 on: 2012-04-10, 10:42:23 »
Göran.

Issue confirmed.
This value is mistakenly ignored (even if saved)
The port 80 will always be used.

Will fix this asap.

Fixed in 1.5.1 which now is available for download

SM0HXB

  • Newbie
  • *
  • Posts: 26
    • View Profile
    • Email
Re: Web Page Port button
« Reply #7 on: 2012-04-10, 14:06:43 »
Thanks for the quick fix Roland.

/Göran
« Last Edit: 2012-04-10, 15:29:28 by sm0hxb »