Author Topic: Firmware version 4.0, HOME edition  (Read 12862 times)

Jan (Microbit)

  • Software Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1796
    • View Profile
    • Email
Re: Firmware version 4.0, HOME edition
« Reply #15 on: 2014-03-06, 16:32:28 »
"You've got mail"!  8)
Always include type of hard/software and version when asking for support.

danne

  • Newbie
  • *
  • Posts: 23
    • View Profile
    • Email
Re: Firmware version 4.0, HOME edition
« Reply #16 on: 2014-03-06, 20:44:10 »

danne

  • Newbie
  • *
  • Posts: 23
    • View Profile
    • Email
Re: Firmware version 4.0, HOME edition
« Reply #17 on: 2014-03-11, 07:23:49 »
Jag upplever som att webswitchen startar om då och då med 4.1.
Det gäller flera WS, inte bara en.

Undersökte saken lite mer idag efter att jag hoppade mellan olika ACP.
WS:n slutade att svara och när jag gick in på systeminfo så var uptime på bara några sekunder. Det att websidan har slutat svara har hänt tidigare, men bara då jag haft många ACP aktiva samtidigt.

Även så beter sig några nexa-brytare väldigt skumt. Dom sätts t.ex på utan att vara initierade i en ACP men det har även hänt att en initierad inte går att stänga av via WS.

Jan (Microbit)

  • Software Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1796
    • View Profile
    • Email
Re: Firmware version 4.0, HOME edition
« Reply #18 on: 2014-03-11, 08:35:52 »
Hur ser ditt bruk av remote-WS-biten ut nu? För den saken är ju en helt ny grej så risken för problem är större då. Hur gör du när du "hoppar mellan ACP"? Snabba sidladdningar? Vilket OS och webbläsare använder du?

Nexa-brytarna däremot borde inte vara så stor risk för att de har påverkats negativt i 4:an. Jag har sett sådant beteende om brytaren är så långt från WSen att det nätt och jämnt funkar. Då kan den vara på när den borde vara av och tvärtom. Men du menar att det inte hände med v3?
Always include type of hard/software and version when asking for support.

danne

  • Newbie
  • *
  • Posts: 23
    • View Profile
    • Email
Re: Firmware version 4.0, HOME edition
« Reply #19 on: 2014-03-11, 13:15:07 »
Quote
Hur ser ditt bruk av remote-WS-biten ut nu? För den saken är ju en helt ny grej så risken för problem är större då.
Ingen utgång eller ingång är aktiv i nån ACP. Endast tempgivare och ingångar som skickar sitt tillstånd.

Quote
Hur gör du när du "hoppar mellan ACP"? Snabba sidladdningar? Vilket OS och webbläsare använder du?
Ja, men inte snabbare än man normalt gör när man vet var man ska trycka. W7 & Chrome, osäker på version.

Quote
Nexa-brytarna däremot borde inte vara så stor risk för att de har påverkats negativt i 4:an. Jag har sett sådant beteende om brytaren är så långt från WSen att det nätt och jämnt funkar. Då kan den vara på när den borde vara av och tvärtom. Men du menar att det inte hände med v3?
Ja, i v3. Men bara då på den som var längst bort. Då var jag helt säker på att det var avståndet som var felkällan. Nu i helgen (med 4.1) så satte jag en närmare WSen för att prova on/off puls och toggle funktionen. Det var då jag uppmärksammade att WSen betedde sig jäkligt skumt. Men jag vet inte riktigt om det var ett följdfel av omstarterna (som jag då inte uppmärksammade).

Jag inaktiverade sedan flera ACPer för att göra jobbet lite lättare för WSen. Men upptäckte senare på kvällen och även i morse att två brytare var aktiva trots att dom inte finns med i nått program... WSen hade nyligen bootat om. Det skedde en gång till under morgonen.

Även så har minst en WS bootat om på landet utan inblandning utifrån.



Ska jag vara helt ärlig så vet jag inte om det är sbs eller v4 som strular. Kanske en kombo mellan dom ;)

danne

  • Newbie
  • *
  • Posts: 23
    • View Profile
    • Email
Re: Firmware version 4.0, HOME edition
« Reply #20 on: 2014-03-11, 13:30:55 »
En sak till...

Ett reläs status verkar inte skickas vidare med remote-funktionen.
Prövat både med ACP och manuellt sätta ett relä som saknar ACP.

Jan (Microbit)

  • Software Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1796
    • View Profile
    • Email
Re: Firmware version 4.0, HOME edition
« Reply #21 on: 2014-03-11, 14:09:29 »
Hmm.. Ja vad ska jag säga... Jag kör den versionen hemma med ett flertal ACP, CW, Nexor, etc och den beter sig så långt vettigt. Vad jag inte har haft igång är remote-WS-delen, så jag nu dragit igång det också för att se vad som händer. Jag vet också säkert att Nexa-brytarna inte har betett sig "udda".

Annars är det nog inte antalet ACP som är "betungande" utan mer troligt nätverkskommunikation, t.ex surfande till WSen och nu även remote-WS-biten. Det var därför jag frågade om OS+webbläsare. Det har nämligen förekommit (sporadiska) konstigheter med W8 i allmänhet och IE i synnerhet. Inget dock som vi har kunnat "fånga på bild".

Vad menar du med att "relästatus inte skickas vidare"? Att "mastern" inte lyckas styra en "slavs" relä? För det är bara åt det hållet det fungerar.
Always include type of hard/software and version when asking for support.

danne

  • Newbie
  • *
  • Posts: 23
    • View Profile
    • Email
Re: Firmware version 4.0, HOME edition
« Reply #22 on: 2014-03-11, 14:34:44 »
Nej, under Set Relays så ser man statusen på alla reläer. Även de som är per remote. Dock så får jag inte statusen att uppdatera sig.

Jag ändrar alltså på sändar WSen. Antingen manuellt eller med en ACP. Den skickar inte ut en uppdatering av tillståndet till den WSen som har reläet upplagt som Remote Relay

Jan (Microbit)

  • Software Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1796
    • View Profile
    • Email
Re: Firmware version 4.0, HOME edition
« Reply #23 on: 2014-03-11, 14:41:36 »
Har du skannat "slav-WSen" med det användarnamn och lösenord som krävs för att kunna uppdatera dess relän? (Antar att du har satt användarnamn och lösenord på slav-WSen)
Always include type of hard/software and version when asking for support.

danne

  • Newbie
  • *
  • Posts: 23
    • View Profile
    • Email
Re: Firmware version 4.0, HOME edition
« Reply #24 on: 2014-03-11, 14:55:13 »
Ja, det har jag gjort.

Tillståndet uppdateras på rätt sätt om jag styr reläet med via "master".

Ingångarna fungerar som dom ska.

Jan (Microbit)

  • Software Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1796
    • View Profile
    • Email
Re: Firmware version 4.0, HOME edition
« Reply #25 on: 2014-03-11, 15:17:21 »
Nu är jag inte med längre  ;)

Detta borde funka:

Styra både lokala och fjärrelän i en master-WS. Fjärreläna ska såklart fysiskt slå om då, liksom att statusen på masterns reläsida ska uppdateras när slaven har ändrat sitt reläs status.

Detta ska inte funka då det inte är designat på det sättet:

Att i en slav-WS styra ett lokalt relä som en master-WS har satt som sitt fjärrelä och då se den ändringen både i master- och slav-WS.

Är det något av detta du menar?


« Last Edit: 2014-03-13, 15:01:35 by Jan (Microbit) »
Always include type of hard/software and version when asking for support.

danne

  • Newbie
  • *
  • Posts: 23
    • View Profile
    • Email
Re: Firmware version 4.0, HOME edition
« Reply #26 on: 2014-03-11, 15:54:14 »
Quote
Styra både lokala och fjärrelän i en master-WS. Fjärreläna ska såklart fysiskt slå om då, liksom att statusen på masterns reläsida ska uppdateras när slaven har ändrat sitt reläs status.

Jepp, funkar

Quote
Att i en slav-WS styra ett lokalt relä som en master-WS har satt som sitt fjärrelä och då se den ändringen både i master- och slav-WS.
Funkar inte. Statusen kommer upp i den lokala WSen, men inte i mastern.

Jan (Microbit)

  • Software Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1796
    • View Profile
    • Email
Re: Firmware version 4.0, HOME edition
« Reply #27 on: 2014-03-11, 16:13:42 »
Med detta:

Quote
Detta funkar inte:

Att i en slav-WS styra ett lokalt relä som en master-WS har satt som sitt fjärrelä och då se den ändringen både i master- och slav-WS.

menar jag att det inte SKA fungera, hehe! Dvs det är inte tänkt att vara "tvåvägs-kommunikation" utan det är mastern som styr, punkt slut  ;)
Always include type of hard/software and version when asking for support.

danne

  • Newbie
  • *
  • Posts: 23
    • View Profile
    • Email
Re: Firmware version 4.0, HOME edition
« Reply #28 on: 2014-03-11, 16:24:29 »
jaha, då fattar jag.  ;D

Blir till att tänka om då.

danne

  • Newbie
  • *
  • Posts: 23
    • View Profile
    • Email
Re: Firmware version 4.0, HOME edition
« Reply #29 on: 2014-03-13, 14:29:55 »
Nu har jag låtit min WS stå och gå sen i tisdags.

Nuvarande uptime är lite över 2 timmar... Vad kan vara orsaken till alla omstarter?