Author Topic: RRC-Micro  (Read 4535 times)

W4FI

  • Newbie
  • *
  • Posts: 15
    • View Profile
    • Email
RRC-Micro
« on: 2014-06-23, 15:11:59 »
Can someone help me setting up HRD 6.2 and RRC-Micro to allow control/operation of my K3 via WAN? I don't want to leave a computer running at the remote site and am using RRC-1258MKII there. I have the RRC-1258 system working with no problems. I would like to be able to control the station in some circumstances where use of the K3/0 Mini is not convenient. I would like to be able to use my laptop. Is HRD 6.2 capable of doing this? Are there other programs that will fill the bill? An Android application would be wonderful!!!

Thanks
Charlie, W4FI


dj0qn

  • Hero Member
  • *****
  • Posts: 2053
    • View Profile
    • DJ0QN / K7DX
    • Email
Re: RRC-Micro
« Reply #1 on: 2014-06-23, 16:51:01 »
This is absolutely no problem whatsoever.

Just set the radio RRC's COM1 to use mode-7. The use the RRC-Micro's COM1 for CAT control. Audio, etc. is handled by the RRC-Micro.

73,
Mitch DJ0QN / K7DX

roland

  • Guest
Re: RRC-Micro
« Reply #2 on: 2014-06-24, 07:42:57 »
Can someone help me setting up HRD 6.2 and RRC-Micro to allow control/operation of my K3 via WAN? I don't want to leave a computer running at the remote site and am using RRC-1258MKII there. I have the RRC-1258 system working with no problems. I would like to be able to control the station in some circumstances where use of the K3/0 Mini is not convenient. I would like to be able to use my laptop. Is HRD 6.2 capable of doing this? Are there other programs that will fill the bill? An Android application would be wonderful!!!

Thanks
Charlie, W4FI



http://www.remoterig.com/forum/index.php?topic=2402.msg12070#msg12070

K1IKE-Joe

  • Jr. Member
  • **
  • Posts: 90
    • View Profile
    • Email
Re: RRC-Micro
« Reply #3 on: 2014-07-07, 00:02:52 »
Hello Mitch,

I used COM2 for my setup, just because I had a cable with the proper gender connectors to do this.  I'm connected to a TS-480SAT.  Any difference between using COM2 or COM1?  COM2 seems to be working just fine.

Joe, K1ike

dj0qn

  • Hero Member
  • *****
  • Posts: 2053
    • View Profile
    • DJ0QN / K7DX
    • Email
Re: RRC-Micro
« Reply #4 on: 2014-07-07, 00:10:11 »
Joe, you should use COM2 for CAT. The other question was concerning a K3/0. In that case, COM2
ties the two units together and is not available for CAT use. In that special case, you need to use
COM1 in the mode that combines the CAT signal. In the case of the TS-480, just use COM2 if you only
have one program (COM1 as well if you want a second program in parallel).

Here is my TS-480 CAT checklist:


CAT CHECKLIST
---------------------
In both scenarios, you MUST first install a standard serial cable between the TS-480 body and COM2 of the radio RRC!

USING A STANDARD SERIAL CABLE
============================
1) Change the CAT rate on the TS-480 to 4800 baud (menu 56). This rate keeps traffic over the internet to a minimum and faster is not necessary for CAT.

2) Change the COM2 serial settings of the radio-RRC to mode-4, 4800 baud, data bits 8, stop bits 1 and submit/apply changes.

3) Change the COM2 serial settings of the control-RRC to mode-4, 4800 baud, data bits 8, stop bits 1 and submit/apply changes.

4) Plug a serial cable in between your PC and the control-RRC COM2

5) Set your software to use the correct COM port on your PC at 4800-8-1-N

USING A USB CABLE
=================
1) Change the CAT rate on the TS-480 to 4800 baud (menu 56). This rate keeps traffic over the internet to a minimum and faster is not necessary for CAT.

2) Change the COM2 serial settings of the radio-RRC to mode-4, 4800 baud, data bits 8, stop bits 1 and submit/apply changes.

3) Install the Microbit Setup Manager if you already haven't. You don't need the problem for this, but this installs the correct drivers on your PC.

4) Change the COM2 serial settings of the control-RRC to mode-4, 4800 baud, data bits 8, stop bits 1, "use USB Com Port as COM2" to "Yes" and submit/apply changes.

5) Plug a USB cable between your PC and control-RRC. Make sure you do NOT do his before step 3 above!

6) Find out the correct port in your Windows Device Manager to use by looking for the "Microbit RRC Virtual COM Port (COM2)"

7) Set your software to use the this COM port on your PC at 4800-8-1-N.

73,
Mitch DJ0QN / K7DX

K4ZLE

  • Newbie
  • *
  • Posts: 9
    • View Profile
    • Email
Re: RRC-Micro
« Reply #5 on: 2014-09-05, 00:36:54 »
My RRC-Micro arrived today and I am attempting to connect to a working K3 setup that has the RRC-1259 MK II in play.  I let a friend connect to my station through the RRC-1258 MK II.  He uses a K3/0 or full K3 connected to his RRC-1259 MK II and everything works.  I want to use the RRC Mico with HR Deluxe V 6.2.xx to connect to the same station over the internet.  I tried making COM1 on the remote RRC-1258 mode 7, etc as suggested  and connecting HRD to the virtual com port associated with the remote COM1.  It does not connect.  I am able to receive audio and send CW but can not get HRD to connect to K# so I can control the radio.  Help please.

Jay, K4ZLE

dj0qn

  • Hero Member
  • *****
  • Posts: 2053
    • View Profile
    • DJ0QN / K7DX
    • Email
Re: RRC-Micro
« Reply #6 on: 2014-09-05, 07:34:37 »
Hi Jay,

Only one device at a time can connect to the radio, so the answer is just to use COM2. Make sure that
you have it set to the correct baud rate throughout and you should be fine.

73,
Mitch DJ0QN / K7DX

sm2o

  • Administrator
  • Hero Member
  • *****
  • Posts: 2579
    • View Profile
    • sm2oan
    • Email
Re: RRC-Micro
« Reply #7 on: 2014-09-05, 08:01:28 »
Yes use COM2. In K3-Twin mode and some other modes, the Radio-RRC sense if a Micro is connecting, and change setting autmatically to fit the Micro like Codecs, com ports etc.

73 de mike

K4ZLE

  • Newbie
  • *
  • Posts: 9
    • View Profile
    • Email
Re: RRC-Micro
« Reply #8 on: 2014-09-05, 13:46:05 »
Mitch and Mike,
The response to the original post on this problem said to set Com 1 to mode 7, now you say use com2.  So I do not use com1 at all? I did set com1 to mode 7 and had baud rates matching everywhere, but it would not read radio freq so not connect that way.  I will try what you suggest now, only using com2.  I am using a Dell tablet running Win 8.2  So as I understand it, you suggest only setting up Com2, set it for mode4, which includes Elecraft control.  Match the baud rate I have set on the RRC1258 for that com2.  In HRD use the virtual com port that I set in the setup for com2 on the RRC micro. 
If that does not work, here is further info:  When I go into device manager and look at the virtual com ports, they are identified as microbit ports, but unknown driver and not signed.  It says the port is operating OK, but when I did deeper it says there is a problem with the port.  Do I need to delete the microbit ports and start over?  Thanks for the assistance.

dj0qn

  • Hero Member
  • *****
  • Posts: 2053
    • View Profile
    • DJ0QN / K7DX
    • Email
Re: RRC-Micro
« Reply #9 on: 2014-09-05, 15:11:47 »
You need to reread it a couple of times, because it covers two completely different things. Let me
try to clarify:

- The K3 "Twin" using a K3/0 or another K3 blocks COM2 for internal use. Therefore, you must
use COM1 for CAT using the synchronization available using mode-7.

- The RRC Micro should use the main K3 CAT, which is COM2. This is possible because there is
nothing else blocking COM2 when you use it. I am not sure if the PC Client supports mode-7. If
it does, then you should also be able to use the same methodology as the K3/0 and use COM1
with mode-7, but using COM2 is much simpler.

73,
Mitch DJ0QN / K7DX

K4ZLE

  • Newbie
  • *
  • Posts: 9
    • View Profile
    • Email
Re: RRC-Micro
« Reply #10 on: 2014-09-05, 15:20:09 »
You are correct!  It connected OK when I used only com2.  Thank you.  Now to get the latency down so it is usable on CW for more than just casual rag chew.  Probably about a 1/3 to half sec. delay on my local LAN.  I know it would be too much over the internet.  But at least it is working.  Thanks again.
Jay, K4ZLE