Webswitch 1216H Support in English > Hardware, Cabling, Installations

Elecraft K3 twin and Ham Radio Deluxe communication issues

(1/2) > >>

I successfully control remote radio - Elecraft K3 via K3/0 Mini and RRC-1258MkIIs setup. Radio configured as Elecraft twin (14).
However, with this setup I can't communicate to Ham radio Deluxe or N1MM.
Tried all possible settings, ports and cables - still no luck.
When communicating without K3/0 Mini via laptop and the radio configured in mode 4 (Elecraft, etc.) -the  Ham Radio Deluxe works fine.

Would do appreciate if someone could advice which settings should I verify to be able communicate with Ham Radio Deluxe with Elecraft twin mode.

73, Evgeny, VE3SSR

It is very simple, just do the following:

- Change both RRC's serial settings COM1 to Mode-7. The baud rate does not have to be the same as COM2.
- Use COM1 on the control RRC for N1MM. You may wish to change the control RRC's COM1 "Use USB Com Port
as COM1" to YES and then use that virtual serial port (see what Windows assigned it in the Device Manager).

Mitch DJ0QN / K7DX

You are great man Mitch!!!

Everything works fine now.
Thanks a lot for your advice.
I believe this should be included into Elecraft K3/0 Mini and RRC-1258MkIIs users manuals.
My problem was remote RRC serial settings on COM1 to Mode-6, not 7.
Best regards and thanks for your help. I have spent a week trying to resolve the issue.

73, Evgeny, VE3SSR

My pleasure, Evgeny!

Mitch DJ0QN / K7DX

One thing that just occurred to me.....

Elecraft included a virtual COM port for CAT control in the K3/0 mini, so you can also do this without
using the RRC. You need to install their serial driver and then plug into the USB port on the K3/0 mini.
Then you will also get a virtual serial port in Windows Device Manager that you can use.

I only have the "old" K3/0, so I haven't tried this myself, but I believe that this should work as well.
Of course, you are stuck using the same baud rate as the K3 Twin system is using, but otherwise it
should make things easier to use.

Mitch DJ0QN / K7DX


[0] Message Index

[#] Next page

Go to full version