Author Topic: No serial passthrough  (Read 3148 times)

ajkatz83

  • Newbie
  • *
  • Posts: 6
    • View Profile
No serial passthrough
« on: 2014-10-13, 23:16:33 »
Hello:

I had just recently gotten the serial portion of my radio to through the Nano app, and it work really well, but the next part of what I wanted to try was to use Ham Radio Deluxe and from what I understood from other topics, there is another cable that comes from the control box on COM2 to the COM port on the PC and that when you start up HRD, you select your local COM port and it should all start up.

I have not had any luck at all. I found the design for the cable, followed that accordingly, switched on CTS and RTS on Ham Radio Deluxe and still it doesn't interact with the program. I tried DTS for luck, and still nothing. I checked the pin connections and they came back all right. I am a tad lost seeing all I want to use is the Digital Master program in HRD but I cannot figure out any other to use that program other than having all of HRD working. I am wondering, too, if the flow control on my PC serial port has to be set to Hardware, right now its "none." Also in the control box, should the COM2 port be set to Mode 4 or is it Mode 5, user defined?

Has anyone used the setup with Ham Radio Deluxe? Again, there is something I am not seeing.

dj0qn

  • Hero Member
  • *****
  • Posts: 2038
    • View Profile
    • DJ0QN / K7DX
    • Email
Re: No serial passthrough
« Reply #1 on: 2014-10-13, 23:54:24 »
I don't know HRD well, but I tried this a few times and it works just fine without tweaking.

Assuming you are using a TS-480 (since Nano is only that rig), make sure that you set both
RRC's COM2 to mode-5 and to the same serial settings (baud rate and other parameters). This
must match the CAT setting of the TS-480 as well. Obviously this is correct already on the radio
RRC, otherwise it wouldn't have worked with the Nano, so focus on the control RRC.

Then double-check the "Use USB port as COM2" setting to no if using a serial cable and yes if using
USB. If USB, make sure you are using the correct virtual port showing for COM in the Windows
Device Manager. There is no reason why this should not work, including over USB.

73,
Mitch DJ0QN / K7DX

ajkatz83

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: No serial passthrough
« Reply #2 on: 2014-10-14, 06:50:04 »
Yes I do have the TS-480. I did get the Nano to work through it so, yes, I do assume it's something to do with the COM ports.

I tried both those suggestions and it didn't connect up at all.  I am thinking it's something to do on the radio end that is not configured right, seeing that everything else is 9600, I may have it at 57600 down on the radio and likely running mode 4. 

73,

sm2o

  • Administrator
  • Hero Member
  • *****
  • Posts: 2569
    • View Profile
    • sm2oan
    • Email
Re: No serial passthrough
« Reply #3 on: 2014-10-14, 08:44:14 »
Yes com2 should be set to mode 4 (typo error from Mitch). And set 9600 baud for com2 in both RRC:s, in the radio and in HRD. 57600 baud is only used at com 0 for the Control panel to radio communication. CTS, RTS etc has no influence when using Remoterig.

73 de mike

dj0qn

  • Hero Member
  • *****
  • Posts: 2038
    • View Profile
    • DJ0QN / K7DX
    • Email
Re: No serial passthrough
« Reply #4 on: 2014-10-14, 12:29:26 »
Yes, I meant mode-4, it was late last night  :(

If Nano works, then I would think that the radio end would be ok and that the problem is on the
control side. Otherwise, Nano could also not work.

73,
Mitch DJ0QN / K7DX

ajkatz83

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: No serial passthrough
« Reply #5 on: 2014-10-14, 16:52:58 »
No worries Mitch, it's all good :)

I checked my radio side, presently, and the COM settings are good!

Mike, from what you are saying, the radio setting's properties have nothing to do with the serial port configurations at all, correct? Those settings under "radio settings" are meant for the TTL and nothing else. It has nothing to do with the serial ports.

It's something on the control side for sure. I made up the cable for the control side from the instructions I has saw on the remote rig site for Kenwood--I did OK with the radio side one, because of Nano, and then for the control side I don't see anything where any wires are reversed or twisted; it's a straight-through cable essentially.

Only other thing I can/will do is make the control side cable from scratch and when I use HRD, I will unselect the CTS and RTS when I make a new connection....those are the only other things I can think of doing.

Thanks very much guys!

73, KD8LDE

dj0qn

  • Hero Member
  • *****
  • Posts: 2038
    • View Profile
    • DJ0QN / K7DX
    • Email
Re: No serial passthrough
« Reply #6 on: 2014-10-14, 18:48:42 »
The communication on COM0 is a proprietary protocol between the radio and its control panel/head.
In order to use the radio for control, you need to use the separate CAT over COM2. This is different
from radio to radio, for example on Icom you can use COM0 for CAT. That is why he baud rate is fixed
on COM0 and flexible on COM2 (but must match the radio's CAT setting).

The cable on the control RRC's COM2 is a normal straight through serial cable, which many people have
in a drawer somewhere. If you don't have one, just use the RRC's built-in USB to serial converter and take
COM2 off of USB instead. This works just fine with HRD and other control software.

I included my TS-480 CAT checklist below that may help. However, it is really very easy. Like I said before,
if nano works, then I see the problem on the control side.

73,
Mitch DJ0QN / K7DX

CAT CHECKLIST
---------------------
IMPORTANT: In both scenarios, you MUST first install a standard serial cable between the TS-480 body and COM2 of the radio RRC!

USING A STANDARD SERIAL CABLE
============================
1) Change the CAT rate on the TS-480 to (for example) 4800 baud (menu 56). This rate keeps traffic over the internet to a minimum and faster is not necessary for CAT, but you can of course run at a faster speed if you want to.

2) Change the COM2 serial settings of the radio-RRC to mode-4, 4800 baud, data bits 8, stop bits 1 and submit/apply changes.

3) Change the COM2 serial settings of the control-RRC to mode-4, 4800 baud, data bits 8, stop bits 1 and submit/apply changes.

4) Plug a serial cable in between your PC and the control-RRC COM2

5) Set your software to use the correct COM port on your PC at 4800-8-1-N

USING A USB CABLE
=================
1) Change the CAT rate on the TS-480 to (for example) 4800 baud (menu 56). This rate keeps traffic over the internet to a minimum and faster is not necessary for CAT, but you can of course run at a faster speed if you want to.

2) Change the COM2 serial settings of the radio-RRC to mode-4, 4800 baud, data bits 8, stop bits 1 and submit/apply changes.

3) Install the Microbit Setup Manager if you already haven't. You don't need the problem for this, but this installs the correct drivers on your PC.

4) Change the COM2 serial settings of the control-RRC to mode-4, 4800 baud, data bits 8, stop bits 1, "use USB Com Port as COM2" to "Yes" and submit/apply changes.

5) Plug a USB cable between your PC and control-RRC. Make sure you do NOT do his before step 3 above!

6) Find out the correct port in your Windows Device Manager to use by looking for the "Microbit RRC Virtual COM Port (COM2)"

7) Set your software to use the this COM port on your PC at 4800-8-1-N.