Author Topic: Relä slår till lite slumpmässigt  (Read 3143 times)

AT

  • Newbie
  • *
  • Posts: 27
    • View Profile
Relä slår till lite slumpmässigt
« on: 2015-10-16, 10:17:16 »
Hej,

Jag använder min webswitch till en kulvertstyrning och har gjort ett enkelt program som ska starta kulvertpumpen varje dag om temperaturen i slavtanken understiger 40 grader. Pumpen ska stanna när temperaturen i slavtanken går över 40 grader eller när temperaturen i lagertanken går under 40 grader ( dvs energin är slut).
Jag bifogar en bild på programmet , temperatur enligt webswitch med max min samt en temperaturkurva mätt med logger 2020. Om man tittar på loggen så ser man att det har funkat så att pumpen har startat vid 40 grader och även stannat när botten når 40, men man kan också se att pumpen har startat igen vid två tillfällen mitt i cykeln ( den blåa kurvan teknik botten respektive den rosa kurvan teknik mitt ökar i temp)
Vad kan vara anledningen till det, finns det något annat som kan trigga relät?

mvh

Anders

Jan (Microbit)

  • Software Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1798
    • View Profile
    • Email
Re: Relä slår till lite slumpmässigt
« Reply #1 on: 2015-10-16, 10:41:26 »
Baserat på det program som du bifogade så finns det ju bara en sak som kan slå till reläet. Så antingen tycker WSen att det kravet har varit uppfyllt eller så finns det någon annan "krockande regel" som påverkar det reläet. Kan du PM:a "Export(bin)"-filen så jag kan se resten av inställningarna?
Always include type of hard/software and version when asking for support.

Jan (Microbit)

  • Software Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1798
    • View Profile
    • Email
Re: Relä slår till lite slumpmässigt
« Reply #2 on: 2015-10-16, 11:28:08 »
Såg inget konstigt med dina inställningar som kan förklara sporadiska relätillslag. (En notering är dock att du inte behöver ha tidsvillkoret Every day + hela dygnet där alls när det är ren temperatur-styrning du vill ha)

Skulle behöva råka vara så att man ser ACP-webbsidan när reläet är påslaget fast det inte ska vara det. Den visar ju (Row x) om någon rads regel är uppfylld.
Always include type of hard/software and version when asking for support.

AT

  • Newbie
  • *
  • Posts: 27
    • View Profile
Re: Relä slår till lite slumpmässigt
« Reply #3 on: 2015-10-16, 11:30:05 »
OK, tack för hjälpen får försöka hålla koll på när det händer och se om jag kan lista ut något

/ Anders

AT

  • Newbie
  • *
  • Posts: 27
    • View Profile
Re: Relä slår till lite slumpmässigt
« Reply #4 on: 2015-10-19, 12:15:22 »
Hej,

Verkar vara mitt givarnät som spökar och ger korta spikar som inte syns på loggern men som triggar WS, om jag sätter upp larm så duggar det tätt med mail som visar att WS reagerar.
Har du någon ide' på vad som kan få dallasgivarna att skicka knepiga värden ?

/ Anders

Jan (Microbit)

  • Software Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1798
    • View Profile
    • Email
Re: Relä slår till lite slumpmässigt
« Reply #5 on: 2015-10-19, 13:24:21 »
Vad får du får värden i larm-mailen? Varierande? Låter annars skumt. Långa kablar?
Always include type of hard/software and version when asking for support.

AT

  • Newbie
  • *
  • Posts: 27
    • View Profile
Re: Relä slår till lite slumpmässigt
« Reply #6 on: 2015-10-19, 13:26:12 »
Varierande värden i larmmailen. ca 40 m kabel till givaren längst bort.

Jan (Microbit)

  • Software Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1798
    • View Profile
    • Email
Re: Relä slår till lite slumpmässigt
« Reply #7 on: 2015-10-19, 13:36:55 »
Hmm... Det var som sagt skumt. Det är ju checksumma på 1-wire-protokollet så om det kommer olika värden från givarna så borde det alltså verkligen vara så att givarna ger dessa. Hur har du fördelat givarna på BUS A resp B? Kör du "parasitmatat" på allt? För 40 m är ganska långt om det är parasitmatat känns det som.
Always include type of hard/software and version when asking for support.