Author Topic: RRC-Micro with a Kenwood TS-480  (Read 12892 times)

wi4usa

  • Newbie
  • *
  • Posts: 10
    • View Profile
    • Email
RRC-Micro with a Kenwood TS-480
« on: 2010-10-06, 01:48:25 »
I hope someone can help. I have the RRC-1258 MKII and the RRC-Micro that I'm trying to get to work with a Kenwood TS-480. I am using Windows XP 32-bit. The software installed fine and I have com 8 - 10 created as virtual ports by the software. I am able to connect to the sip fine. My baud rate on the radio is set to 57,600. What I'm not able to do is to use the com ports to get cat data for Ham Radio Deluxe. What am I doing wrong?

I am assuming that com0 is used for the rrc-1258 to communicate to the RRC-Micro. Should I put cat control on com1 or com2. I have tried both with no success. Ham radio deluxe just will not connect to the com port. I am connected to the sip fine. You can try to connect on your own at wi4usa.dyndns.biz. There is no password at this point until I can get it working. Has anyone done this configuration and got HRD to get cat info from the serial port? Can someone please, please send me all of your settings.

By the way, I also own the control portion of the RRC-1258 as well and I am able to control the radio through the remote head no problem. So I know the wiring is correct. I just can't get the serial port working when using the RRC-Micro.

Someone please help!

73 de wi4usa

Thom
thomas.jw.baxter@gmail.com

sm2o

  • Administrator
  • Hero Member
  • *****
  • Posts: 2386
    • View Profile
    • sm2oan
    • Email
Re: RRC-Micro with a Kenwood TS-480
« Reply #1 on: 2010-10-06, 07:41:42 »
You don't say anything about CATcable. You need a serial cable from Radio-RRC/Com2 to Radio CAT port. See Kenwood in general. HRD can not handle the Control panel protocol.

73 de mike


wi4usa

  • Newbie
  • *
  • Posts: 10
    • View Profile
    • Email
Re: RRC-Micro with a Kenwood TS-480
« Reply #2 on: 2010-10-08, 00:19:09 »
I have a standard serial cable from com2 on the interface to the radio.

sm2o

  • Administrator
  • Hero Member
  • *****
  • Posts: 2386
    • View Profile
    • sm2oan
    • Email
Re: RRC-Micro with a Kenwood TS-480
« Reply #3 on: 2010-10-08, 08:41:41 »
Hi

I don't think there are standard cables which fits check http://www.remoterig.com/schema/Kenwood-cable-K15-2.pdf

first try with the RS232 cables direct from the PC to the radio, connect them toghether without the RRC:s, if it works then you can try with the RRC:S

de mike

wi4usa

  • Newbie
  • *
  • Posts: 10
    • View Profile
    • Email
Re: RRC-Micro with a Kenwood TS-480
« Reply #4 on: 2010-11-14, 03:55:52 »
All is well now.  The release of the RRC and the micro client made my TS-480 connect and play with HRD today.  Great job with the latest Beta guys.  I really appreciate it!

73 de wi4usa

Thom

dj0qn

  • Hero Member
  • *****
  • Posts: 1633
    • View Profile
    • DJ0QN / K7DX
    • Email
Re: RRC-Micro with a Kenwood TS-480
« Reply #5 on: 2010-11-14, 10:39:58 »
Thom,

Could you please give the settings you used to make this work?
I installed the new beta and 2.27, but it still doesn't work.

Thanks & 73,
Mitch DJ0QN / K7DX

ON4AOI

  • Sr. Member
  • ****
  • Posts: 295
    • View Profile
    • Email
Re: RRC-Micro with a Kenwood TS-480
« Reply #6 on: 2010-11-14, 13:19:18 »
Mitch, tried with the new software today and all except PTT is working,
PTT only works 2 seconds and then release the connection,
PTT didn't work in previous releases also.
BTW for HRD to work you can not go higher then 38400 baud !!!
so the TS480 comport and HRD should not be set higher.

Guy ON4AOI

dj0qn

  • Hero Member
  • *****
  • Posts: 1633
    • View Profile
    • DJ0QN / K7DX
    • Email
Re: RRC-Micro with a Kenwood TS-480
« Reply #7 on: 2010-11-16, 10:41:54 »
Guy,

I still can't get it to work after lowering the baud rate. I must be missing
some setting. It would be great if you and Thom were to provide a list of
correct settings.

Thanks & 73,
Mitch DJ0QN / K7DX

Jan (Microbit)

  • Software Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1796
    • View Profile
    • Email
Re: RRC-Micro with a Kenwood TS-480
« Reply #8 on: 2010-11-16, 11:18:52 »
Guy,

I still can't get it to work after lowering the baud rate. I must be missing
some setting. It would be great if you and Thom were to provide a list of
correct settings.

Thanks & 73,
Mitch DJ0QN / K7DX
I might have lost track of what your problem is, so asking what is that that doesn't work? The audio, HRD, something else?
Always include type of hard/software and version when asking for support.

dj0qn

  • Hero Member
  • *****
  • Posts: 1633
    • View Profile
    • DJ0QN / K7DX
    • Email
Re: RRC-Micro with a Kenwood TS-480
« Reply #9 on: 2010-11-16, 11:28:32 »
I didn't report a problem and try it out earlier, since the
forum reports were that it didn't work with the TS-480.

Then I read that the new version works, so I tried it out and can't
get it to work, so that's why I am asking for the settings from the
other guys.

The instructions are not all that clear to me, and my radio RRC-1258
COM2 setting doesn't allow it to be set in logical parallel with COM0, it
goes back to inactive. I understood that this setting is necessary
to allow HRD to access the TS-480 and the 2nd com port on the Micro
Client. I assume that I misunderstood something.

73,
Mitch DJ0QN / K7DX

Jan (Microbit)

  • Software Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1796
    • View Profile
    • Email
Re: RRC-Micro with a Kenwood TS-480
« Reply #10 on: 2010-11-16, 11:56:48 »
Which "Hardware" version do you see on the "Info" page? Which "Program mode" are you using?
Always include type of hard/software and version when asking for support.

dj0qn

  • Hero Member
  • *****
  • Posts: 1633
    • View Profile
    • DJ0QN / K7DX
    • Email
Re: RRC-Micro with a Kenwood TS-480
« Reply #11 on: 2010-11-16, 12:03:05 »
Hardware is version 5.
"Program Mode" is 5 - TS480.

Jan (Microbit)

  • Software Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1796
    • View Profile
    • Email
Re: RRC-Micro with a Kenwood TS-480
« Reply #12 on: 2010-11-16, 12:16:17 »
I am not 100% updated myself when it comes to all possible combinations of settings. But I do know that if you set "Program mode" to 5, then setting Com 2 to parallel isn't allowed, and that is why you see it go back to inactive. I would think that you should have Com 2 in mode 4 and match that with similar settings in the PC program. Mikael isn't here for the moment, so if this doesn't help then we have to wait for him.
Always include type of hard/software and version when asking for support.

dj0qn

  • Hero Member
  • *****
  • Posts: 1633
    • View Profile
    • DJ0QN / K7DX
    • Email
Re: RRC-Micro with a Kenwood TS-480
« Reply #13 on: 2010-11-16, 12:20:25 »
Ok, thanks, Jan.

Also, hopefully the other guys will mention how they got it to work.

73,
Mitch DJ0QN / K7DX

ON4AOI

  • Sr. Member
  • ****
  • Posts: 295
    • View Profile
    • Email
Re: RRC-Micro with a Kenwood TS-480
« Reply #14 on: 2010-11-16, 19:50:20 »
It is a weird problem

running XP home --- RRC-CLIENT + HRD works ok except that I only have PTT for 1-2 seconds
and this is everytime I try

running vista home RRC-CLIENT + HRD works perfect even the PTT is acting normal just after you first installed it BUT rebooting or restarting rrc-client (remains ok) and HRD is not working anymore even with administrator rights, HRD cant get connection with the TS-480 anymore.

reconnecting to the xp home pc and all is ok again except for the PTT

Guy ON4AOI