Author Topic: Fel vid uppdatering av firmware  (Read 6406 times)

SM6VTT

  • Jr. Member
  • **
  • Posts: 90
    • View Profile
Fel vid uppdatering av firmware
« on: 2010-10-16, 12:27:53 »
Försöker uppdatera till senaste versionen men får följande fel: "CRC32 mismatch, header=-2066745840, calculated=2053668334"

Jag har RRC-1258(MkI)

Skall testa att göra en reset och se om det går efter det...

Någon annan som har samma problem??
« Last Edit: 2010-10-16, 15:43:50 by SM6VTT »

SM6VTT

  • Jr. Member
  • **
  • Posts: 90
    • View Profile
Re: Fel vid uppgradering?
« Reply #1 on: 2010-10-16, 13:50:34 »
Reset hjälper inte.

Funderar inte via setup manager heller, säger "Failed programming new firmware: Program update failed! (Invalid file content)"

Varken RRC-1258-CRC_v2.20_2010-09-14.bin eller RRC-1258-CRC_v2.20_2010-09-24.bin

Jag har hw version 3

Någon idé?

SM6VTT

  • Jr. Member
  • **
  • Posts: 90
    • View Profile
Re: Fel vid uppgradering?
« Reply #2 on: 2010-10-16, 14:01:03 »
Ryckte ur nätverksuttaget och radion. Stängde av antivirusprogramvaran, laddade ner filen på nytt och körde in den via usb och Setup manager... "show terminal" var igång

Nu säger den att den har kört in den men det är fortfarande den gamla som ligger kvar efter omstart...

Skall det vara så?? ;-)

« Last Edit: 2010-10-16, 14:16:57 by SM6VTT »

Jan (Microbit)

  • Software Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1800
    • View Profile
    • Email
Re: Fel vid uppdatering av firmware
« Reply #3 on: 2010-10-18, 10:57:30 »
Du verkar ha fått en envis RRC på din hals  ;) (Eller en olycklig kombination av PC/webbläsare och RRC)

Kan du testa USB-uppgradering utan att ha "Show terminal" igång? Den kräver nämligen en del "resurser".  Testa även gärna med olika webbläsare, IE verkar vara den "minst kompatibla" om man så säger...

Vad du har för dator och Windows-version kan också vara bra att veta.
Always include type of hard/software and version when asking for support.

SM6VTT

  • Jr. Member
  • **
  • Posts: 90
    • View Profile
Re: Fel vid uppdatering av firmware
« Reply #4 on: 2010-10-18, 11:17:26 »
Jag gjorde uppdatering på kontroll änden utan problem. Samma dator och samma fil, utan problem. Gjorde precis på samma sätt.

Utan "Show terminal" fungerade det inte alls. Den sa att det var korrupt fil eller nåt liknande.

Den hade betett sig lite konstigt det sista, det var därför jag skulle uppdatera den. Nu har det skitit sig totalt för nu kommer jag inte åt den via USB heller, verkar som om det blev nåt fel i sista uppdaterings försöket...

Väntar svar från Micke, om ingen annan har nåt förslag...??
« Last Edit: 2010-10-18, 11:21:36 by SM6VTT »

Jan (Microbit)

  • Software Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1800
    • View Profile
    • Email
Re: Fel vid uppdatering av firmware
« Reply #5 on: 2010-10-18, 12:02:33 »
Jag är ju en av de stackars programmerare som försöker få RRC:n att funka så bra det bara går(ifall du trodde jag var en "allmän" forummedlem menar jag)  ;)

Låter helknäppt att det skulle ha funkade "bättre" med terminalen synlig! Måste rimligen varit nått annat som sammanföll med det.

Jag rekommenderar att du testar att göra en "hårdreset", dvs håll inne resetknappen i minst 15-20 sekunder. Det kan vara så att "skit" i inställningarna förhindrar den att funka som den ska. (Du tappar iofs dina inställningar då tyvärr)

Annars finns också en sista utväg som går ut på att ansluta en terminal till COM1 och uppdatera programmet via den inbyggda bootloadern. Vi tar det sen om det behövs.
Always include type of hard/software and version when asking for support.

SM6VTT

  • Jr. Member
  • **
  • Posts: 90
    • View Profile
Re: Fel vid uppdatering av firmware
« Reply #6 on: 2010-10-18, 21:46:58 »
Jag rekommenderar att du testar att göra en "hårdreset", dvs håll inne resetknappen i minst 15-20 sekunder. Det kan vara så att "skit" i inställningarna förhindrar den att funka som den ska.

Annars finns också en sista utväg som går ut på att ansluta en terminal till COM1 och uppdatera programmet via den inbyggda bootloadern. Vi tar det sen om det behövs.

Tack för snabbt svar...

Reset fungerar ej. När jag kopplar via USB så verkar den bara boota om enligt lysdioderna.

Testade att koppla in en seriell kabel och jag kommer åt den.... så långt allt bra..
« Last Edit: 2010-10-18, 23:09:51 by SM6VTT »

Jan (Microbit)

  • Software Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1800
    • View Profile
    • Email
Re: Fel vid uppdatering av firmware
« Reply #7 on: 2010-10-19, 06:49:18 »
Aha! Då skulle jag vilja veta vad du får för utskrifter i terminalen när du dels:

1/
Bara startar upp den som vanligt.

2/
Håller inne resetknappen i c:a 20 sekunder utan att släppa den det allra minsta under tiden ;-)
Always include type of hard/software and version when asking for support.

SM6VTT

  • Jr. Member
  • **
  • Posts: 90
    • View Profile
Re: Fel vid uppdatering av firmware
« Reply #8 on: 2010-10-19, 10:02:09 »
1/
Bara startar upp den som vanligt.
==========================================
** 1285/1258 Bootloader V1.5            **
** Booting application                  **
==========================================
** Press capital x for xmodem apploader **
==========================================
Company : Microbit
Product : 1258
Hardware: 3
Software: 0.0.2.0
Compiler: 4.1.2 (WinARM 4/2007)
Build   : Dec 10 2009 11:04:54
ROM/RAM : 267428/40268
ethRAM  : 2816 (max 3kB!)
USBRAM  : 0
ResetSrc: b [3]
Uptime  : 0
=========================
Debug level   = 255
Control panel = 2
Program mode  = IC706
PID           = 2147483647
=========================
U2LCR=83
audio = BOTH_OPEN
KSZ8041NL PHY detected
USB: Got new addr:0
presc:   4
[/quote]

2/
Håller inne resetknappen i c:a 20 sekunder utan att släppa den det allra minsta under tiden ;-)

Default settings saved, reset...

==========================================
** 1285/1258 Bootloader V1.5            **
** Booting application                  **
==========================================
** Press capital x for xmodem apploader **
==========================================
Company : Microbit
Product : 1258
Hardware: 3
Software: 0.0.2.0
Compiler: 4.1.2 (WinARM 4/2007)
Build   : Dec 10 2009 11:04:54
ROM/RAM : 267428/40268
ethRAM  : 2816 (max 3kB!)
USBRAM  : 0
ResetSrc: 4 [3]
Uptime  : 0
=========================
Debug level   = 255
Control panel = 2
Program mode  = IC706
PID           = 2147483647
=========================
U2LCR=83
audio = BOTH_OPEN
KSZ8041NL PHY detected
USB: Got new addr:0
presc:   4
« Last Edit: 2010-10-19, 10:42:42 by SM6VTT »

SM6VTT

  • Jr. Member
  • **
  • Posts: 90
    • View Profile
Re: Fel vid uppdatering av firmware
« Reply #9 on: 2010-10-19, 11:04:24 »
Kollade inställningarna under sys och eth=255, genom att ändra till 0 kommer jag nu åt den via ip adressen....

SM6VTT

  • Jr. Member
  • **
  • Posts: 90
    • View Profile
Re: Fel vid uppdatering av firmware
« Reply #10 on: 2010-10-19, 11:08:56 »
Nu verkar jag vara tillbaka till ursprungsläget. När jag försöker uppdatera till RRC-1258-CRC_v2.20_2010-09-14.bin får jag "CRC32 mismatch, header=-2066745840, calculated=2053668334"

SM6VTT

  • Jr. Member
  • **
  • Posts: 90
    • View Profile
Re: Fel vid uppdatering av firmware
« Reply #11 on: 2010-10-19, 11:45:22 »
Testade runt lite i terminal läge och hittade "corrupt Snr,Mac and PID crc" under "flash". Nu gick det att uppgradera!!!

Problemet ser ut att vara löst...

SM6VTT

  • Jr. Member
  • **
  • Posts: 90
    • View Profile
Re: Fel vid uppdatering av firmware
« Reply #12 on: 2010-10-19, 13:22:03 »
Man skall inte ropa hej...

Något är väldigt konstigt. Jag kommer inte åt den fullt ut via USB och den säger att den har ett serienummer som är 117835012 när den i själva verket har 1636. Den skriver även ut PID som 2147483647, om det skall vara så vet jag inte men den andra enheten har PID 0
« Last Edit: 2010-10-19, 13:34:22 by SM6VTT »

Jan (Microbit)

  • Software Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1800
    • View Profile
    • Email
Re: Fel vid uppdatering av firmware
« Reply #13 on: 2010-10-20, 08:44:13 »
Har inte hunnit svara förrän nu, tyvärr  ;)

Det är uppenbart att inställningarna i Flash-minnet har blivit alldeles korrupta, t.ex är ju serienr + PID helt uppåt väggarna. Det verkar inte heller som att det har funkat som det borde med "sätta default"-grejen då Ethernet-typen förblev 255 även efter detta. Den skulle nämligen ha blivit 5 efter det.  Även dina andra försök med bl.a uppdatering av firmware med olika felmeddelanden pekar på att den har stora problem att hantera Flash-minnet.

Så det som återstår är att du skickar den till oss så vi får fixa till den.
Always include type of hard/software and version when asking for support.

SM6VTT

  • Jr. Member
  • **
  • Posts: 90
    • View Profile
Re: Fel vid uppdatering av firmware
« Reply #14 on: 2010-10-20, 10:18:31 »
Misstänkte att det kunde bli så.

Stämmer adressen??

Microbit 2.0 AB
Nystaden Företagscentrum 1
952 61 KALIX


Någon speciell mottagare??