Author Topic: 4.23 BETA Buggrapport  (Read 3741 times)

SM5XJX

  • Newbie
  • *
  • Posts: 23
    • View Profile
    • Email
4.23 BETA Buggrapport
« on: 2016-01-06, 15:25:22 »
Hej

Jag har efter 4.23 upptäckt följande på HOME versionen:

En 1 wire tempgivare dyker upp som en extra givare men den går att bocka bort i programmet således inget större problem men något skumt.

Ett 1 wire ingångskort 2 kanals tappade adressen o fick sökas om.

Ett annat 1 wire  2 kanals ingångskort tappade funktionen ingång A LOW helt o den återfjädrande strömställaren fick programmeras om till LOW B.

Sedan har inte mina SMS vid larm kommit som jag tycker de borde men jag har haft fel förr... Detta har hängt med även på tidigare versioner.
Jag kör Smart SMS. Test SMS kommer fram utan dröjsmål.

Gott nytt 2016
Fredrik
« Last Edit: 2016-01-06, 15:40:09 by SM5XJX »

SM5XJX

  • Newbie
  • *
  • Posts: 23
    • View Profile
    • Email
Re: 4.23 BETA Buggrapport
« Reply #1 on: 2016-01-06, 15:47:41 »
Bifogar bilder. ..
[/quote]


Skickat från min GT-I9195 via Tapatalk

Jan (Microbit)

  • Software Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1796
    • View Profile
    • Email
Re: 4.23 BETA Buggrapport
« Reply #2 on: 2016-01-06, 16:02:09 »
Hej

Jag har efter 4.23 upptäckt följande på HOME versionen:

En 1 wire tempgivare dyker upp som en extra givare men den går att bocka bort i programmet således inget större problem men något skumt.

Ett 1 wire ingångskort 2 kanals tappade adressen o fick sökas om.

Ett annat 1 wire  2 kanals ingångskort tappade funktionen ingång A LOW helt o den återfjädrande strömställaren fick programmeras om till LOW B.

Sedan har inte mina SMS vid larm kommit som jag tycker de borde men jag har haft fel förr... Detta har hängt med även på tidigare versioner.
Jag kör Smart SMS. Test SMS kommer fram utan dröjsmål.

Gott nytt 2016
Fredrik
Vilken är "extra"? Den första?

Tappad adress menas att den försvann ur programmeringen?

Om ingång A försvinner men B finns kvar så låter det otroligt skumt om det skulle ha nått med programmet i allmänhet och 4.23 i synnerhet att göra.

SMS-larm har jag på en WS hemma och de kommer "för ofta", med det menas att när jag öppnar fönstret till det lilla rum där övervakningen sker för att hiva in pelletssäckar så hinner templarmet gå iväg med SMS. Har du kollat vilken status det är på Monitoring-sidan?

Så värst "Gott" är nog inte 2016 om WSen krånglar på de sätt du beskriver  ;)
Always include type of hard/software and version when asking for support.

SM5XJX

  • Newbie
  • *
  • Posts: 23
    • View Profile
    • Email
Re: 4.23 BETA Buggrapport
« Reply #3 on: 2016-01-06, 17:06:55 »
Hej

Det är den andra som du ser att jag "stängt av".
Tappad adress ja den försvann ur listan över 1 wire objekt så programmet pekade mot något som inte fanns enligt WS.
Ja skumt jag vet bara att det hände vid övergången till 4.23. Jag ska kolla trådningen snarast.

Jag kollade statusen nu den är inactive så ingen reaktion där. Även efter filtertiden på 60 sek.
Larm lampan som delar tempgivare reagerade dock vid inställt värde.

F

Vid omstart av WS så kommer spökgivaren upp igen och man måste manuellt "plocka bort den igen"
« Last Edit: 2016-01-06, 18:53:07 by SM5XJX »

Jan (Microbit)

  • Software Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1796
    • View Profile
    • Email
Re: 4.23 BETA Buggrapport
« Reply #4 on: 2016-01-07, 08:31:17 »
Ok, då är biten med den återkommande sensorn nog begriplig. Det är nämligen så att av historiska skäl så sker en automatiskt skanning av 1:a och 2:a raderna i 1-wire-listan ifall inget är programmerat in på nån av dem. Så det är mest troligt därför den gärna vill lägga till en på 2:a raden. Har nog inte tagits i beaktande att man kan ha en sån konfig som du råkar ha  ;)

Att det däremot försvinner bara en 1-wire-enhet från listan är svårare att förstå, borde vara allt eller inget kan man tycka, såvida det inte har nått att göra med föregående grej.

Monitorstatusen jag tänkte på var:

Quote
No queued emails/SMS

Last email/SMS status:  Email/SMS sent successfully

för jag fattade det som att det var SMS-skickandet som sket sig men du menar att det kanske inte ens blev "Active"?
Always include type of hard/software and version when asking for support.

SM5XJX

  • Newbie
  • *
  • Posts: 23
    • View Profile
    • Email
Re: 4.23 BETA Buggrapport
« Reply #5 on: 2016-01-07, 09:16:54 »
Det blev aldrig active.

Skickat från min GT-I9195 via Tapatalk


Jan (Microbit)

  • Software Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1796
    • View Profile
    • Email
Re: 4.23 BETA Buggrapport
« Reply #6 on: 2016-01-07, 09:59:12 »
Det blev aldrig active.

Skickat från min GT-I9195 via Tapatalk
Ja se det ska den bli, förutsatt att ändringen kvarstår minst 60 sekunder.
Always include type of hard/software and version when asking for support.

SM5XJX

  • Newbie
  • *
  • Posts: 23
    • View Profile
    • Email
Re: 4.23 BETA Buggrapport
« Reply #7 on: 2016-01-07, 11:08:32 »
Vad har du för lösning?
Det är bevisligen  något strul med larmfunktionen.

Skickat från min GT-I9195 via Tapatalk


Jan (Microbit)

  • Software Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1796
    • View Profile
    • Email
Re: 4.23 BETA Buggrapport
« Reply #8 on: 2016-01-07, 19:44:55 »
Ingen "lösning" baserat på vad som hittills har framkommit. Har du testat vad som händer om du tillfälligt ändrar programmeringen så att larm(en) ska aktiveras pga att tempvillkor(en) uppfylls? Och gäller det förresten alla tre larmen att de inte aktiveras?
Always include type of hard/software and version when asking for support.

SM5XJX

  • Newbie
  • *
  • Posts: 23
    • View Profile
    • Email
Re: 4.23 BETA Buggrapport
« Reply #9 on: 2016-01-07, 21:03:33 »
Ja jag har testat att ändra parametrarna så larmet ska trigga. Inget händer inget active... jag har testat på båda mina WS ena kör 4.20 denna kör 4.23. Har jag gjort rätt enligt tidigare bild?
 
Bifogar bild på status:


Skickat från min GT-I9195 via Tapatalk


Jan (Microbit)

  • Software Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1796
    • View Profile
    • Email
Re: 4.23 BETA Buggrapport
« Reply #10 on: 2016-01-07, 21:55:56 »
Nu tätnar verkligen mysteriet! Din programmering ser vettig ut.

Jag testade nyss att lägga till en rad med larm om det är -25 eller kallare ute och återställning -23 eller varmare. Det är nu -26 så det larmade direkt och blev Active.

Du får det inte att funka på två olika programversioner heller. Som sagt, verkligen udda! Kan du göra "export (bin") och maila mig filen så jag kan kolla på den?

Skulle också vara till hjälp om jag fick tillgång till din WS, dels "surf" men även en till port(TCP) till den för Telnet, ifall det inte syns nått i dina inställningar.
Always include type of hard/software and version when asking for support.

SM5XJX

  • Newbie
  • *
  • Posts: 23
    • View Profile
    • Email
Re: 4.23 BETA Buggrapport
« Reply #11 on: 2016-03-29, 21:38:55 »
Nu tätnar verkligen mysteriet! Din programmering ser vettig ut.

Jag testade nyss att lägga till en rad med larm om det är -25 eller kallare ute och återställning -23 eller varmare. Det är nu -26 så det larmade direkt och blev Active.

Du får det inte att funka på två olika programversioner heller. Som sagt, verkligen udda! Kan du göra "export (bin") och maila mig filen så jag kan kolla på den?

Skulle också vara till hjälp om jag fick tillgång till din WS, dels "surf" men även en till port(TCP) till den för Telnet, ifall det inte syns nått i dina inställningar.
Ok då har jag tagit mig tid att öppna den.
Se mail. Den ena är öppen även för telnet. Båda för "surf".

Skickat från min GT-I9195 via Tapatalk


Jan (Microbit)

  • Software Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1796
    • View Profile
    • Email
Re: 4.23 BETA Buggrapport
« Reply #12 on: 2016-03-31, 16:05:00 »
Har hittat en bugg som förklarar varför det inte funkar. Monitor-inställningen "SMTP server(Email only)" som bara ska behöva fyllas i om man skickar larmen via email var tvungen att innehålla något även när sms användes som leveranssätt. Kommer en fix i version 4.25.
Always include type of hard/software and version when asking for support.