Author Topic: No contact with outside world...  (Read 6074 times)

NZ5E

  • Jr. Member
  • **
  • Posts: 42
    • View Profile
No contact with outside world...
« on: 2010-11-15, 03:02:47 »
I have tried all weekend to connect to the Radio RRC outside of my LAN, but still can't access the internal webserver or communicate via the remote head/Control RRC from outside my LAN.

I have successfully updated firmware in both boxes to 2.26, connected to each internal webserver to set parameters to the best of my knowledge, and performed strapping for the TS-480SAT.

The setup at the house consists of cable internet provided by Suddenlink via a Motorola modem which is connected by a Cat-5 cable to a Linksys by Cisco wireless router WRT54G2.  Off the back of the wireless router, I have a Cat-5 cable connected to a POE which supplies power through the Cat-5 cable to a GNS-1140 wireless bridge system to supply internet to the shop (radio) location about 300 feet behind the house in clear line-of-sight.

At the shop location, a Cat-5 cable is routed inside the shop from the GNS-1140 Remote unit.  Just browsing the internet with my laptop connected to the cable, I can't tell any difference in the internet speed compared to connecting my laptop directly to the wireless router at the house.  The GNS-1140 seems to act just like a direct cable connection with no loss of speed.

I connected my laptop to the cable from the bridge at the shop location and registered a host name with DynDns.com.  I put the host name, username, and password in the DynDNS settings of the Control unit.  I also used the host name for the SIP contact in the Radio unit.

I forwarded ports 5060, 11000, and 12000 in the wireless router to IP address 192.168.1.101, which is the IP address I have to use to connect to the Radio unit for the Web interface.  But, I have noticed that the LAN IP address of the internet cable to the Radio unit changes from 192.168.1.100 through 192.168.1.104, depending on how many computers are using the LAN.  Therefore, I also enabled DNZ in the wireless router for 192.168.1.102.  I tried changing the SIP port 5060 to 11001, but still no contact outside my LAN.

I am using my Motorola Droid cellphone with 3G service to tether internet via a USB cable to my Tablet PC running Windows XP.  I am utilizing internet sharing in the Tablet PC to provide internet to the Control unit via a Cat-5 cable.

I would assume that until I can contact the internal webserver of the Radio unit from outside my LAN, I am wasting my time trying to connect the TS-480SAT remote head?

I am now totally confused.  I have changed so many settings (one at the time) that I can't even remember what combinations I have tried.  Where should I turn?

dj0qn

  • Hero Member
  • *****
  • Posts: 2060
    • View Profile
    • DJ0QN / K7DX
    • Email
Re: No contact with outside world...
« Reply #1 on: 2010-11-15, 12:32:06 »
It is not that easy to understand where your exact problem lies,
but I would venture to guess that you either didn't change the
port of your RRC-1258 server, or you are not trying to access the
port number with your browser.

A simplified procedure would be (radio side):

-  change IP address to fixed internal address that fits your subnet.
   Alternatively, set the MAC address in your router's DHCP server to
   always give the same IP address. This is needed for port forwarding
   or to place into DMZ later.

- Log onto the RRC-1258 and change the following:
1) Web server port to something not used
2) Maybe change SIP port, since 5060 is built into many routers
    and often has a conflict.
3) Enter your DynDNS account information
4) Suggest you change the web page user and password as well

- Then go into your router and forward the RRC-1258 ports (SIP,
   web server, etc.), or place into DMZ

- To access your RRC-1258's web page afterwards to configure
   RemoteRig, enter the following into your browser:
   http://XXXXX.dyndns.org:YYYY
   where XXXXX is your account/URL and YYYY is the port number
   Inside of your network, you enter http://192.168.XX.XX:YYYY
   where XX is your internal IP address, YYYY the port

If you still can't figure it out, I would be happy to give you a phone call
or Skype to go through this. I am 7 hours ahead of you.

73,
Mitch DJ0QN / K7DX

dj4mz

  • Jr. Member
  • **
  • Posts: 97
    • View Profile
Re: No contact with outside world...
« Reply #2 on: 2010-11-15, 14:50:40 »
Hi,

I'm not sure if I correctly understood your setup.

                                            /---[GNS-1140, your house]---[WLAN link]---[GNS-1140, shop]---[Shop network]---[RRC Remote-Side]
---[Internet]---[Motorola-Modem]---[WRT54G2]
                                            \---[local network, your house]---[RRC Control-Side]



If this is correct, then your problem has nothing to do with internet/outside world! No DynDNS needed! And yes, as long as you can not access the RRCs Webpage you are wasting time when playing around with the TS480. BTW: I wouldn't change any settings related to SIP ports at the moment. First lets get network to work properly and then change ports etc. if required.

Please provide the following information to help to trace down your problem.
1. Connect a computer to [local network, your house] open a command window and type "ipconfig" (assuming you are using Windows). Please provide IP-Address, Subnetmask and Default-Gateway
2. Repeat step 1 but now with a computer connected to [Shop network].

vy 73
Simon (DJ4MZ)

NZ5E

  • Jr. Member
  • **
  • Posts: 42
    • View Profile
Re: No contact with outside world...
« Reply #3 on: 2010-11-17, 21:46:40 »
...change IP address to fixed internal address that fits your subnet...

The Linksys WRT54G2 wireless router is setup for a starting IP Address of 192.168.1.100 and a maximum number of DHCP users of 50.  Therefore, I enabled DMZ in the router for address 192.168.1.151.  I then went to the shop location and connected to the Remoterig Radio Unit and set DHCP to No, IP Address to 192.168.1.151, Netmask to 255.255.255.0, and Gateway to 192.168.1.1.  I called Suddenlink to inquire about what DNS Address to use and then set the DNS Server to 208.180.42.100. 
« Last Edit: 2010-11-17, 22:06:31 by NZ5E »

NZ5E

  • Jr. Member
  • **
  • Posts: 42
    • View Profile
Re: No contact with outside world...
« Reply #4 on: 2010-11-17, 21:51:54 »
I subscribed to DynDNS.com so I could create several accounts in different ways to try.  I entered my Host name into the Remoterig Radio Unit along with my DynDNS username and password.  I called Linksys technical support because the wireless router also had a setting for DDNS.  I was advised to also turn the functionality on in the wireless router.  DynDNS.org was one of the selections.

NZ5E

  • Jr. Member
  • **
  • Posts: 42
    • View Profile
Re: No contact with outside world...
« Reply #5 on: 2010-11-17, 22:03:30 »
Researching port forwarding on the internet, I ran across several posts of others with SuddenLink service that complained about SuddenLink blocking Port 80.  Do I need Port 80 for communications with the TS-480SAT or is Port 80 only used to be able to access the internal webserver from anywhere on the internet?

I used the Custom Port Test functionality on whatsmyip.org/ports to test several ports.  When connected directly to the Motorola SB5101N modem, 5060, 11000, 12000, and 23 returned Closed.  Port 80 returned Timed-out.

I called SuddenLink technical support, but have yet to be called back by anyone that knows more than I do (and that's sad).

At this point, I think my problem is with the ports being blocked by SuddenLink.  I read on one forum that the ports are not blocked for a Business Account, which of course costs about twice as much!  I will report back when I finally get through to someone that is network savvy at Suddenlink.

dj0qn

  • Hero Member
  • *****
  • Posts: 2060
    • View Profile
    • DJ0QN / K7DX
    • Email
Re: No contact with outside world...
« Reply #6 on: 2010-11-18, 05:38:19 »
I still think that my first theory was right....you did not change your RRC port from
port 80 to another port. You must do so, since otherwise trying to access your
network over DynDNS will try to open port 80 on your router.

To access, you must put the port number in your browser, e.g.
http://XXXXX.dyndns.org:YYYY, where YYYY is the port number.

Please reread my instructions from before, I already explained this.

73,
Mitch DJ0QN / K7DX

Jan (Microbit)

  • Software Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1799
    • View Profile
    • Email
Re: No contact with outside world...
« Reply #7 on: 2010-11-18, 06:00:40 »
I too agree that changing RRC's web server port from 80 to something else is the first step to take, because it's the easiest step to start with when communication isn't working.
Always include type of hard/software and version when asking for support.

NZ5E

  • Jr. Member
  • **
  • Posts: 42
    • View Profile
Re: No contact with outside world...
« Reply #8 on: 2010-11-18, 13:06:56 »
....you did not change your RRC port from port 80 to another port. You must do so, since otherwise trying to access your network over DynDNS will try to open port 80 on your router...

What port number should I replace Port 80 with?  Is there a range of port numbers that are acceptable for webservers?  Should I go through some sort of proceedure to determine which port to choose to make sure I am not creating conflicts?

Also, please give me a suggested alternate port for Port 5060.

Note:  I don't know of any other special internet operations going on that would require additional ports to be open that might cause conflicts.  Other than browsing the web with a laptop connected via the wireless router, the only other purpose of having internet at this location is to supply internet to the Remoterig system.
« Last Edit: 2010-11-18, 13:16:03 by NZ5E »

dj0qn

  • Hero Member
  • *****
  • Posts: 2060
    • View Profile
    • DJ0QN / K7DX
    • Email
Re: No contact with outside world...
« Reply #9 on: 2010-11-18, 13:55:50 »
It really doesn't matter, as long as there is nothing else in your network with that port
in use. Just use 8000 or perhaps something less easy to guess.

You can find a list of assigned port numbers at http://www.iana.org/assignments/port-numbers
but most of these are not relevant and you can use them anyway.

The DOS command "netstat -a" will show you a list of ports currently in use by your PC.

Bottom line: pick something strange and the probability of a conflict is nill.

My offer to talk you through this by phone or Skype stands.

73,
Mitch DJ0QN / K7DX

dj0qn

  • Hero Member
  • *****
  • Posts: 2060
    • View Profile
    • DJ0QN / K7DX
    • Email
Re: No contact with outside world...
« Reply #10 on: 2010-11-18, 17:58:04 »
Glad to hear that it works!

Due to deregulation, calling the USA is a local call and costs me nothing.
Skype calls are free, anyway.

Drop me a mail directly to coordinate, we don't need to make everyone
read everything ;-)  My mail is dj0qn (at) darc.de or Skype is mitchwo.

Note that I will be out of town starting tomorrow through next Wednesday,
so better today or from Wednesday evening my time again. I will have
Skype in my hotel rooms, but no idea when I will have time.

73,
Mitch DJ0QN / K7DX

NZ5E

  • Jr. Member
  • **
  • Posts: 42
    • View Profile
Re: No contact with outside world...
« Reply #11 on: 2010-11-18, 22:42:16 »
Finally got everything working and made my first contact on my "new" internet remote base.  I have to go to work right now, but will report back later for the benefit of others.

Thanks for all the help!