Author Topic: WinKey emulator issue: Why is space(s) required at end of N1MM+ F-key command?  (Read 12853 times)

Jan (Microbit)

  • Software Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1796
    • View Profile
    • Email
Jan (Microbit) - Please review the above.  I believe that the problem is that the "Tail Time", if any, isn't equal to the "Key delay", as I believe that it should be.  This is only a problem when the WinKey emulator output is controlled by ASCII characters.
Have you had a look at "PTT tail delay" found in the radio RRC?
Always include type of hard/software and version when asking for support.

w2huv

  • Newbie
  • *
  • Posts: 20
    • View Profile
W1UE - Dennis, I talked to Lee, WW2DX, one the co-owners of RHR, on the phone yesterday.  He told me that you should never use the KY CATA1ASC sequence in N1MM+ function key definitions when you are using a K3/0 or K3/0 Mini control head and an RRC1258.  He also told me that he has operated in several contests using the WinKey emulator built-in to the RRC1258 in the past and doesn't recall any problems.  Apparently, we had communications failures in the past.  He told me that he will that a look at my issue when he has some "on" time.

One probable difference between the RHR configuration and your configuration is that operation is in half-duplex because full duplex requires too much bandwidth.

Thanks for informing me that many Winkey emulators don't support the variable settings that N1MM+ has on it's Winkey page.

Jan (Microbit) - I found "PTT-off mute delay" listed in the Advanced Settings on my control RRC.  Does "PTT tail delay" only appear in the Advanced Settings of a radio RRC?

W1UE

  • Full Member
  • ***
  • Posts: 102
    • View Profile
    • Email
If you read the setup manual on the Remote Rig Setup you can see what parameters are adjustable on the Control and Remote RRCs, what range they can be set to, and in most cases the default that usually works okay.  I would not be surprised at all if RHR does not allow its users access to their Remote RRCs, and it would also not surprise me if if RHR had a "recommended" group of settings for your Control RRC instead of the defaults as stated in the manual.  Still, to get a feel for what parameters you can change on your Control RRC setting the best thing to do is to read the manual.  It is readily available for download on the RR website.

Dennis W1UE

w2huv

  • Newbie
  • *
  • Posts: 20
    • View Profile
Jan (Microbit) - I was doing what W1UE suggested (read the manual) while he was preparing his last post and answered my last questions.  I found that the radio RRC only has two settings:

PTT activated by Keyer (No/Yes)
PTT tail delay ms [0-999]

No recommended settings are listed.

Is the first setting supposed to be "On" when using the WinKey emulator?  What is a typical value for the second setting?  I would assume that it should be the same as the "Key delay" setting in the control RRC.

When I know what the settings should be or at least starting points, I will contact RHR and have them check and change the settings as needed.

W1UE - It would be helpful to know the values that you are using for the above settings.
« Last Edit: 2016-03-16, 19:29:47 by w2huv »

sm2o

  • Administrator
  • Hero Member
  • *****
  • Posts: 2519
    • View Profile
    • sm2oan
    • Email
PTT activated by keyer is normally used. The Radio is then keyed before the CW starts and you do not need to have the radio in VOX mode or what it's called it's a little bit different between different radios. The Mic cable must be connected to make it work.

PTT tail delay is how long time the PTT above signal should be active after the last dot or dash is sent. This setting is more to avoid PA relays to release to early.

Those two settings has no relation with the KeyDelay setting, Key delay setting is used to decide how much buffering the Radio-RRC should use before starting to send CW, With a perfect Internet connection this can be set set low but with a bad internet connection it must be set so it can take care of the Jitter. For normal use 50 ms isa good start value
« Last Edit: 2016-03-16, 20:50:10 by sm2o »

w2huv

  • Newbie
  • *
  • Posts: 20
    • View Profile
sm2o - Thanks for your insight!

w2huv

  • Newbie
  • *
  • Posts: 20
    • View Profile
W1UE - Dennis, would you please provide your two radio RRC Keyer settings?  The parameters are as follows:

PTT activated by Keyer (No/Yes)
PTT tail delay ms [0-999]

w2huv

  • Newbie
  • *
  • Posts: 20
    • View Profile
Thursday afternoon I requested RHR to record and report to me the "PTT activated by Keyer" and "PTT tail delay" for the stations that I operate on 160m, W1/Calais160, W2/Summit160 and W4/Atlanta.  So far, no response.

Being impatient as I am, last night I decided to do experiment to determine the settings myself.  First, I removed the space at the end of each function command definition.  Then, I turned off VOX (activates PTT).  That made no difference.  Since VOX was off, the logical conclusion is that "PTT activated by Keyer" is on.  Since I continued to receive ERR KEY messages, I suspect that "PTT tail delay" is set at 0.

Any comments?

W1UE

  • Full Member
  • ***
  • Posts: 102
    • View Profile
    • Email
John
Your impatience is showing through, as is your frustration.  Let's stop for a moment and analyze the problem.  It may also be useful to take this off the forum and communicate direct. 

Facts:
You have a K3/0 Mini.  Some questions:
1. Do you connect the paddle to the Mini, or to the RRC Control Box?
2. You are using the attached USB cable and the Microbit ports for radio control and Winkey.
3. What version of the K3/0 mini firmware are you using?  To see what is in your mini, you have to disconnect the Internet line to the RRC box, turn the Mini on, then enter the Config menu.  If you leave the Internet line connected, you will see the Firmware version of the Remote K3 unless RHR has disabled it.
4. If you aren't using Firmware 5.38, you should update.  There were several fixes related to ERR KEY in Firmware 5.38.

My view now is that this problem is not directly related to RHR or Remote Rig units, but has to do with your equipment, either the Firmware or the station setup.  Something is causing the ERR KEY message.  ERR KEY is telling us that the keying line is being grounded by something; if it was an RHR problem they would be having LOTS of complaints.  Since you seem to be the only one with the problem, my conclusion is that it must be local to your setup.  What is wrong, though, is escaping us.

Dennis W1UE

w2huv

  • Newbie
  • *
  • Posts: 20
    • View Profile
W1UE - Dennis, I have answered your questions in bold in your response:

Facts:
You have a K3/0 Mini.  Some questions:
1. Do you connect the paddle to the Mini, or to the RRC Control Box?  To the RRC box.
2. You are using the attached USB cable and the Microbit ports for radio control and Winkey.  Yes.
3. What version of the K3/0 mini firmware are you using?  0538.  I didn't disconnect the internet line because I wasn't connected to a remote station.  To see what is in your mini, you have to disconnect the Internet line to the RRC box, turn the Mini on, then enter the Config menu.  If you leave the Internet line connected, you will see the Firmware version of the Remote K3 unless RHR has disabled it.
4. If you aren't using Firmware 5.38, you should update.  There were several fixes related to ERR KEY in Firmware 5.38.

My view now is that this problem is not directly related to RHR or Remote Rig units, but has to do with your equipment, either the Firmware or the station setup.  Something is causing the ERR KEY message.  ERR KEY is telling us that the keying line is being grounded by something; if it was an RHR problem they would be having LOTS of complaints.  That makes sense.  Since you seem to be the only one with the problem, my conclusion is that it must be local to your setup.  What is wrong, though, is escaping us.

Dennis W1UE

Would you suggest that I send you a Private Message or use the email address posted on QRZ?

W1UE

  • Full Member
  • ***
  • Posts: 102
    • View Profile
    • Email

w2huv

  • Newbie
  • *
  • Posts: 20
    • View Profile
The subject issue was resolved by unchecking “PTT via Radio Command CW Mode” in the N1MM+ logger “Details” for the Elecraft K3 as shown in the attachment.  It was that simple!

Thanks to all that attempted to assist me.