Author Topic: SOLVED - K3 Mini Everything working except WinKeyer - SOLVED  (Read 1929 times)

NG7M

  • Newbie
  • *
  • Posts: 4
    • View Profile
    • Email
Hi, I have a K3 Mini setup with the two RRC-1258 MkII boxes and everything is working great except for the winkeyer.  All the firmware on the RRC boxes is the lastest 2.90 version and the firmware on the K3 Mini and remote K3 is at version 5.50.

I have spent a lot of time doing the research and reading other forum posts where others are having the same issue I'm having and I fully understand the concept of the USB serial port mappings with the RRC boxes.  I'm running Windows 10 and I have duplicated the issue with two different computers... again, windows 10 64 bit versions on both computers.  I doubt it's an issue due to virtual port drivers.  I have tried to rule out all the issues I have read about, but clearly I'm missing something.

Keying via the paddle input at the Control site is working just fine at the remote site.  I'm using VOX to key... i.e. VOX needs to be on at the Remote K3.

The issue when using the winkey emulator at the control site is that it keys the radio at the remote site but the output is messed up... i.e. a question mark sounds like a poorly sent R... dit dahhhh dit... like some drunk operator using a bug or straight key. :)  I would fit right in at times! :)

I have the COM3 Extra USB port at the control site setup for WinKey mode 8 as is documented... I have even tried going down the path of using the external com ports on the control site RRC box for CAT control, which works for Com 1 on the front of the control site RRC box.  Working great for cat control via a USB com1 or direct com1 using a physical com port on my computer...  Not that this matters, but when trying to setup the com2 physical port on the rear of the RRC control box for winkey, I can't get the firmware update to the control RRC box to stick.  It always switches back to Logical parallel with COM0.  So, I can't even try the external winkeyer emulation via the external COM2 port on the RRC control box.

That last paragraph may be hard to follow, but I was trying to remove the virtual USB ports from the mix... that' the only reason I switched over the external RRC control box COM1 port.  I can obviously go back to the USB  ports for CAT control.

So if someone is actually reading my post at this point and I haven't lost you!  What am I missing... FSK works great via the COM3 Extra USB port, and I have even verified the transmitted signal from the remote site back to my control site via another receiver at the control site.  FSK output works great via the COM3 Extra USB port on the control site RRC box.

I'm like 99% there in the setup and want to use N1MM+ to control the Winkey emulation via the control box COM3 extra port set to mode-8 winkey.  No go... I'm the drunken CW op when trying to send CW from N1MM+ at the control site. ;)  And by the way, I tried the old N1MM version and also Dxlab WinWarbler... they all behave the same way.

I'm not going back to Windows 7... period.... and there is no way in hell I'm going back to Windows XP.  If this is a Windows 10 issue at this point based on old posts I have been reading from early 2016, then it needs to be fixed.

Please advise if I have done something wrong which has escaped me.

de Max NG7M
« Last Edit: 2016-09-12, 01:53:07 by NG7M »

NG7M

  • Newbie
  • *
  • Posts: 4
    • View Profile
    • Email
I forgot to mention, I made sure that in N1MM+ there are no CW keying commands being sent by N1MM+ via CAT control to the CAT control port.  All the check boxes in the K3 config dialog box are unchecked.  I read the posts about that being an issue.  So that is not the issue in this case.

mg NG7M

NG7M

  • Newbie
  • *
  • Posts: 4
    • View Profile
    • Email
I also tried down grading the RRC 1258 box firmware versions... I tried 2.84 and 2.87, same result... nonsense transmitted from the remote K3, but the side note at the control site sounds good.  Oh incase someone else asks about the extra spaces at the end of the CW messages in N1MM+, I tried that too... it doesn't help.

mg NG7M

NG7M

  • Newbie
  • *
  • Posts: 4
    • View Profile
    • Email
Well after many hours of weeping and wailing and gnashing my teeth, I figured out the problem.  I hope this helps someone else that comes along.

The issue was with the Keyer settings in the Control side RRC-1258 MkII.  By default and or early on in the installation I had Keyer->Key delay ms set to: 0

I also had: Lf delay ms set to: 0

But after trial and error, if I set Key delay ms to even 1 ms, things started working as expected.  Even with 1 ms set for the delay time before the keying of the radio is executed at the RRC radio, I could still make out the CW sent from the Remote site.  The RRC1258 manual clearly shows that this setting should default to 50 ms. http://www.remoterig.com/downloads/RemoteRig_RRC1258-MkII_Users_manual.pdf

However, in my control side RRC 1258 I had both Lf delay and key delay set to 0.  Again, the magic change for my situation was to drop something greater than 0 ms into the Key delay setting.

So if some other poor slob runs into the same problem I had, RTFM... for Key delay ms and Lf delay ms.  The manual states to start with your ping time (by the way, PING stands for Packet Internet Groper) between the control and remote sites.  In my case the ping time is very low due to both sites being on the same ISP network and it's geographically about 8 miles from me as the crow flys.  Anyway, things still worked with a Lf delay ms at 0.

I now have my numbers set as follows for my low ping time between the control QTH and the remote QTH:

Lf delay ms = 40 ms (conservative typical ping time between the remote and control stations in my case, W7CT and NG7M)
Key delay ms = 50 ms (the manual default)

How did my Key delay ms get set to 0???? that is the $64 question.  I have no idea.  Talk about a pain in the back side!  Anyway it seems to me that NOT allowing it to go lower than 5 ms or something like that would save a lot of grief for new users.  i.e. update the web interface and don't allow the value to go to zero at a minimum.

RRC with a K3 Mini is now working with the Winkeyer emulator setup on the extra Com3 USB port in the control RRC-1258 MmkII at NG7M (control) and W7CT (remote).

I think I'll take the rest of the evening off. :)

mg NG7M