Author Topic: Installasjon av USB fungerer ikke  (Read 4113 times)

la5eka

  • Newbie
  • *
  • Posts: 22
    • View Profile
    • Email
Installasjon av USB fungerer ikke
« on: 2010-12-09, 10:51:46 »
Jeg har forsøkt å installere Setup manager på to separate PC'er, og på begge får jeg feilmeldingen
“This device cannot start. Code 10" på USB driver. Begge er WInXP, Service Pack 2.

Anyone ?

la5eka

  • Newbie
  • *
  • Posts: 22
    • View Profile
    • Email
Re: Installasjon av USB fungerer ikke
« Reply #1 on: 2010-12-10, 10:30:06 »
Er det ingen andre som har problemer med dette ?

Jan (Microbit)

  • Software Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1796
    • View Profile
    • Email
Re: Installasjon av USB fungerer ikke
« Reply #2 on: 2010-12-10, 16:45:27 »
Menar du att du inte ens lyckas installera Setup Manager-programmet? För det ska inte ha nått att göra med USB-drivrutinerna. Vilken sorts USB-enhet är det du får "Code 10" på? RRCn ska främst dyka upp som en "HID"-enhet, för det är på det viset som Setup Manager-programmet kommunicerar med RRCn. RRCn kan även visas som en USB-serieport, men den behövs inte för Setup Managern.
Always include type of hard/software and version when asking for support.

la5eka

  • Newbie
  • *
  • Posts: 22
    • View Profile
    • Email
Re: Installasjon av USB fungerer ikke
« Reply #3 on: 2010-12-10, 17:55:07 »
Det gjelder serieporten. Setupmanager fungerer fint, det eneste som ikke fungerer, er USB seriedriver (Microbit RRC Virtual Comport)- den får jeg feilmelding på under install og hver gang jeg kobler til. Dette skjer på alle PC'er jeg har prøvd med. Virtuelle serieporter pleier å fungere greit her i huset. På den ene PC'en kjører jeg MicroHam USB Device Router 7.7, men MicroBit fungerer ikke selv om jeg deaktiverer den. Jeg kjører også RigExpert serieporter, Prolific, Eltima, etc... alt fungerer, bare ikke MicroBit. Det er jo synd å måtte dra med seg en ekstra USB/Serie dongle på tur for å få rig control...


LA5EKA ...
« Last Edit: 2010-12-10, 18:15:27 by la5eka »

Jan (Microbit)

  • Software Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1796
    • View Profile
    • Email
Re: Installasjon av USB fungerer ikke
« Reply #4 on: 2010-12-10, 20:50:47 »
Har du alltså ett flertal virtuella serieportar på de PC:ar du har försökt installera vår port på? Tänker ifall det blir någon "krock" mellan dem.

Du kan se i Windows "Event log" för "Applications" och/eller "System" ifall där finns någon information om vad som blir fel när du försöker installera serieportarna. I "Applications"-loggen skriver port-drivern med "Source" = "1274Serial". (Skriver namnen på engelska då jag inte vet vad de heter på ditt språk)

En PC är för övrigt en sak som är väldigt knepig att få allt att alltid funka felfritt på då det finns ett oändligt antal kombinationer av hård- och mjukvara ;)

Finns det förresten något särskilt skäl till att du inte har SP3 på dina datorer?

Always include type of hard/software and version when asking for support.

la5eka

  • Newbie
  • *
  • Posts: 22
    • View Profile
    • Email
Re: Installasjon av USB fungerer ikke
« Reply #5 on: 2010-12-21, 18:05:17 »
Hallo !

Nå har jeg gått over til SP3 på den ene pc'en, og driverne ser nå ut til å installeres korrekt. Imidliertid ser det ikke ut til å skje noe når jeg kobler til den virtuelle porten. Hvordan fungerer det ? Er det slik at COM0 er ex. CI-V fra riggen ? Når jeg setter com2 i parallell med com0 fungerer CI-V (på control boksens com2). Forsøker jeg gå igjennom Microbit porten fungerer ingenting. Er det noe spesielt man må sette opp ? Bør jeg kanskje installere Microbit driverne på nytt ? 

73 de LA5EKA ...

sm2o

  • Administrator
  • Hero Member
  • *****
  • Posts: 2506
    • View Profile
    • sm2oan
    • Email
Re: Installasjon av USB fungerer ikke
« Reply #6 on: 2010-12-22, 08:29:07 »
Hej

Du lämnar för lite information för att man skall kunna hjälpa dig ordentligt. Men om det är så att du har en CI-V kabel till COM0=TTL Kontakten på Radio-RRC så skall du ha COM2 inactive i Radio-RRC, sedan i PC-Clienten väljer du CI-V protocol på fliken COM0, där väljer du också en av de Virtuella Microbit COM-portarna. I HamRadioDeLuxe ställer väljer du sedan samma Virtuella COM-port som du gjorde på COM0 fliken. Du måste givetvis också ställa in serieports parameterarna i HRD så det är lika som i radion och i Radio-RRC.n

god jul

/mikael


la5eka

  • Newbie
  • *
  • Posts: 22
    • View Profile
    • Email
Re: Installasjon av USB fungerer ikke
« Reply #7 on: 2010-12-22, 13:12:27 »
Hei igjen, og takk for svar.

Jeg finner dessverre ikke noen COM0 "flik" når jeg retter web-browser mot control boksen. Kun COM1 og COM2 er synlig. Her er mine settings exportert:


      Info

*Name*   *Value*
Company   Microbit
Product   1258
PID   4
Hardware   6
Software   2.30
Bootloader   <= 1.7
Compiler   4.1.2 (WinARM 4/2007)
Build   Dec 16 2010 14:37:11
ROM/RAM   343436/52960
ETH-RAM   2944 (max 3kB!)
ResetSrc   0 [3]
Uptime   367
    
Serial number   3113
MAC address   00:50:xx:xx:xx:xx
IP address   192.168.0.100
Netmask   255.255.255.0
Gateway   192.168.0.1
DNS   192.168.1.1


      Settings

Unit ID (Banner)   
DHCP   1
IP   xxx.xx.xx.247
Netmask   255.255.255.0
Gateway   xxx.xx.xx.1
Dns server   192.168.0.1
Extern IP/Host   
Eth-type   5
Web page user   xxxxx
Web page pwd   xxxxx
Program mode   1
Control panel   1
Sip password   
Sip contact   xxx.dyndns.org
Auto connect   1
Audio quality   0
Audio dual-rx   0
Codec out gain   255
Codec inp gain   18
Codec inp HPF Hz   3
Codec inp preamp   1
COM0 baudrate   19200
COM0 data bits   8
COM0 stop bits   1
COM0 parity   0
COM1 mode   0
COM1 baudrate   19200
COM1 data bits   8
COM1 stop bits   1
COM1 parity   0
COM1 rts/cts   0
COM1 terminator (hex)   00
COM2 mode   9
COM2 baudrate   19200
COM2 data bits   8
COM2 stop bits   1
COM2 parity   0
COM2 terminator (hex)   00
UDP cmd port   60001
UDP audio port   11000
SIP port   5070
Web server port   80
Telnet server port   23
Rx jitter buffer size   4
Rx jitter delay   3
Audio packet size (ms)   20
Continuous RTP tx   0
Debug level   0
DynDNS check interval   0
Own host name   
Username   
Password   
Enable   1
Speed wpm [0/10-40]   0
Iambic   1
Paddle reverse   1
Weight [25-40]   30
Side tone hz [0,500-1500]   600
Side tone -db [50-0]   50
Lf delay ms [0-500]   500
Key delay ms [0-250]   0
IN0 mode   0
OUT0 mode   0
OUT0 mode   0
OUT1 mode   0
OUT1 mode   0
OUT2 mode   0
OUT2 mode   0
USB RTS as PTT   0
USB DTR as CW   0
Enable ping watchdog   0
IP address to ping   
Ping interval (seconds)   300
Startup delay (seconds)   300
Failure count to reboot   3


      Status

*Name*   *Value*
Control panel   ON
Radio   OFF
SIP status   Connected/transfering
Last SIP error   None
RTP Timeout   60
SIP Timeout   0
Rx Jitter buffer size   4
Rx Jitter delay   3
Current audio packet size   20
Current audio quality   0 - alaw 8 kHz
SIP Out port   5070
SIP In port   5070
Audio Out port   11000
Audio In port   11000
Command Out port   60001
Command In port   60001
External SIP In port   5070
External Audio In port   11000
External Cmd In port   60001
Other party   xx.xx.xx.196
Input 0   High
Input 1   High
Input 2   High
Output 0   High
Output 1   Low
Output 2   Low
DNS status   OK, XXX.dyndns.org = xx.xx.xx.196



sm2o

  • Administrator
  • Hero Member
  • *****
  • Posts: 2506
    • View Profile
    • sm2oan
    • Email
Re: Installasjon av USB fungerer ikke
« Reply #8 on: 2010-12-22, 22:58:49 »
Com 0 fliken finns i PC-Clienten men den har du säkert redan hittat

/mikael

la5eka

  • Newbie
  • *
  • Posts: 22
    • View Profile
    • Email
Re: Installasjon av USB fungerer ikke
« Reply #9 on: 2011-06-04, 14:04:04 »
Ser at fra v 2.35 fungerer cat control over USB på control unit. Supert ! Remoterig blir bare bedre og bedre ! Nå trenger jeg ikke drasse med meg ekstra
USB->Serial converter lenger... og heller ikke keyer ;) ...


73 de LA5EKA, Gisle på Nykirke ...