Author Topic: USB as COM0 (for N1MM)  (Read 916 times)

SM0UXX

  • Jr. Member
  • **
  • Posts: 99
    • View Profile
USB as COM0 (for N1MM)
« on: 2017-10-14, 10:05:55 »
Hi all,
I have read posts and the manual on how to get the CAT from my FT2000 work on my N1MM+ (from local radio).
The thing is that I use COM1 for rotator control, so if I use the mode 6 desceibed in the manual the rotator don’t work. Then I have tried to use the USB as com port 0 option instead. But when I chose ”Use USB Com Port as COM0 = YES” and apply, it’s automatically reset to =NO when the rrc has rebooted.

EDIT: Serial settings for COM2 is "Logical parallel with COM0"

Any ideas?
« Last Edit: 2017-10-14, 10:58:21 by SM0UXX »

dj0qn

  • Hero Member
  • *****
  • Posts: 1795
    • View Profile
    • DJ0QN / K7DX
    • Email
Re: USB as COM0 (for N1MM)
« Reply #1 on: 2017-10-14, 20:27:23 »
You need to use COM2 for CAT, COM0 will never work.

73,
Mitch DJ0QN / K7DX

SM0UXX

  • Jr. Member
  • **
  • Posts: 99
    • View Profile
Re: USB as COM0 (for N1MM)
« Reply #2 on: 2017-10-17, 22:00:22 »
Thanks for the answer Mitch.
I might have missed some basic things, but I'm not sure how I set it up. Obviously there are some virtual com ports installed when the control RRC is connected to my computer with USB. COM 2 on the RRC is connected to my control-side FT2000, and is set up as "logical parallel with COM0" - should this rather be the Yeasu/Kenwood/etc mode?

dj0qn

  • Hero Member
  • *****
  • Posts: 1795
    • View Profile
    • DJ0QN / K7DX
    • Email
Re: USB as COM0 (for N1MM)
« Reply #3 on: 2017-10-17, 22:16:06 »
It is really not all that complicated. I assume that you are trying to control the FT-2000 only via
software and not using "Twin" mode. In this case:

1) Put a straight through serial cable between the rig's CAT port and the radio RRC's COM2 port

2) Set the serial settings on the radio RRC as follows:
   - set baud rate for COM2 to the same as the CAT rate set in the radio   
   - make sure "use USB Com Port as COM2" is set to NO

3) On the control RRC:
   - first install the Microbit Setup Manager to get the serial drivers installed BEFORE plugging in the RRC
   - set baud rate for COM2 to the same as the CAT rate set in the radio
   - If you wish to use USB instead of a serial cable, set "use USB Com Port as COM2" to YES
   - plug a USB cable between your PC and control-RRC. Make sure you do NOT do his before you install Microbit Setup Manager!
   - find out the correct port in your Windows Device Manager to use by looking for the "Microbit RRC Virtual COM Port (COM2)"
   - Set your software to use the this COM port on your PC at the baud rate you set for COM2 and for CAT in the rig.

Yes, in your case it would be for program mode 4 (Yaesu, Kenwood, Elecraft).

73,
Mitch DJ0QN / K7DX

SM0UXX

  • Jr. Member
  • **
  • Posts: 99
    • View Profile
Re: USB as COM0 (for N1MM)
« Reply #4 on: 2017-11-12, 11:05:36 »
Many thanks for the reply Mitch,
I haven't had any time to play with this for the last weeks but did another try today. In fact I use the Yeasu twin setup, so the control radio is connected to COM2 on the RRC. I have tied all virtual RRC COM ports to a value below 10. For example 'RRC Virtual Comport' is set to COM5.
If I select "Use USB Com Port as COM2" (under serial settings in the control RRC), I can actually set the frequency from N1MM+ - but I get an error message "Invalid CAT data" in the program. Also I can't control the radio at all by the control side radio with this setting.

I have probably missed something essential here  ;D

dj0qn

  • Hero Member
  • *****
  • Posts: 1795
    • View Profile
    • DJ0QN / K7DX
    • Email
Re: USB as COM0 (for N1MM)
« Reply #5 on: 2017-11-12, 19:14:45 »
That was important information that was missing before   :-[

Then go to both RRC's serial settings and set COM1 to mode-7 (copies CAT data to COM1). Then use
COM1 for CAT on either side instead.

73,
Mitch DJ0QN / K7DX

SM0UXX

  • Jr. Member
  • **
  • Posts: 99
    • View Profile
Re: USB as COM0 (for N1MM)
« Reply #6 on: 2017-11-12, 20:34:38 »
Yes, sorry for leaving that out  ::)

I use COM1 for rotator control, so that´s a problem then... (I could of course use the Webswitch for rotator control instead, but not sure if I can run it from my logging program then?).

dj0qn

  • Hero Member
  • *****
  • Posts: 1795
    • View Profile
    • DJ0QN / K7DX
    • Email
Re: USB as COM0 (for N1MM)
« Reply #7 on: 2017-11-12, 22:10:03 »
Yes, that is your only option.

It is no problem to use the Webswitch. You can use it with two methods:
- the web interface
- use a virtual serial server

The manual explains the web interface well. To use the serial server, go to the last tab of
Microbit Setup Manager and install it on the PC(s) that you plan to control it with and
then use any software for control.

73,
Mitch DJ0QN / K7DX

IT9QGH

  • Newbie
  • *
  • Posts: 5
    • View Profile
    • Email
Re: USB as COM0 (for N1MM)
« Reply #8 on: 2018-07-10, 01:12:11 »
Hello Mitch ... I'm sorry but I have a similar situation but I can not make anything work ... I use the yaesu twin mode with control radio ft 950 and tx ft5000 radio, I performed the explanation of the manual by connecting the radios on com port 2, speed 38600 and rts disabled ... nothing to do wrong ... but if I use the PC control unit and Ft5000 radio, it works well ... do you have any suggestions?
Thanks 73 IT9QGH Marcello

dj0qn

  • Hero Member
  • *****
  • Posts: 1795
    • View Profile
    • DJ0QN / K7DX
    • Email
Re: USB as COM0 (for N1MM)
« Reply #9 on: 2018-07-10, 13:13:23 »
Hi Marcello,

The instructions for you are also above:

"Then go to both RRC's serial settings and set COM1 to mode-7 (copies CAT data to COM1). Then use
COM1 for CAT on either side instead."

Did you try that?

73,
Mitch DJ0QN / K7DX

IT9QGH

  • Newbie
  • *
  • Posts: 5
    • View Profile
    • Email
Re: USB as COM0 (for N1MM)
« Reply #10 on: 2018-07-11, 15:21:23 »
Thanks Mitch for answering me ... I still have not tried for the fact that I'm already out of my qth and then I have to ask an acquaintance of mine to go to my house and bring the connector db9 to Com1 .... then the rest (RRC radio) I will go to change in serial mode (Com1) mode 7 copying baud rate .... instead in Com2 how should I set?

dj0qn

  • Hero Member
  • *****
  • Posts: 1795
    • View Profile
    • DJ0QN / K7DX
    • Email
Re: USB as COM0 (for N1MM)
« Reply #11 on: 2018-07-11, 18:04:09 »
Hi Marcello,

NO, that is wrong! You did not understand the instructions correctly, no cable should be changed on the radio side,
otherwise you Yaesu Twin setup will no longer function.

All you need to do is to make one change on the RRC settings, which you can do remotely, assuming you forwarded
the RRC's web port. Here are the instructions again:

- Change the radio RRC's serial settings for COM1 to mode-7. Note that the baud rate does not have to be identical with
COM2 to fit a lower bandwidth or software requirement.

- Change the control RRC's serial settings for COM1 to mode-7. Make the baud rate the same as you made COM1 on the
radio RRC

- If using a "real" serial cable or USB to serial converter cable:
     - connect between the control RRC's COM1 and the PC. If using a USB to serial converter, make sure it is a FTDI
       version and not Prolific
     - The  serial setting for COM1 "Use USB Com Port as COM1" must be set to NO

- If using a USB cable:
     - make sure that first Microbit Setup Manager is installed first on the control PC to get the drivers.
     - Then change the serial settings for COM1 to change "Use USB Com Port as COM1" to YES
     - connect the USB cable between the RRC and computer and wait for the drivers to finish installing
     - go to the Windows Device Manager and look at which virtual serial port was assigned to COM1 and use that for
        your software, taking the correct baud rate into account.

73,
Mitch DJ0QN / K7DX

IT9QGH

  • Newbie
  • *
  • Posts: 5
    • View Profile
    • Email
Re: USB as COM0 (for N1MM)
« Reply #12 on: 2018-07-12, 02:54:17 »
Hello Mitch, I followed your explanations but still nothing ... the yaesu twin system (ft950 control and ft5000 radio) does not work ... I repeat the links ... maybe I still did not understand ... Cat cable ft950 ( control) rs232 connected to Com2 RRc control .... Cat cable ft5000 (radio) rs232 connected to Com2 RRc radio.
The RRc control and radio configuration I followed your explanations.
Excuse me but this situation is making me go crazy ... the manual explains how to make the cables (I followed step by step making them) and I configured as the manual says ... in short it works only in Pc (control) and Ft5000 (radio) ... clearly with other configurations for RRC

dj0qn

  • Hero Member
  • *****
  • Posts: 1795
    • View Profile
    • DJ0QN / K7DX
    • Email
Re: USB as COM0 (for N1MM)
« Reply #13 on: 2018-07-12, 10:53:19 »
Marcello,

Do the radios work in Twin mode ok? is the problem only that you can't get CAT working, or more?

The cable between the radio RRC COM2 and the rig  is a straight through normal serial cable and
the one on the control side a normal null-modem serial cable that can be bought anywhere.

I also noted in the manual on page 149 that they recommend to use mode-6 instead of mode-7 for
COM1. I don't think that will make a difference, but you can try it.

73,
Mitch DJ0QN / K7DX
« Last Edit: 2018-07-12, 11:03:11 by dj0qn »

IT9QGH

  • Newbie
  • *
  • Posts: 5
    • View Profile
    • Email
Re: USB as COM0 (for N1MM)
« Reply #14 on: 2018-07-14, 00:54:04 »
 Hello Mitch ... I'm sorry if I respond late ... I've been very busy with the work and I'll see if with a clear mind next week I'll do something ... hoping to solve the problem and give a perfect detailed explanation to anyone who wants to use the system .... I will keep you updated
73 Marcello IT9QGH