Author Topic: RRC micro changes  (Read 2057 times)

Neil

  • Newbie
  • *
  • Posts: 14
    • View Profile
RRC micro changes
« on: 2017-11-17, 02:45:17 »
I have ordered the RRC MICRO but it is a week away and I will be visiting my remote site (300 KM trip one way tomorrow) I presently am using a TS480  and RRC1258MKII's which work great. Do I need to make changes at the remote site to allow use of the RRC MICRO?
Tks
Neil
VE6TCK

dj0qn

  • Hero Member
  • *****
  • Posts: 1887
    • View Profile
    • DJ0QN / K7DX
    • Email
Re: RRC micro changes
« Reply #1 on: 2017-11-17, 07:06:34 »
Hi Neil,

RRC Micro requires CAT on COM2 to be working using that setup. If you don't yet have CAT installed, you need to take a
serial cable along and set that up.

73,
Mitch DJ0QN / K7DX

Neil

  • Newbie
  • *
  • Posts: 14
    • View Profile
Re: RRC micro changes
« Reply #2 on: 2017-11-18, 05:10:31 »
Thanks Mitch I got the cable installed I am starting to work with Kenwoods ARCP480 for control but I am not able to connect, am I correct in assuming that this software will connect directly to the RRC 1258 MKII with no CPU on site ? I suspect I have an issue with port forwarding or some other such thing .....I realize this is not "kenwood "support but what info you can provide would be helpful.

Thanks
Neil
VE6TCK

dj0qn

  • Hero Member
  • *****
  • Posts: 1887
    • View Profile
    • DJ0QN / K7DX
    • Email
Re: RRC micro changes
« Reply #3 on: 2017-11-18, 06:09:01 »
Hi Neil,

It is much simpler than that. From your comments, I assume you didn't read the manual. Anyway,
I have a checklist for setting-up CAT on the TS-480 as follows:

CAT CHECKLIST
---------------------
IMPORTANT: In both scenarios, you MUST first install a standard serial cable between the TS-480 body and COM2 of the radio RRC!

USING A STANDARD SERIAL CABLE
============================
1) Change the CAT rate on the TS-480 to 4800 baud (menu 56). This rate keeps traffic over the internet to a minimum and faster is not necessary for CAT.

2) Change the COM2 serial settings of the radio-RRC to mode-4, 4800 baud, data bits 8, stop bits 1 and submit/apply changes.

3) Change the COM2 serial settings of the control-RRC to mode-4, 4800 baud, data bits 8, stop bits 1 and submit/apply changes.

4) Plug a serial cable in between your PC and the control-RRC COM2

5) Set your software to use the correct COM port on your PC at 4800-8-1-N

USING A USB CABLE
=================
1) Change the CAT rate on the TS-480 to 4800 baud (menu 56). This rate keeps traffic over the internet to a minimum and faster is not necessary for CAT.

2) Change the COM2 serial settings of the radio-RRC to mode-4, 4800 baud, data bits 8, stop bits 1 and submit/apply changes.

3) Install the Microbit Setup Manager if you already haven't. You don't need the problem for this, but this installs the correct drivers on your PC.

4) Change the COM2 serial settings of the control-RRC to mode-4, 4800 baud, data bits 8, stop bits 1, "use USB Com Port as COM2" to "Yes" and submit/apply changes.

5) Plug a USB cable between your PC and control-RRC. Make sure you do NOT do his before step 3 above!

6) Find out the correct port in your Windows Device Manager to use by looking for the "Microbit RRC Virtual COM Port (COM2)"

7) Set your software to use the this COM port on your PC at 4800-8-1-N.

I assume this solves your problem.

73,
Mitch DJ0QN / K7DX

Neil

  • Newbie
  • *
  • Posts: 14
    • View Profile
Re: RRC micro changes
« Reply #4 on: 2017-11-18, 21:58:17 »
Thanks for the check list Mitch that will be helpful  to many I did read the manual but my comprehension may have been lacking ( I suffer from a diagnosed learning disability and am old enough to remember 8" floppies hihi)  I try to stay abreast of technology but it might be winning. I will keep at it ...but back to the question I posed. Will my local rig control software in this case ARCP480 communicate and control the RRC1285MKII on the remote site with out a computer on that site? I am lead to believe this from the graphic on the RRC micro PC Client page. My  RRC Micro will be here Monday and I will be back at it in earnest.

TKS
73
Neil
VE6TCK

dj0qn

  • Hero Member
  • *****
  • Posts: 1887
    • View Profile
    • DJ0QN / K7DX
    • Email
Re: RRC micro changes
« Reply #5 on: 2017-11-18, 22:26:19 »
Hi Neil

Sorry, I thought that answer was obvious.  Any kind of software supporting CAT will work, i.e. dozens of programs including that one

73,
Mitch DJ0QN / K7DX

Neil

  • Newbie
  • *
  • Posts: 14
    • View Profile
Re: RRC micro changes
« Reply #6 on: 2017-11-18, 22:28:49 »
Thanks
73
Neil
VE6TCK

Neil

  • Newbie
  • *
  • Posts: 14
    • View Profile
Re: RRC micro changes
« Reply #7 on: 2017-11-28, 04:15:30 »
Still no joy here I have the RRC 1258 connected to the TS480 with a serial cable I can connect with RRC micro and have flashing LED's for RTP & RRC but no audio. When I try to connect with ARCP 480 I receive the message " Unknown device connected to COM2 or baud rate in this software does not match transceiver"  I am using ver 2.88 and a 1274B  with windows 7 I have checked that ports are open and checked the speeds in the radio and RRC's. The RRC's work fine with the control face of the TS480 at this QTH  so the system works fine in that sense. Again to confirm I DO NOT need a CPU at the remote site, simply connecting the RRC1258 to the TS480 via a serial cable on COM2 should allow CAT control of the radio with ARCP480.

Neil

dj0qn

  • Hero Member
  • *****
  • Posts: 1887
    • View Profile
    • DJ0QN / K7DX
    • Email
Re: RRC micro changes
« Reply #8 on: 2017-11-28, 05:27:48 »
Neil,

It is really straightforward and I can't understand why you would have a problem. The hard part is
getting the RemoteRig system to work in the first place, which you already have. Then all you do is
to make sure that CAT is setup per my checklist. Then set RRC Micro to use that serial port and the
other connectivity settings (SIP contact, password and ports) as you do in the RRC. After hitting connect, it
should indicate a connection and then you can start any CAT program to use at that point.

So let me make some random comments and ideas what you can look for:

- No computer is involved on the radio side
- You can test CAT to see if it is working by connecting a PC on the control side to the RRC's COM2 
per my checklist and using a program of your choice.
- Audio has nothing to do with CAT, it comes through the same SIP connection that you use for the control
RRC. If it works for the RRC, it must work on the RRC Micro, assuming you entered the settings correctly.
- No ports need to be opened in Windows, this is outgoing.
- Did you set the CAT rate in the TS-480 to match the RRC (step 1 on my checklist)? In ARCP-480 as well?
- Are you using the correct Windows virtual serial port for COM2 for ARCP-480?

Go through this list and see if it helps. If you need any help and will only be at the station a short time, I can
take a look via Teamviewer and see what is wrong. In that case, mail me directly at dj0qn (at) darc.de and
I will see when I get a chance.

73,
Mitch DJ0QN / K7DX



Neil

  • Newbie
  • *
  • Posts: 14
    • View Profile
Re: RRC micro changes
« Reply #9 on: 2017-11-30, 19:09:47 »
I certainly agree setting up the RRC initially is the difficult part usually, I have gone thru the check list and believe I have it set up right I have confirmed the proper speed in the RRC com port as well as in
The ARCP480 and the TS480  Menu.  I am at quite a loss, I spoke to VE6WZ one city to the south he is using a very similar installation with no issues. I can connect with RRC Micro but there is no audio on a windows 10 and 7 CPU using the internal sound card and drivers or with a blue tooth or wifi audio headset (Steve suggested it as a possible solution )  I may take a bit of a break with the xmas season but I will be sure to report the final solution thanks for your help Mitch.
Neil

dj0qn

  • Hero Member
  • *****
  • Posts: 1887
    • View Profile
    • DJ0QN / K7DX
    • Email
Re: RRC micro changes
« Reply #10 on: 2017-12-01, 07:10:30 »
Neil,

It is probably a very simple problem that will take a minute to solve.

Anyway, if the problem is lack of audio and the connect indicates an audio stream, then your problem
is your Windows settings. Open up the sound card settings and switch to the sound card output that you
set in the RRC Micro. Then adjust the audio there and I bet that solves the problem.

73,
Mitch DJ0QN / K7DX

Neil

  • Newbie
  • *
  • Posts: 14
    • View Profile
Re: RRC micro changes
« Reply #11 on: 2017-12-03, 00:22:50 »
I agree it would appear to be a set up problem in windows, I have tried it on 2 windows 10 cpu's 1 window 7  on two different networks. I have upgraded application firmware on both RRC to 2.91.  I have tried several audio devices( blue tooth headset etc)  I test the audio cards/ devices with windows as well as other audio sources and they work fine. Here is where it gets confusing when Steve VE6WZ sets me up as a contact in his RRC micro he has the same issue I have he can connect but no audio, he uses the same equipment to connect to his site everyday. ....it is a mystery.

Neil

Neil

  • Newbie
  • *
  • Posts: 14
    • View Profile
Re: RRC micro changes
« Reply #12 on: 2017-12-03, 00:25:31 »
I forgot to mention when I am connected to my RRC site status reports "Connection status faulty (see below) UDP CMD status error (0)" 

Neil

Neil

  • Newbie
  • *
  • Posts: 14
    • View Profile
Re: RRC micro changes
« Reply #13 on: 2017-12-03, 00:29:44 »
PSS At this point in time I am working on only getting the RCC micro to work CAT is on the back burner a friend is going in to the hospital and I want to get him on HF even with out control of the rig.

NB

Neil

  • Newbie
  • *
  • Posts: 14
    • View Profile
Re: RRC micro changes
« Reply #14 on: 2017-12-03, 03:16:54 »
Some progress I am now able to connect to VE6WZ site, on his recommendation I adjusted the jitter size,delay and packet size I settled on 11, 9 and 40. So this proves I have a viable CPU/sound card combination. Sadly I have made adjustments on my own RRC micro client and have been rewarded with nothing but dead air. 

Neil