Author Topic: Poor/No CAT Control  (Read 306 times)

WZ4M

  • Newbie
  • *
  • Posts: 3
    • View Profile
Poor/No CAT Control
« on: 2018-01-08, 23:26:48 »
I'm trying to set up a pair of RRC with an Elecraft KX3.  Right now everything is just on a local LAN and I'm only trying to get CAT control working.  I'm using a Prolific based USB to Serial connection to the RRC Control and a homebrew DB9 to 3.5mm stereo cable from the RRC Radio to the KX3 ACC1.  Using these cables only (USB to serial connected to homebrew cable to KX3) CAT control works just fine, 38400 baud.  Things go sideways when I try to go through the RRC instead.

RRC Control Serial Settings
Com2 Mode - Mode 4
Com2 Baudrate - 38400, 8, 1, No Parity, 00 Terminator,
Use USB Com as COM2 - No

RRC Control Radio Settings
Program Mode 4
Com0 - 38400, 8, 1, No Parity,
Use USB Com as Com0 - No

RRC Radio Serial Settings:
Com 2 Mode 4
Com 2 - 38400, 8, 1, No Parity, 00 Terminator
USe USB Com Port as COM2 - No

RRC Radio Radio Settings:
Program Mode 4
Com 0 Baud - 38400, 8, 1, 0 Parity
Use USB Com Port as Com0 - No

RRC Control Status
Name   Value
P5.4   OFF
Radio   OFF
Connection status   OK
SIP status   Connected/transfering
Last SIP error   None
RTP status   Excellent(60)
UDP cmd status   OK(26)

If I connect to an antenna I get audio, but I don't even have that connected anymore. OCCASIONALLY I can use the KX3 utility or WIN4K3Suite to connect, and once I even got Win4K3 to send frequency, but I couldn't change freq and it wouldn't follow the radio.  90% of the time I can't seem to make a connection at all or it seems to hang on making a connection (it's hard to tell what's really happening). 

This seems so elementary but I can't get past it.  I don't understand what Com0 actually does and if the settings need to match Com2 on either/both RRC.  P5.4 and P5.2 are OFF on my units and not in the documentation pictures, but I can't find any information on what those mean. I would suspect my cable except for the fact that it works FB when I'm straight serial. I can't figure out where to look.  What am I missing?  Suggestions?  Is there a way to see serial status within the RRCs?

Vy73,
Tommy WZ4M

dj0qn

  • Hero Member
  • *****
  • Posts: 1769
    • View Profile
    • DJ0QN / K7DX
    • Email
Re: Poor/No CAT Control
« Reply #1 on: 2018-01-09, 00:18:49 »
Hi Tommy,

If you are running only one rig, then put the CAT with a real serial cable to COM2 of the radio RRC.

On the control side, use COM2 either through a real serial cable, the Prolific cable, or the built-in USB serial port
by changing the setting of the control RRC's COM2 to use USB to yes.

73,
Mitch DJ0QN / K7DX

WZ4M

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Poor/No CAT Control
« Reply #2 on: 2018-01-09, 00:25:35 »
That's exactly how I have it set up.  I probably wasn't clear about that. Radio side COM2 goes to the KX3 ACC1 (cat control) port using a DB9 to 3.5mm serial.  Control side is USB-Serial to Com2.  I also tried using USB as Com2 at one point, but made no further success so I went back to the USB-Serial to Com2 to make things easier.  Or so was the thought.  Seems like it should be straight forward, but no dice.

WZ4M

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Poor/No CAT Control
« Reply #3 on: 2018-01-09, 02:05:24 »
Welp, I did a reset to factory defaults on both units and started again.  No problems now.  Go figure.  Running everything at 9600 baud which should be fine so long as I don't try to load firmware over it and it's as slow as Win4K3 will go. 

dj0qn

  • Hero Member
  • *****
  • Posts: 1769
    • View Profile
    • DJ0QN / K7DX
    • Email
Re: Poor/No CAT Control
« Reply #4 on: 2018-01-09, 04:00:59 »
That is what Ham Radio is all about....sometimes things work the way they should,
sometimes they don't. Would be too boring otherwise   ;)

Glad you got it working.

73,
Mitch DJ0QN / K7DX