Author Topic: TS-2000/RC-2000 - No mic level in digital modes  (Read 512 times)

ea3geo

  • Newbie
  • *
  • Posts: 20
    • View Profile
    • Email
TS-2000/RC-2000 - No mic level in digital modes
« on: 2019-01-17, 14:44:50 »
Dear OM's,

I'm blocked in something that should be easy but I don't find what it is.

I've got my pair of RRC-1258 with a TS2000 on the radio side and the RC2000 on the control side. All built as per the instructions. All working perfectly after many years. With standard phone SSB all goes well.

I was wondering if FT8 could be worked remotely (not sure due to the sync time requirements) and I decided to go the easy way: An standard stereo cable from the RRC speaker to mic input in the PC and I produced a cable from the computer speaker to the MJ-88 Kenwood cable used for the AUX/Mic RRC port.

The cable I produced is very simple: A 3,5 mm mono jack with the live microphone line to pin 1 and ground microphone to pin 7.

The result is fine FT8 reception but no mic level at all, so no TX. There is no ALC reading in the radio.

I don't see where's my mistake.

Any ideas???

73 ES GD DX DE EA3GEO

dj0qn

  • Hero Member
  • *****
  • Posts: 2051
    • View Profile
    • DJ0QN / K7DX
    • Email
Re: TS-2000/RC-2000 - No mic level in digital modes
« Reply #1 on: 2019-01-17, 18:24:32 »
You actually connected it the recommend way, so it should work.

I have found that most issues are Windows related; you need to go to the audio setting under
Windows and make sure that the audio level is set correctly. BTW, it is recommended to not use
the speaker jack, but instead the line out jack. This offers a constant and separate output, independent
of the speaker controls. Not all PC's offer this, however.

I also recommend that you spend the 10 and buy a USB sound card for the PC. This solves several problems:
- Better quality audio
- Separate Windows inputs and outputs with audio controls that can be kept at a constant level
- A line out jack

73,
Mitch DJ0QN / K7DX

ea3geo

  • Newbie
  • *
  • Posts: 20
    • View Profile
    • Email
Re: TS-2000/RC-2000 - No mic level in digital modes
« Reply #2 on: 2019-01-17, 20:45:24 »
Hi Mitch, thank you. I really appreciate your help.

I have in fact a USB sound card, this is an iMic. The out can be selected to be LINE or MIC. I started first doing my tests with that one. But when I saw there wasn't results I switched to use the direct PC soundcard.

I have now make a check: I have put an speaker to the OUT jack in the iMic and if I press the tune option in WSJT-X I can clearly hear the tone. It's very very puzzling.

In normal phone operation, with the original Kenwood microphone, this works perfect.

It could be (it should be) the cable I did. But I don't see my mistake there. The head of the jack goes to 1 and the ground goes to 7. I didn't connect any other cable, just these two.

I'm thinking on doing a direct cable to the RJ45 connector (???).

I'll let you know. Thanks!!

73 de EA3GEO, Daniel

ea3geo

  • Newbie
  • *
  • Posts: 20
    • View Profile
    • Email
Re: TS-2000/RC-2000 - No mic level in digital modes
« Reply #3 on: 2019-01-17, 23:47:07 »
Well, still in the mess in here...

New tests done:

-Direct cable from speaker out to RJ45 AUX/Mic in RRC (tests with both iMic OUT and speaker jack from PC): The same.

-Tests with a diferent computer: The same!

To summarize, is like if you were in phone SSB, you pressed the micro and you stay silent: PTT is on (I can see that in the RC2000) but no ALC/Mic level at all.

If I disconnect the AUX/Mic input to the RRC and I connect that to an external speaker, I can hear the signal sent by WSJT-X...

Well, right now, I don't know what to do. I better go to sleep...  :)

dj0qn

  • Hero Member
  • *****
  • Posts: 2051
    • View Profile
    • DJ0QN / K7DX
    • Email
Re: TS-2000/RC-2000 - No mic level in digital modes
« Reply #4 on: 2019-01-18, 02:52:06 »
Hard to say from here what you did wrong. The cabling is super simple. I usually suggest that one
takes an old ethernet cable and uses that. All you need are the two wires to go to a plug that goes
to the line out of the sound card.

Note that the red straps in the RRC determine the pinout used by the AUX/MIC jack. This may vary
between different types of rigs and microphones, so take another look at that.

Otherwise, my previous comment is valid that it is often a setting in the operating system that prevents
this from working. The correct sound card needs to be selected and the audio set to the correct level.

Good luck today.

73,
Mitch DJ0QN / K7DX

sm2o

  • Administrator
  • Hero Member
  • *****
  • Posts: 2576
    • View Profile
    • sm2oan
    • Email
Re: TS-2000/RC-2000 - No mic level in digital modes
« Reply #5 on: 2019-01-18, 08:30:27 »
Hi as you probably do not have any hardware PTT you need to set RTP-TX to continuous so the Mic audio stream is always open. Maybe it's already said above

73 de mike

ea3geo

  • Newbie
  • *
  • Posts: 20
    • View Profile
    • Email
Re: TS-2000/RC-2000 - No mic level in digital modes
« Reply #6 on: 2019-01-18, 20:24:16 »
Fixed! Thank you Mike!

Yes, it was the RTP-TX. When changed to continuous, this worked at first attempt.

Isn't that weird that all was working fine in SSB phone but not at all in digital modes?

In any case, thank you to both, Mitch and Mike, for your assistance.

73 from EA3GEO, Daniel

dj0qn

  • Hero Member
  • *****
  • Posts: 2051
    • View Profile
    • DJ0QN / K7DX
    • Email
Re: TS-2000/RC-2000 - No mic level in digital modes
« Reply #7 on: 2019-01-19, 03:53:15 »
Glad to hear that you got it working, Daniel.

I assumed that you were using PTT, so Mike was right. People need to know that
also to use SSB with VOX, it is necessary to change RTP to continuous.

Glad you got it working!

73,
Mitch DJ0QN / K7DX