Author Topic: cable TS-480 to microphone connector  (Read 251 times)

HB9CVN-4F3CV

  • Newbie
  • *
  • Posts: 18
    • View Profile
cable TS-480 to microphone connector
« on: 2019-04-16, 22:01:56 »
hi,

I have everything working to the point that WSJT-X get the audio from the radio and show the traffic. Also the PTT works fine, turning the radio to TX when needed.

Now I have to bring the audio from the PC to the RJ45 AUX/MIC of the remoterig.

Taken apart a network cable and according to ts-480 mircophone pinout, I should use the contacts 5 and 6, which should be the white/blue and green.

Connected these two contact to a mono jack. White/Blue to the ground pin and green to the tip one.


As soon as I insert the jack into the PC headphone socket,  the TS-480 goes to TX.

VOX is off.

No doubt I am doing something wrong... What?????


The microphone works fine, so it shouldn't be a jumper related problem
« Last Edit: 2019-04-16, 22:24:45 by HB9CVN-4F3CV »

La1zm

  • Newbie
  • *
  • Posts: 25
    • View Profile
Re: cable TS-480 to microphone connector
« Reply #1 on: 2019-04-17, 15:58:33 »
Hi
I am using wsjt-x and it is working fine via remoterig and ts-480. I am using two trafos for audio between rrc and pc (rpi), and using a optocoupler for ptt (with usb-rs232 adaptor and DTR).
My connections:
Mic-3
Mic gnd-4
Ptt-5
Ptt gnd- 6
Audio from rrc via sp.

73 de
Alf, la1zm

HB9CVN-4F3CV

  • Newbie
  • *
  • Posts: 18
    • View Profile
Re: cable TS-480 to microphone connector
« Reply #2 on: 2019-04-17, 17:13:25 »
thanks Alf,

then the pins are correct for the microphone. The PTT goes via CAT and works.

Is it necessary to have the transformer? I was using pin 3 and 4 but with a cable between the hedphones out of the PC and the AUX/MIC RJ45 of the remotering.

When WSJT-X is  switching to TX, I do have the audio at the headset  PC socket. But connecting the cable to the remotering produces no modulation at all

VK3ALB

  • Jr. Member
  • **
  • Posts: 42
    • View Profile
Re: cable TS-480 to microphone connector
« Reply #3 on: 2019-04-18, 00:14:48 »
I am looking at A38 version of the user manual. On P189 there is a schematic of the AUX/MIC cable. It shows the MIC signal is on pin 3 and the GND is on Pin 4. You should trust this.

There is no need for a transformer, there is already one inside the RRC.

If you get no modulation from your PC cable it could be that you are grounding the audio at the RRC. Have you tried reversing the connections at the RRC?
Lou
VK3ALB

La1zm

  • Newbie
  • *
  • Posts: 25
    • View Profile
Re: cable TS-480 to microphone connector
« Reply #4 on: 2019-04-20, 18:13:41 »
Hi
If ptt goes via cat you have to put RTP
Tx mode to continuous (advanced setting control side).
73 de Alf, la1zm

K1IKE-Joe

  • Jr. Member
  • **
  • Posts: 90
    • View Profile
    • Email
Re: cable TS-480 to microphone connector
« Reply #5 on: 2019-04-21, 12:02:11 »
Setting RTP to continuous will fix this problem, but can cause excessive data use on a metered service like cell phone data service.  Also, as the manual says, it also can be a security issue.

I'm using WSJT-X at the RCC console end and finally got it working properly by NOT using the CAT PTT option.  There seems to be an issue with passing audio thru the Mic jack on the control RCC when PTT is not active.  I don't want to use RTP set to continuous because the primary use of the RemoteRig setup is for SSB.  I opted to use the DTR method of PTT in WSJT-X software for the Kenwood TS480.  This requires another serial COM port, but works well.  I'm presently using a RigBlaster nomic interface and 2 USB-to-serial adapters on my laptop computer.

During troubleshooting I watched the serial data stream coming from the computer to the control RRC.  The WSJT-X software sends the CAT command "TX;" instead of "TX0;" when using CAT PTT.  I compared this to Ham Radio Deluxe and the Kenwood ARCP software that uses the "TX0;" command for PTT.  At first I thought this was a problem, but the Kenwood documentation says that the command "TX;" will default to "TX0;". (see the attachment)

If you don't want to use 2 COM ports (one for CAT and the other for PTT) you can use the Signalink-USB and eliminate the need for a USB to Serial adapter.  But, you will have to use the VOX option within the Signalink to provide PTT.  Not always the best choice, but it should work.

73, Joe, K1ike