Author Topic: Configuration of N1MM with K3 Twins RRC 1258  (Read 590 times)

N2SO

  • Newbie
  • *
  • Posts: 8
    • View Profile
Configuration of N1MM with K3 Twins RRC 1258
« on: 2019-05-04, 19:04:32 »
Hi,
I recently installed a private K3-Remote System using my existing K3 and adding a K3/Ø Mini Control Panel. I have the RRIGSET and all required cables installed. I have tested the system and it appears to work well as I can both hear and control the remote radio and send CW on my straight key plugged into the back of the K3/Ø. 
I would like to add the N1MM contest program using windows 10 Lap Top locally with a USB cable running from the USB socket on the front of the RRC to my Lap Top. I have configured both RRCs COM1 to: “Mode-7 CAT to COM2 (local & remote)”.  The serial setting for COM1 has been set “Use USB Com Port as COM1” to YES. COM3 (extra) mode has been set to “Mode -8 Winkeyer”.
RRC 1258 Ø (COM 1)
RRC 1258 1(COM 11)
RRC 1258 2 (COM 12)
RRC 1258 3 COMExtra (COM 2)
So far I have been unable to configure N   1MM to communicate with my K3 remote. COM 11 doesn’t work and COM12 produces unsolicited and random CW transmissions. COM2 make no difference.  Interestingly, I can use my K3 remote with SKCCLogger with COM2. Any assistance would be greatly appreciated.

73 Charles N2SO



dj0qn

  • Hero Member
  • *****
  • Posts: 2051
    • View Profile
    • DJ0QN / K7DX
    • Email
Re: Configuration of N1MM with K3 Twins RRC 1258
« Reply #1 on: 2019-05-04, 19:10:19 »
harles,

You must use COM11.

You wrote that you set “Use USB Com Port as COM1” to YES. In that case, are you using the standard USB cable without adapter between the RRC and PC?

73,
Mitch

N2SO

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: Configuration of N1MM with K3 Twins RRC 1258
« Reply #2 on: 2019-05-04, 19:50:11 »
Yes, Mitch. At the control I am using a simple USB cable to my PC. No adapter. I do have the Elecraft USB adapter cable on hand which I tried plugging into COM1 on the front of RRC control, but it did not work.
I tried COM11 but it is not recognized by N1MM.

73, Charles N2SO

dj0qn

  • Hero Member
  • *****
  • Posts: 2051
    • View Profile
    • DJ0QN / K7DX
    • Email
Re: Configuration of N1MM with K3 Twins RRC 1258
« Reply #3 on: 2019-05-04, 19:52:59 »
Hi Charles,

Plugging into the K3/0 Mini won't work when using the RRC. You can only use
the RRC.

Then you need to look at the settings in the K3 and N1MM. Make sure that are are
exactly the same baud rate:
- RRC COM1 on both sides
- K3 menu RS232
- N1MM

Again, you need to use COM11.

73,
Mitch DJ0QN / K7DX

dj0qn

  • Hero Member
  • *****
  • Posts: 2051
    • View Profile
    • DJ0QN / K7DX
    • Email
Re: Configuration of N1MM with K3 Twins RRC 1258
« Reply #4 on: 2019-05-04, 20:21:35 »
Correction: the K3 menu RS232 should match the COM2 settings. COM1 can be a
different setting. It is a must for the COM2, not COM1.

73,
Mitch DJ0QN / K7DX

N2SO

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: Configuration of N1MM with K3 Twins RRC 1258
« Reply #5 on: 2019-05-05, 01:45:16 »
Oh, yes I plugged the RS232 cable on the remote K3 into COM2 on the back of the remote RRC.

dj0qn

  • Hero Member
  • *****
  • Posts: 2051
    • View Profile
    • DJ0QN / K7DX
    • Email
Re: Configuration of N1MM with K3 Twins RRC 1258
« Reply #6 on: 2019-05-05, 02:05:49 »
Hi Charles,

This is the sort of thing you should have sent me directly and not over this Forum.

Anyway, like I wrote before, there are no RRC settings beyond serial that affect CAT at
all. You need to look at the settings in N1MM. The RRC settings are fine.

Do you have a USB to serial converter available, preferably with an FTDI chip? If so, use
that instead of the USB cable on COM1 of the RRC. In that case, you would need to set
“Use USB Com Port as COM1” to NO and use the serial port of the converter cable. You may
be experiencing driver problems with the RRC's built-in converter. That occurs a lot.

73,
Mitch DJ0QN / K7DX




N2SO

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: Configuration of N1MM with K3 Twins RRC 1258
« Reply #7 on: 2019-05-05, 03:38:55 »
Sorry about the attachments, Mitch. It certainly won't happen again. I do have such a cable which I purchased from Elecraft. I removed the other USB cable and plugged the KUSB  to COM1 on the RRC and to my Lap Top. I changed the serial setting on the RRC to "Use USB COM port to COM 1" to NO.  The device manager assigned COM3 to this cable. When I changed the N1MM port for the K3 radio to COM3  and pressed OK, I got a blinking red light on the Cable and the same message of no communication. Perhaps there is something wrong with the cable? Or driver settings? What about the K3 emulator?

Thanks again, Mitch.

73 Charles N2SO

dj0qn

  • Hero Member
  • *****
  • Posts: 2051
    • View Profile
    • DJ0QN / K7DX
    • Email
Re: Configuration of N1MM with K3 Twins RRC 1258
« Reply #8 on: 2019-05-05, 03:59:37 »
Hi Charles,

Hard to say, at least that should have worked. I still think the problem is with N1MM somewhere.

Let's make a time for me to take a look using Teamviewer. Please contact me directly to arrange it.
I think that I will be home on Sunday afternoon.

73,
Mitch DJ0QN / K7DX

N2SO

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: Configuration of N1MM with K3 Twins RRC 1258
« Reply #9 on: 2019-05-05, 16:31:22 »
That would be great Mitch. I am assuming you are in the Eastern Time Zone? I am presently in LA so I am guessing 2hrs from now or later? Just text or call me at 718.612.2019 when you are ready and I will have everything up and running.

73, Charles N2SO

dj0qn

  • Hero Member
  • *****
  • Posts: 2051
    • View Profile
    • DJ0QN / K7DX
    • Email
Re: Configuration of N1MM with K3 Twins RRC 1258
« Reply #10 on: 2019-05-05, 16:33:55 »
Hi Charles,

Yes, I am still in Florida and can't leave for Germany until a bit later this summer.

It will be sometime between 1 and 5 pm my time, but will try as early as possible.

73,
Mitch DJ0QN / K7DX

N2SO

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: Configuration of N1MM with K3 Twins RRC 1258
« Reply #11 on: 2019-05-05, 17:50:13 »
Fine. See you later.

N2SO

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: (RESOLVED)Configuration of N1MM with K3 Twins RRC 1258
« Reply #12 on: 2019-05-05, 23:55:05 »
Thanks to Mitch DJ0QN we worked out that one of the N1MM settings was off by one digit. The stop bits on K3 COM3 port was set at 2 instead of 1. Also we decided to give up on the RRC COM ports and instead installed the Elecraft KUSB interface cable running from COM1 on the front of the control RRC to my Lap Top. Of course that does not install the the Winkey Emulator, but hey when all else fails there's always the reliable straight key!
As also pointed out by Dennis W1UE, there is even a work around for that involving the use of the small MORTTY CW keyer which can be plugged into the remote system to accomplish the same thing.

Thanks to all who read my original post and wondered how to help.

73, Charles N2SO

dj0qn

  • Hero Member
  • *****
  • Posts: 2051
    • View Profile
    • DJ0QN / K7DX
    • Email
Re: Configuration of N1MM with K3 Twins RRC 1258
« Reply #13 on: 2019-05-06, 03:47:24 »
Hi Charles,

I forgot about that. It only takes a minute to switch back to the USB cable. Give it a try yourself, you
already know how to set it up and change the stop bit. Apparently N1MM has a "feature" that defaults
to two stop bits instead of one.

73,
Mitch DJ0QN / K7DX

N2SO

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: Configuration of N1MM with K3 Twins RRC 1258
« Reply #14 on: 2019-05-08, 01:50:48 »
Hi Mitch,

Well, I have been playing with the Winkeyer Emulator for the last couple of days. There are very few choices of settings, but nothing seems to work. I can't say I am surprised since the other RRC COM ports don't work either. But I have had no problems since we switched to the Elecraft KUSB cable and configured N1MM correctly. I didn't bring my paddle with me and I only have the straight key which is built for travel, (Czech Military Key) so I am a bit limited contest wise. But I tried out a QSO Party last weekend and had no trouble.

73 Charles N2SO