Author Topic: K3 twin with RRC issues  (Read 69 times)

on4iq

  • Newbie
  • *
  • Posts: 28
    • View Profile
    • the ON4IQ pages
    • Email
K3 twin with RRC issues
« on: 2019-10-11, 18:57:15 »
Well i've been struggling to get a K3 twin setup running in the shack.
Here are the odd things:
- i am only able to get a k3twin working if the control side has the USB plugged into the RRC, i've have a 12v/4amp power adapter for it, but no USB plugged in means K3 switches off at radio side
- i am unable to get any cat data to com1, tried all possible serial choices (mode 6-7-11) but no cat data on the radio siden no cat data on control end

I tried cross, straight connection via breakout box, just in case cabling was wrong, still no result
Its an old RRC set , MkII though, but i'm starting to think the issue is in the RRC itself (the usb cable thing is weird)

Anyone experienced this.?


dj0qn

  • Hero Member
  • *****
  • Posts: 2060
    • View Profile
    • DJ0QN / K7DX
    • Email
Re: K3 twin with RRC issues
« Reply #1 on: 2019-10-11, 19:11:46 »
This sounds like a power supply problem. It must work without the USB cable in it.

Here is my K3 CAT Checklist:

 CAT Checklist for K3 Twin
----------------------------------
Note first that in a "Twin" configuration, COM2 is used to "tie" the two ends together and carries the CAT data. In order to access CAT, you need to get to COM2 without touching it. The easiest method is to duplicate COM2 over COM1 using a function in the RRC as follows:

- Change both RRC's COM1 to mode-7. Note that the baud rate does not have to be identical with COM2 to fit a lower bandwidth or software requirement.

- If using a "real" serial cable:
     - connect a straight through serial cable between the control RRC's COM1 and the PC. If using a USB to serial converter cable, make sure it is using an FTDI chipset.
     - note that if you also use the radio RRC's COM1, the pinout is not the standard straight-through serial port. Use the pinout description in the RemoteRig manual, or just try a null-modem cable which usually works (may need a gender changer).
     - the  serial setting for COM1 "Use USB Com Port as COM1" must be set to NO

- If using USB:
     - make sure that first Microbit Setup Manager is installed first on the control PC to get the drivers.
     - Then change the serial settings for COM1 to change "Use USB Com Port as COM1" to YES
     - connect the USB cable between the RRC and computer and wait for the drivers to finish installing
     - go to the Windows Device Manager and look at which virtual serial port was assigned to COM1 and use that for your software, taking the correct baud rate into account.

Note also that you can pull CAT data in parallel off of the radio RRC to use a PC on that end, or to sync with a remote device (amplifier, SteppIR, etc.)

73,
Mitch DJ0QN / K7DX

on4iq

  • Newbie
  • *
  • Posts: 28
    • View Profile
    • the ON4IQ pages
    • Email
Re: K3 twin with RRC issues
« Reply #2 on: 2019-10-11, 19:42:17 »
Tnx Mitch,
its was the powersupply, actually both powersupply that came with this 2nd hand rrc set are no good.
this affects the rs232 ports aswell.

s