Author Topic: Hum Problem with 2.35 and USB COM2  (Read 5772 times)

dj0qn

  • Hero Member
  • *****
  • Posts: 1883
    • View Profile
    • DJ0QN / K7DX
    • Email
Hum Problem with 2.35 and USB COM2
« on: 2011-03-31, 15:33:35 »
I have a user that has a problem that I am unable to duplicate with my set-up.

His installation has been working just fine until now. He upgraded to be able to use
the new USB to COM2 feature of firmware 2.35.

However, he starts gets a loud hum come after about two minutes of turning the
TS-480 on, and the head turns off at that point. Here are some details:

- TS-480 head with RRC firmware 2.35 (upgraded shortly before problem started)
- New USB as serial feature enabled ("Use USB Com Port as COM2")
- Appears that the RRC maintains connection to station RRC after head turns off
- Cables (ethernet, RRC--> head) checked and ok
- Swapped power supply with no change
- Removing USB cable makes hum continuous
- Changing "Use USB Com Port as COM2" back to NO, solves the problem,
   but of course doesn't allow the CAT through USB

I can send an MP3 if someone wants to listen to the problem.

I would say that this is a bug in 2.35, but as I said, I can't duplicate it locally.

73,
Mitch DJ0QN / K7DX



ON4AOI

  • Sr. Member
  • ****
  • Posts: 295
    • View Profile
    • Email
Re: Hum Problem with 2.35 and USB COM2
« Reply #1 on: 2011-03-31, 17:37:46 »
Mitch,
I had / have the same problem when there is a connection to
a computer audioin for afsk/fsk, didn't look further cause I am
rebuilding the setup and unplugged the audio cable.

Will investigate when all is connected again, probably end next
week

Guy ON4AOI   

Jan (Microbit)

  • Software Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1796
    • View Profile
    • Email
Re: Hum Problem with 2.35 and USB COM2
« Reply #2 on: 2011-04-07, 10:18:02 »
We have found what most likely is causing this problem. It will be fixed in the coming 2.36 version. It happens as you already have noticed when using the USB Com port as COM2, but also requires data to come in from the radio RRC while the USB Com port isn't opened by the PC.
Always include type of hard/software and version when asking for support.

dj0qn

  • Hero Member
  • *****
  • Posts: 1883
    • View Profile
    • DJ0QN / K7DX
    • Email
Re: Hum Problem with 2.35 and USB COM2
« Reply #3 on: 2011-04-07, 10:22:31 »
Thanks for the great news, Jan.

I was about to get the user to make some tests removing the power cable (it is a notebook PC),
but I will put that on hold until 2.36 is out. He first removed the headset as Guy suggested, but
that didn't make a difference. If you need a beta tester, I can send the firmware to him.

Part of my problem is this user is not very good with computers and lives a long ways from me.

73,
Mitch DJ0QN / K7DX


sm3ccm

  • Newbie
  • *
  • Posts: 25
    • View Profile
Re: Hum Problem with 2.35 and USB COM2
« Reply #4 on: 2011-04-07, 11:27:35 »
Mitch.

Have you tried to help your friend using www.teamviewer.com , an excellent German program
and the best thing, it's free for personal use.

73 de Lars  SM3CCM   

dj0qn

  • Hero Member
  • *****
  • Posts: 1883
    • View Profile
    • DJ0QN / K7DX
    • Email
Re: Hum Problem with 2.35 and USB COM2
« Reply #5 on: 2011-04-07, 11:37:13 »
Thanks, Lars, yes, I have used that program for several users. In this case, I also need
to explain hardware as well as software. I have been able to talk him through firmware
updates, etc., but will of course revert to Teamviewer if he has problems.

73,
Mitch DJ0QN / K7DX

Jan (Microbit)

  • Software Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1796
    • View Profile
    • Email
Re: Hum Problem with 2.35 and USB COM2
« Reply #6 on: 2011-04-15, 09:59:13 »
2.36 is released now:

http://www.remoterig.com/wp/?page_id=79

Give it a try and see if the USB COM2 works ok now  :)
Always include type of hard/software and version when asking for support.

dj0qn

  • Hero Member
  • *****
  • Posts: 1883
    • View Profile
    • DJ0QN / K7DX
    • Email
Re: Hum Problem with 2.35 and USB COM2
« Reply #7 on: 2011-04-15, 13:00:25 »
Thanks, Jan.

The user will install it this evening, so I can let you know in
a couple of days of use if this problem has been solved.

73,
Mitch DJ0QN / K7DX

hb9edm

  • Jr. Member
  • **
  • Posts: 37
    • View Profile
Re: Hum Problem with 2.35 and USB COM2
« Reply #8 on: 2011-04-17, 13:17:53 »
hello!

On my setup I'm using COM2 to control my rotator.
With "Use USB Com Port as COM2" parameter the COM2 stop working.

fw:
2.36

com2 settings:
com2 mode -> Mode 3, char-timeout
com2 baudrate -> 4800
com2 data bits -> 8
com2 stop bits -> 1
com2 parity -> 0 - off
com2 terminator -> 0d
HB9EDM

Remote setup:
TS480 - Expert 1K - ERC rotator - Heil

Jan (Microbit)

  • Software Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1796
    • View Profile
    • Email
Re: Hum Problem with 2.35 and USB COM2
« Reply #9 on: 2011-04-18, 10:18:52 »
hello!

On my setup I'm using COM2 to control my rotator.
With "Use USB Com Port as COM2" parameter the COM2 stop working.
What dou you mean "COM2 stop working"? Do you mean that COM2 on the RRC stops working when enabling "Use USB Com Port as COM2"? If so then it is how it is supposed to work, the USB Com port "takes over" from the RRC's COM2 port. They can not work in "parallel".
Always include type of hard/software and version when asking for support.

hb9edm

  • Jr. Member
  • **
  • Posts: 37
    • View Profile
Re: Hum Problem with 2.35 and USB COM2
« Reply #10 on: 2011-04-18, 20:00:03 »
Jan!
ehm.... ok, my mistake!

I thought it was possible to use it as an additional COM port for PTT...

HB9EDM

Remote setup:
TS480 - Expert 1K - ERC rotator - Heil

dj0qn

  • Hero Member
  • *****
  • Posts: 1883
    • View Profile
    • DJ0QN / K7DX
    • Email
Re: Hum Problem with 2.35 and USB COM2
« Reply #11 on: 2011-04-18, 20:19:27 »
Jan,

I have a report from the user that the hum problem has NOT happened
again since the update to 2.36. Looks like you may have found the
problem, but of course I will keep you informed if he does have a
problem again.

Thanks again & 73,
Mitch DJ0QN / K7DX

Jan (Microbit)

  • Software Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1796
    • View Profile
    • Email
Re: Hum Problem with 2.35 and USB COM2
« Reply #12 on: 2011-04-18, 20:53:12 »
Jan,

I have a report from the user that the hum problem has NOT happened
again since the update to 2.36. Looks like you may have found the
problem, but of course I will keep you informed if he does have a
problem again.

Thanks again & 73,
Mitch DJ0QN / K7DX
Holding my thumbs!  ;D
Always include type of hard/software and version when asking for support.