Author Topic: Firmware Upgrade Problem.  (Read 3547 times)

VK3OE

  • Jr. Member
  • **
  • Posts: 30
    • View Profile
    • Email
Firmware Upgrade Problem.
« on: 2011-05-03, 08:27:09 »
I have upgraded from V2.33 to V2.37 on both control and remote units.

The audio functionality seems to be better with V2.36 and 2.37.

All runs fine except when the link drops out,... I get a continuous single tone beep and I cannot connect again. I need to restart both units to get connected again.

Revreted back to V2.36 but the same problem is evident.

Please advise.

Andrew
VK3OE

Jan (Microbit)

  • Software Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1800
    • View Profile
    • Email
Re: Firmware Upgrade Problem.
« Reply #1 on: 2011-05-03, 09:07:25 »
And on 2.33 you don't get it?
Always include type of hard/software and version when asking for support.

VK3OE

  • Jr. Member
  • **
  • Posts: 30
    • View Profile
    • Email
Re: Firmware Upgrade Problem.
« Reply #2 on: 2011-05-03, 09:22:32 »
Hello Jan,

Never had the problem on V2.33 !!

A few more details..

When I try to connect, even after a disconnect, I get the repeated 420Hz tone, one on off cycle every 400ms. The remote unit is visible over IP, Info status etc no problem, even when the beep tone is going. I restarted the remote unit and tried to connect but no luck. I restarted the control unit unit and after several tries was able to connect.

Hope that helps Jan.

PS. I should have put this in the RCC 1258 general discussion,not here!!!

Thanks,
Andrew
VK3OE

VK3OE

  • Jr. Member
  • **
  • Posts: 30
    • View Profile
    • Email
Re: Firmware Upgrade Problem.
« Reply #3 on: 2011-05-03, 09:36:18 »
Hello Jan,

In fact to get the connect again, I have to restart both radio and control devices, restarting either alone will not allow a connection again after the beeps start.

Thanks,

Andrew
VK3OE

Jan (Microbit)

  • Software Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1800
    • View Profile
    • Email
Re: Firmware Upgrade Problem.
« Reply #4 on: 2011-05-03, 09:43:33 »
Very strange!

It sounds like you are getting a "busy tone"(beep beep beep) when trying to connect.

Could have understood it better if it would be enough with resetting the radio-RRC.  What does the radio-RRC's status page show when you get the busy tone? (For ex "SIP status")
Always include type of hard/software and version when asking for support.

VK3OE

  • Jr. Member
  • **
  • Posts: 30
    • View Profile
    • Email
Re: Firmware Upgrade Problem.
« Reply #5 on: 2011-05-03, 10:00:12 »
Hello Jan,

When beeps are present....

On the radio unit SIP Status connected/transfering

On the control SIP status idle.

So it looks like when there is a disconnect, the SIP at the radio thinks that it is still going ,,,, maybe??

So, I restart the radio unit and SIP status goes to idle, then try to connect and get beep again, SIP status on control is now unknown (1).

The radio unit SIP status is now at connected/transfering and the beeps are still there.

So, restart both devices, SIP ststus at idle on both.

Connect and all works, connected/transfering on both devices...  So must restart both devices to get SIP status to idle before I can reconnect.

Thanks,
Andrew
VK3OE

Jan (Microbit)

  • Software Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1800
    • View Profile
    • Email
Re: Firmware Upgrade Problem.
« Reply #6 on: 2011-05-03, 10:31:27 »
Thanks for the detailed information! Sadly enough I still don't see how this could be possible. I just re-tried doing this myself, with and without SIP password, and it worked ok. For you it seems the radio-RRC first gets connected and the another connect attempt is made, which then gets "busy" back. Is it possible you could pm or email me info how to connect to your radio-RRC? (Assuming it's on the Internet) It would also be good to be able to Telnet into it.
Always include type of hard/software and version when asking for support.

Jan (Microbit)

  • Software Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1800
    • View Profile
    • Email
Re: Firmware Upgrade Problem.
« Reply #7 on: 2011-05-03, 14:03:29 »
It turned out to be a bug introduced in v2.36 in combination with a unusual behaviour there the control-RRC somehow came to "call" the radio-RRC twice when attempting to connect. v2.38 should fix that if someone else gets "busy" when calling the radio-RRC with the same client(PC or RRC)
Always include type of hard/software and version when asking for support.