Author Topic: Microbit RRC Client - won't connect  (Read 5827 times)

N0ECT

  • Newbie
  • *
  • Posts: 2
    • View Profile
    • Email
Microbit RRC Client - won't connect
« on: 2013-10-12, 20:54:47 »
We have (2) RRC-1258 MkII boxes connected and working from (2) different remote IP Subnets.  It works controlling my Kenwood TS-590, just like the book says.

The remote TS-590 Radio is directly connected to the RRC-1258 at (10.0.3.13)  (COM2)
My PC with the Microbit RRC client refuses to connect to 10.0.3.13

From my PC (that is VPN'd into 10.0.3.0) I can open the browser and look at 10.0.3.13 and review the settings there.
At 10.0.3.13 are:  (I have made my RRC PC client settings match this)
SIP Port:  13000
Web Page:  80
Password:  hello
Audio Port:  13001
Command Port:  13002
Jitter size:  4
Jetter Delay:  3

I have made a 4 page PDF file of my settings and connection failure.
If my client PC can connect via a web browser, why won't my Microbit RRC client?

KB8CR

  • Full Member
  • ***
  • Posts: 104
  • IC-7100 and IC-706 on RRC's
    • View Profile
    • Email
Re: Microbit RRC Client - won't connect
« Reply #1 on: 2013-10-12, 21:32:39 »
You need to make sure that you are port forwarding Ports 13000, 13001, 13002 to the RRC-Radio box.

Charlie KB8CR

N0ECT

  • Newbie
  • *
  • Posts: 2
    • View Profile
    • Email
Re: Microbit RRC Client - won't connect
« Reply #2 on: 2013-10-12, 22:19:39 »
Thanks Charlie.

I connect to the remote network  10.0.3.0  (where the TS-590 is connected to the RRC-1258 (on COM2) via a VPN connection from my Win7 PC.
So once the (PC to LAN) VPN is connected, I'm on the same network (10.0.3.50) as the TS-590 at 10.0.3.13...  My PC and the Radio can "see" each other directly since they're on the same network after the VPN connection is made...

There isn't (as far as I know) any requirement to forward an IP ports - since I"m on the same network.  Yes, my Win7 PC has the windows firewall turned off.

Other ideas?

KB8CR

  • Full Member
  • ***
  • Posts: 104
  • IC-7100 and IC-706 on RRC's
    • View Profile
    • Email
Re: Microbit RRC Client - won't connect
« Reply #3 on: 2013-10-12, 22:37:18 »
I don't use a VPN, and don't know much about them, but are there configurations for it? Port 80 is normally open on all systems, but it might be that ports 13000-13002 aren't making it thru to the box.  Looking at your configuration I don't see any glaring problems.

Charlie KB8CR

KB8CR

  • Full Member
  • ***
  • Posts: 104
  • IC-7100 and IC-706 on RRC's
    • View Profile
    • Email
Re: Microbit RRC Client - won't connect
« Reply #4 on: 2013-10-12, 22:46:50 »
I was just reading on the web about VPN's and port forwarding. I found the following:

  • What sort of VPN are you wanting to use. If it's PPTP then you will need to forward TCP/1723, and Protocol 47 (GRE).
     For IPSEC you will need UDP/500 and Protocol 50 (ESP).

  • You are only forwarding the UDP and TCP protocols. GRE and ESP are protocols, not ports. If the DMZ function assigns a public IP address to your server then it is likely that your router cannot forward these protocols via NAT. Some router cannot forward GRE or ESP protocols

So, it MIGHT be your router. Just a thought.

Charlie KB8CR
[/list]

dj0qn

  • Hero Member
  • *****
  • Posts: 2212
    • View Profile
    • DJ0QN / K7DX
    • Email
Re: Microbit RRC Client - won't connect
« Reply #5 on: 2013-10-13, 01:29:19 »
There is no need to forward ports if you use a VPN.

It is hard to tell from what you sent. I assume that you connected a serial cable
to COM2 of the RRC from the TS-590's CAT port?

This is a requirement to use the PC Client, different from RRC's.

73,
Mitch DJ0QN / K7DX

KQ0C

  • Newbie
  • *
  • Posts: 19
    • View Profile
    • Email
Re: Microbit RRC Client - won't connect
« Reply #6 on: 2013-11-01, 03:26:04 »
We solved this issue... the two 1258 boxes weren't disconnected so they blocked the the micro from establishing a connection.

Net, you need to break the existing connection between two boxes before you can call the radio end box from the micro.