Author Topic: Corrupt Serial number and missing input fields - new Elecraft Twin Control unit  (Read 3068 times)


  • Newbie
  • *
  • Posts: 3
    • View Profile
    • Email
I recently purchased Elecraft Twin units.  I am currently only using the Control unit as I will be accessing a friend's remote K3 (already setup and running by a second friend with a K3/0 mini).
I worked steadily through the Microbit Setup Manager and then began changing parameters in the various screens on the web interface to configure the unit.  I clicked the 'Apply Changes' button after each screen had been submitted with the desired values (I now understand that I need only press 'Apply Changes' once for all the parameter changes).  I believe during one of these Apply Changes actions, that some corruption of the unit may have occurred as the unit now has slow blinking Pwr light and many fields are missing in the web browser interface; example: when I select Keyer Settings on the web interface, I get 'No settings available for this device'.  Same for I/O settings; and Serial Settings is missing some fields. I also note that in the Info screen the serial number is now shown as 4249467295 whereas the box label shows 7981 (and this was correctly shown when I started the configuration process).

Things I've tried:
Restart the unit.  No change in behaviour evident.
Reset the unit.  No change in behaviour evident overall, some fields returned - but not all; serial number remains corrupt.  Moved the USB connection to a second laptop (and loaded Setup Manager on that laptop).  First laptop has Microham virtual ports on it, so wanted to eliminate the possibility that they are not 'playing nice'.  No change in behaviour evident.

Suggestions, please!

RRC Software 2.80
K3/100 radio
Vista Business OS on Lenovo laptop; Firefox browser
Cabling all as delivered and installed per manual for Control unit
WiFi connection (working fine AFAIK) from RRC to ASUS DSL-N55U router
All software and firmware is at latest release status.

David G3WGN  M6O