Author Topic: FT-847 with RRC-1258 MarkII: RS-232-problem  (Read 5686 times)

Klaus

  • Newbie
  • *
  • Posts: 4
    • View Profile
    • Email
FT-847 with RRC-1258 MarkII: RS-232-problem
« on: 2011-02-14, 10:03:45 »
Hi all!

My problem:
I can control my FT-847 from my PC via USB and an USB to serial converter (brand: Manhattan) with "TRX-Manager" and "HamRadioDeluxe".

Closing the chain with the two RRC-1258 I can hear the audio of the FT-847, the LEDīs are o.k. on front and rear but I find no access to control my FT-847.
The above mentioned adapter is connected to COM 2 of the RRC-control unit. Both units are connected via Ethernet. My FT-847 is connected to the radio-RRC via a crossing cable where on FT-side pin 7 and 8 are connected.

Is there anywhere an idea how to find step-by-step where the problem is? I tried all possible combinations from program modes with data speed, CTS, RTS,...
and found no reaction until now.

It could even be that the hardware is not anymore o.k. in the RS-232-data link. But how to find that?

I know there are some happy users with the combination FT-847/RRC-1258
.....  and I would like to become one of those.

Thank you in advance.

73, Klaus, DJ6LE

sm3jgg

  • Newbie
  • *
  • Posts: 23
    • View Profile
    • Email
Re: FT-847 with RRC-1258 MarkII: RS-232-problem
« Reply #1 on: 2011-02-14, 19:36:52 »
It take me some time (many hours) to figur out the rs-232 on the ft-847
here is a short explanation anyway.

The 847 "did not have" a standard rs-232 connection 
pin 2 and 3 are switched on that radio.

So if you have an usb <-> rs-232 cableadapter,
and it works ok, if its used direkt between the computer and the 847

That cable/adapter will not work if you plug it into the rrc system.

You have modifie it (or make an adapter) pin 2 -> 3  and 3 -> 2 between computer and "rrc Control"
and then also att the "rrc radio" side make a cable with  pin 2 -> 3 and 3 -> 2

73 de SM3JGG  Staffan
   

Klaus

  • Newbie
  • *
  • Posts: 4
    • View Profile
    • Email
Re: FT-847 with RRC-1258 MarkII: RS-232-problem
« Reply #2 on: 2011-02-14, 19:59:24 »
Hi, Staffan,

thank you very much for your mail. What you have told is logical and could be the reason for the failing. I will check it to-morrow.
In between I took an old notebook with RS-232-connector integrated >> same result.
To-morrow I will follow your advice, take this notebook again and remove the crossed "null-modem"-cable.

You gave me some hope.

73, Klaus, DJ6LE

Klaus

  • Newbie
  • *
  • Posts: 4
    • View Profile
    • Email
Re: FT-847 with RRC-1258 MarkII: RS-232-problem
« Reply #3 on: 2011-02-24, 17:57:54 »
Hi all,

some more ideas?
The last proposal did not help, RS-232 does not work.

Thanks + regards,

Klaus

sm3jgg

  • Newbie
  • *
  • Posts: 23
    • View Profile
    • Email
Re: FT-847 with RRC-1258 MarkII: RS-232-problem
« Reply #4 on: 2011-02-27, 12:54:01 »
Hello again !


If you use your
"for ft-847 special serial cables" (se earlier post)

then 

Check your "radio settings"

Here are my settings , what works for me and my ft-847....
(I had put my FT-847 to 9600 baud in the menu)

RRC 1258 control....

program mode = 3
control panel = yes
sip password = 
sip contact =
auto connect = No
audio quality = 0
codec out gain = 262
codec imp gain = 18
codec inp PGF Hz = 163
Com0 baudrate = 9600
com0 data bits = 8
com0 stop bits = 2
com0 parity = 0


and here are my settings for
RRC 1258 radio....

program mode = 3
conbtrol panel = 0
sip password =
audio quality = 0
codec out gain = 262
codec inp gain = 0
codec inp HPF Hz = 163
com0 baudrate = 9600
com0 data bits = 8
com0 stop bits = 2
com0 parity = 0

 73 and GL de SM3JGG  Staffan



Klaus

  • Newbie
  • *
  • Posts: 4
    • View Profile
    • Email
Re: FT-847 with RRC-1258 MarkII: RS-232-problem
« Reply #5 on: 2011-03-01, 13:51:44 »
Hi, Staffan,

thank you for your mail and your patience.

By the way (to prevent misunderstanding):
I feed my "Control-box" at COM1 from my PC and I try to control my FT-847 from COM1 of the "Radio-box". Speed: 9600 baud (also on FT-847).
Until now I do not use COM0.

My settings:
1) Control-box:
Program mode: 3 - FT 8x7, FT 1000x
Sip password:
Sip contact: 192.168.123.228
Auto connect: Yes
Audio quality: 2-Linear 16 bits 8 kHz
Codec out gain: 255
Codec inp gain: 16
Codec inp. HPF Hz: 163
Codec inp preamp: No
COM0 baudrate: 9600
COM0 data bits: 8
COM0 stop bits: 2
COM0 parity: 0 - off

2) Radio-box:
Program mode: 3 - FT 8x7, FT-1000x
Sip password:
Audio quality: 2 - Linear 16 bits 8 kHz
Codec out gain: 255
Codec inp gain: 0
Codec inp. HPF Hz: 163
COM0 baudrate: 9600
COM0 data bits: 8
COM0 stop bits: 2
COM0 parity: 0 - off

I think our differing Codec parameters are not important for the control of the FT-847.

I discussed my problem with some hams and they did see a possible cause of my problem within the open definition of the RS-232 connections:
are all 0/+5 volts or are there also +/- levels. I am looking now for an oscilloscope to see what happens within the chain between PC and FT-847.

Thank you again very much and best regards.

Klaus, DJ6LE

M0BPQ

  • Jr. Member
  • **
  • Posts: 50
    • View Profile
    • Email
Re: FT-847 with RRC-1258 MarkII: RS-232-problem
« Reply #6 on: 2011-03-04, 22:23:49 »
I too had problems controlling my FT-847, and the problem was inthe cable construction. I think I put the pins in my engineering notebook so if you are still stuck, drop me a mail steve at mycall dot com and I will dig it out.
73
Steve