Author Topic: CW issue: first characters corrupted, then fine  (Read 398 times)

OE7AFT

  • Newbie
  • *
  • Posts: 7
    • View Profile
CW issue: first characters corrupted, then fine
« on: 2022-01-11, 22:15:38 »
Hi
I have the following issue with my remote TS-480:
when TXing in CW the first 1 or 2 characters are corrupted but then it works fine for the rest of the passage. Next passage, again: first 1 or 2 characters corrupted, then fine.
I am able to test the behaviour only in 80m, where I can RX my own signal on the control site but other OMs on the radio site have confirmed the issue on other bands too.
I would  almost certainly exclude an RFI issue and I would rather say it has to do with some buffer but I have already set buffer size, jitter and delays to the max value almost

I have the following settings:

Control Site (cable connection):
Rx jitter buffer size   16
Rx jitter delay   15
Audio packet size (ms)   40
RTP tx mode   1
....
UDP cmd min-data-size   10
....
Lf delay ms [0-500]   400
Key delay ms [0-250]   200

Radio Site (WiFi connection to fiber router):
Rx jitter buffer size   16
Rx jitter delay   15
Audio packet size (ms)   40
RTP tx mode   1
Disable audio tones   0

The typical ping time is 50ms

Even if annoying, I can still live with this issue in normal QSOs but it is almost impossible to work DX stations or contests.
I haven't been able to find any similar 3D in the forum. Any suggestion?
73 de IZ4AFL


OE7AFT

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: CW issue: first characters corrupted, then fine
« Reply #1 on: 2022-02-14, 10:21:07 »
does anyone have a clue?

I have tried to increase "UDP cmd min-data-size" to 99 but no improvement

sm2o

  • Administrator
  • Hero Member
  • *****
  • Posts: 2856
    • View Profile
    • sm2oan
    • Email
Re: CW issue: first characters corrupted, then fine
« Reply #2 on: 2022-02-14, 23:15:21 »
Hi

packet sizes and jitter bufers are not involved at all in CW-keying

you can try to set PTT activated by keyer =yes in the Radio-RRC

also set Key-delay to minium 50 ms in control-RRC maybe higher

if you have a mobile internet connection they sometimes are slow to setup the data stream then it can work by setting RTP tx mode = continuously in  control-RRC but be aware that data is sent all the time in both direction so the data cost will be x2 if it's not free

73 de mike