RRC-Nano > General

RRC-Nano K


Hi !

I tried the Remoterig RRC-Nano K Android APP long time ago, and worked fine.

Now I tried again in a POCO M4Pro, but when I hit the connect button the app close down.

I'm not sure if the reason can be that I've already used the trial period in the past.... or if this doesn't work on my new phone.

Just before pay the license, how can I request another trial version in order to check if this works for me ?

THANKS !!!!!

EA2TA George


You get a new Trial period when you change to a new phone, and if the trail period has ended it says so in text.

So if it doesn't work with the new phone, don't buy the PRO it will not work either

73 de mike

Hi Mike,

Thanks for reply and info.

I'll try to see if I can rollback to my previous phone.

I tried again in my new phone and now I'm receiving the "App trial period expired" message, so this is at least an step ahead. But how can I try for a new trial period ? in fact the app was installed in this new phone, but never worked.

Is there a way to request a new trial period before purchase the Pro version ?



[0] Message Index

Go to full version