RRC 1258 Support in English > Configuration, RRC 1258

Failed firmware update on 1258

(1/2) > >>

WA2TTP Steve:
I just received the units today and attempted to update the firmware per the manual.

I down loaded and installed Microbit Setup manager V1.9 to my Toshiba laptop running Windows Vista 32 bit.

The manager will connect to the units, via USB, and read there current versions, V2.33.

I down loaded the latest version V2.39, extracted the files to my desk top.

Selected the file on the manager and hit update. (C:\Users\Stevie\Desktop\RRC-1258-CRC_v2.39_2011-05-23.bin) After a few seconds I get the following:
Failed programming new firmware error code 31

I don't think I did anything wrong.


Hi Steve,

do an initial setup of the boxes (at least IP address and subnet mask) via USB so that you can access the boxes via LAN. Then update the firmware via the web interface of the box. There was a bug in the firmware related to updating via USB. It is solved from V2.36 on (see change notes in V2.36).

vy 73
Simon, DJ4MZ

Hi Steve

There must be something unique in your environment. 

I did exactly what you did via USB (no internet configuration done) and it worked just fine.  I was using Windows 7 64 Bit.

So, either your download is corrupt (highly unlikely) or there are issues on your usb buss. 

I know it sounds weird, but try another usb cable and try NOT using it on a Hub (you might have tried this already).

mike va3mw

Jan (Microbit):
As Simon, DJ4MZ said: There was a bug in the firmware related to upgrading the software via USB. In addition to that might be said that it worked in many cases even before the fix in v2.36. It seemed to have something to do with the characteristic of the USB bus in a specific PC.

WA2TTP Steve:
Thank you all for the replies.

I did the update thru the web interface and it worked fine. Now on version 2.39.

I continued to enter the settings for the TS-480 and it to is working fine. Audio both ways sound good, PTT ok.

Next step will be entering the DNYdns host info and see if it works from my son in laws office internet connection.

Thanks for the help.


[0] Message Index

[#] Next page

Go to full version