Author Topic: Nano not working on RRC 2.86 firmware  (Read 2037 times)

iw1rdz

  • Newbie
  • *
  • Posts: 27
    • View Profile
    • Email
Nano not working on RRC 2.86 firmware
« on: 2015-06-12, 15:24:48 »
Hello to all,

I upgraded RRC firmware to 2.86 and after that nano app does not work anymore.

Nano connects to RRC but after few seconds of audio it freezes and the control hangs.

I returned to 2.85 firmware and nano is working again  8).

I'm using Samsung S3 with custom 4.3 Android version and a licensed K nano app that connects to RR-1258 MKII (version 5 HW6 sn 4131) with kenwood TS2000 serial on com2.

Any advice?

Regards, IW1RDZ - Steve


Jan (Microbit)

  • Software Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1796
    • View Profile
    • Email
Re: Nano not working on RRC 2.86 firmware
« Reply #1 on: 2015-06-12, 15:47:04 »
That is the opposite expected outcome when going from 2.85 to 2.86. What does the RRC's status page show when the freezing happens?

Especially these fields are of interest:

Connection status
SIP status
Last SIP error
RTP/UDP audio status
UDP cmd status
Always include type of hard/software and version when asking for support.

iw1rdz

  • Newbie
  • *
  • Posts: 27
    • View Profile
    • Email
Re: Nano not working on RRC 2.86 firmware
« Reply #2 on: 2015-06-12, 17:24:11 »
on 2.85:
Connection status OK
SIP status Connected/transfering
Last SIP error None
RTP status Excellent(60)
UDP cmd status OK(44)

on 2.86 during first few seconds in which I have audio on nano app but it seems neither radio control nor audio volume slide control:
Connection status OK
SIP status Connected/transfering
Last SIP error None
RTP status Excellent(59)
UDP cmd status OK(44)

on 2.86 after a few seconds from connection:
Connection status Disconnected
SIP status Error
Last SIP error SIP Error
RTP/UDP audio status Disconnected
UDP cmd status Disconnected

73, Steve

Jan (Microbit)

  • Software Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1796
    • View Profile
    • Email
Re: Nano not working on RRC 2.86 firmware
« Reply #3 on: 2015-06-13, 07:51:12 »
What you wrote even more seems like the opposite of what to expect, i.e what you see for 2.85 would be for 2.86 and vice versa. I am not able to tell what is going wrong from that information though, is it possible for us to have the information needed to connect to your RRC? If the RRC is behind a firmware/NAT we also would need an additional forwarded TCP port to the RRC for Telnet access. If so then PM/email the information. Since it's weekend now it might not be until Monday that we will be able to have a look at it though.
Always include type of hard/software and version when asking for support.

iw1rdz

  • Newbie
  • *
  • Posts: 27
    • View Profile
    • Email
Re: Nano not working on RRC 2.86 firmware
« Reply #4 on: 2015-06-18, 23:34:56 »
At the moment the connection to my radio RRC is via local wireless network or via DDNS VPN server configured on a radio site raspberry pi if I am outside my local network;  I will try to change configuration to allow you to enter, as soon as possible.
I will send a pm to you, thanks.