Author Topic: Nano not hooking up  (Read 16656 times)

AE5OQ

  • Newbie
  • *
  • Posts: 25
    • View Profile
Nano not hooking up
« on: 2015-03-17, 20:14:37 »
Nano just errors "SIP error: Forbidden (403)" I have gone over all the settings and instructions, but no joy. Oh, by the way why does the Nano ask for "Call Sign" when the RRC1258 doesn't?
Armstead

Jan (Microbit)

  • Software Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1829
    • View Profile
    • Email
Re: Nano not hooking up
« Reply #1 on: 2015-03-17, 22:13:13 »
Which software version does the RRC have?
Always include type of hard/software and version when asking for support.

roland

  • Guest
Re: Nano not hooking up
« Reply #2 on: 2015-03-17, 22:43:01 »
Oh, by the way why does the Nano ask for "Call Sign" when the RRC1258 doesn't?
That's used for licensing

dj0qn

  • Hero Member
  • *****
  • Posts: 2223
    • View Profile
    • DJ0QN / K7DX
    • Email
Re: Nano not hooking up
« Reply #3 on: 2015-03-18, 00:33:56 »
I am having exactly the same error trying to access DL5NAM's RRC using Nano. It
works fine on my systems, but not on his. Chris mailed you directly on this problem,
and I see no difference between his installation and mine.

73,
Mitch DJ0QN / K7DX

Jan (Microbit)

  • Software Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1829
    • View Profile
    • Email
Re: Nano not hooking up
« Reply #4 on: 2015-03-18, 05:37:01 »
I am having exactly the same error trying to access DL5NAM's RRC using Nano. It
works fine on my systems, but not on his. Chris mailed you directly on this problem,
and I see no difference between his installation and mine.

73,
Mitch DJ0QN / K7DX
We are looking at Chris' system right now, and it seems it is a port forwarding issue, though we have not verified that yet.
Always include type of hard/software and version when asking for support.

sm2o

  • Administrator
  • Hero Member
  • *****
  • Posts: 3020
    • View Profile
    • sm2oan
    • Email
Re: Nano not hooking up
« Reply #5 on: 2015-03-18, 08:39:39 »
We found the problem, they where not using the straight port forwarding, so the port numbers shown in the Radio RRC where from the outside forwarded to an other RRC used for a TS-480 with different password.

Conclusion, USE STRAIGHT PORT FORWARDING to avoid confusion.

73 de mike

Jan (Microbit)

  • Software Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1829
    • View Profile
    • Email
Re: Nano not hooking up
« Reply #6 on: 2015-03-18, 08:47:30 »
Nano just errors "SIP error: Forbidden (403)" I have gone over all the settings and instructions, but no joy. Oh, by the way why does the Nano ask for "Call Sign" when the RRC1258 doesn't?
Armstead
PM or email me/us the info needed to connect to your RRC and we will have a look at it.
Always include type of hard/software and version when asking for support.

dj0qn

  • Hero Member
  • *****
  • Posts: 2223
    • View Profile
    • DJ0QN / K7DX
    • Email
Re: Nano not hooking up
« Reply #7 on: 2015-03-18, 10:39:26 »
I assumed that if the control RRC works from the outside ok, then Nano should work as well. That doesn't make much sense to me. Strange.

73,
Mitch DJ0QN / K7DX

Jan (Microbit)

  • Software Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1829
    • View Profile
    • Email
Re: Nano not hooking up
« Reply #8 on: 2015-03-18, 10:48:54 »
I assumed that if the control RRC works from the outside ok, then Nano should work as well. That doesn't make much sense to me. Strange.

73,
Mitch DJ0QN / K7DX
If you are referring to Chris' system then what could be the explanation is that the SIP, audio and command ports were wrong in the Nano app and so Nano tried to connect to wrong RRC.
Always include type of hard/software and version when asking for support.

dj0qn

  • Hero Member
  • *****
  • Posts: 2223
    • View Profile
    • DJ0QN / K7DX
    • Email
Re: Nano not hooking up
« Reply #9 on: 2015-03-18, 10:58:14 »
I was looking at his radio RRC directly for the settings. That could only  be the case if Chris gave me the wrong RRC to look at (he has two).

73,
Mitch DJ0QN / K7DX

AE5OQ

  • Newbie
  • *
  • Posts: 25
    • View Profile
Re: Nano not hooking up
« Reply #10 on: 2015-03-18, 11:14:23 »
Radio RRC firmware is 2.84

Jan (Microbit)

  • Software Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1829
    • View Profile
    • Email
Re: Nano not hooking up
« Reply #11 on: 2015-03-18, 11:17:57 »
I was looking at his radio RRC directly for the settings. That could only  be the case if Chris gave me the wrong RRC to look at (he has two).

73,
Mitch DJ0QN / K7DX
But it seems they are not using "straight port forwarding", so the port numbers visible in the RRC were not the same as the "outside ports".
Always include type of hard/software and version when asking for support.

dj0qn

  • Hero Member
  • *****
  • Posts: 2223
    • View Profile
    • DJ0QN / K7DX
    • Email
Re: Nano not hooking up
« Reply #12 on: 2015-03-18, 11:24:24 »
We are going in circles: it worked fine from Chris' control RRC, so why wouldn't it work from Nano as well? Of course, that is assuming he gave me the correct radio RRC screen shot to use for my test.

73,
Mitch DJ0QN / K7DX

Jan (Microbit)

  • Software Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1829
    • View Profile
    • Email
Re: Nano not hooking up
« Reply #13 on: 2015-03-18, 11:36:45 »
We are going in circles: it worked fine from Chris' control RRC, so why wouldn't it work from Nano as well? Of course, that is assuming he gave me the correct radio RRC screen shot to use for my test.

73,
Mitch DJ0QN / K7DX
No, no circles at all  8) When we first attempted to connect using the Nano App we used ports 13000-13002. That either resulted in not authorized, or busy. Changing password did not work either. Debugging the RRC show that when attempting to connect nothing happened. Then we changed ports in Nano to those they use externally for that RRC and it started to work. So just looking at the radio RRC which ports are in use did not give correct information as the ports used on the Internet side were different.
Always include type of hard/software and version when asking for support.

Jan (Microbit)

  • Software Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1829
    • View Profile
    • Email
Re: Nano not hooking up
« Reply #14 on: 2015-03-18, 11:39:22 »
Radio RRC firmware is 2.84
Sorry for the confusing in this thread!  ;)

I have successfully connected to your radio RRC using the Nano App. You could try restarting your phone since that has fixed such problems before.
Always include type of hard/software and version when asking for support.