Author Topic: RRC Control Unit COM Ports  (Read 2978 times)


  • Jr. Member
  • **
  • Posts: 93
    • View Profile
    • Email
RRC Control Unit COM Ports
« on: 2017-08-14, 20:29:21 »
Hello to the group.

I am wrestling with COM Port related issues for a few days now. It seemed to work fine on Friday but when I reconnected on Saturday morning I could not connect to my contesting (and logging) software. I did not change any settings.

I have tried to get the Control unit to work with my logging and contesting software (DXLAB and N1MM+) without success. I have tried 4 computers. Three  running W10 and one running W7.
I just received a new Surface W10 laptop and thought that I would try to use it as there should be no conflicts with COM ports as it is brand new.

I downloaded the latest version of Microbit Setup manager and loaded it. I am able to find the control unit using the Setup manager.
When I connect the USB mini cable from the Control unit to the Surface and check Device Manager, I do NOT  see the usual RRC COM Ports such as:
RRC1258 COM0 (COMx)
RRC1258 COM1 (COMx)
RRC1258 COM2 (COMx)
RRC1258 COMExtra (COMx)

What I see is 4 COM ports but the naming convention is (see attached screenshot) not correct:

USB Serial Device X
USB Serial Device X
USB Serial Device X
USB Serial Device X

I have the latest version of Setup Manager and have the latest updates for the Surface installed.

Not quite sure what to make of this?

Assistance/guidance would be greatly appreciated.