Author Topic: using virtual COM1 for rotor control  (Read 3989 times)

HL5KY

  • Newbie
  • *
  • Posts: 6
    • View Profile
    • Email
using virtual COM1 for rotor control
« on: 2013-02-14, 01:52:25 »

I've tried to look up this issue on the last thread but no luck.

I am using real COM1 for rotor control and COM2 for CAT. It works fine with following setup.

COM1 (ERC) Mode-3, 9600, 8, 1, 0, cts/rts(no), terminator(00)
COM2 (TS-480) Mode-4, 9600, 8, 1, 0, terminator(00)

When I connect them through the virtual COM ports with "Use USB Com Port as COM(x)" to "Yes", it only works on COM2. COM1 doesn't work.

Setup manager version is 1.17(which might has something to do with driver version).

As using one USB cable is simpler than using two serial calbes, I would like to run them up with virtual COM ports. Does anybody have any idea for this issue?

HL5KY, Joe.

dj4mz

  • Jr. Member
  • **
  • Posts: 97
    • View Profile
Re: using virtual COM1 for rotor control
« Reply #1 on: 2013-04-20, 00:03:20 »
Hi Joe,

I'm not sure if that is the reason but as far as I know the ERC uses 4800Bd not 9600Bd.

vy 73
Simon, DJ4MZ

HL5KY

  • Newbie
  • *
  • Posts: 6
    • View Profile
    • Email
Re: using virtual COM1 for rotor control
« Reply #2 on: 2013-05-22, 03:52:50 »
Simon,

You can change baud rate and other seup with Service tool of ERC.

As I've mentioned, my setup with the physical COM ports works fine. The issue is only with virtual COM ports.

Joe.
« Last Edit: 2013-05-22, 03:55:02 by HL5KY »